[Karmic] QtCurve uses huge fonts instead of KDE fonts

Bug #414711 reported by Sokraates on 2009-08-17
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gtk2-engines-qtcurve (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by josueburgos
Nominated for Lucid by Rafael Belmonte

Bug Description

Using Kubuntu Netbook Remix on an AAO 110. All updates as of 16.08.2009.

QtCurve uses some huge fonts (12pt or bigger, probably DejaVu Sans) instead of the KDE fonts (DejaVu Sans 7pt), as specified under "GTK+ Appearence" in System Settings.

Raleigh however uses the correct fonts when told to "Use my KDE fonts in GTK+ applications.

This bug has been experienced in Firefox 3.5. and network-manager-gnome. I don't use any other GTK+ apps. I have not had such problems with Jaunty and KDE 4.3.

If anyone has an idea where I could to further triage this bug, please tell me.

Sokraates (sokraates) wrote :

Here are some screenshots. First, this is how Arora looks.

Sokraates (sokraates) wrote :

Now Firefox with QtCurve.

Sokraates (sokraates) wrote :

Firefox with Raleigh.

Sokraates (sokraates) wrote :

network-manager-gnome with QtCurve.

Sokraates (sokraates) wrote :

Finally network-manager-gnome with Raleigh.

Sokraates (sokraates) on 2009-09-09
summary: - [KNR] QtCurve uses huge fonts instead of KDE fonts
+ [Karmic] QtCurve uses huge fonts instead of KDE fonts
Sokraates (sokraates) wrote :

Here is the workaround provided by sam81 in the duplicate. I have tested it today (09.09.2009) with the latest updates and it still works (while the bug itself is still there):

"The problem disappeared after I modified the KDE font settings.
My KDE font was Deja Vu Sans 8, when I changed it to Bitstream Vera Sans 8, GTK apps with Qtcurve had the correct font within KDE. Then I changed the font back to Deja Vu Sans 8 and still GTK apps with Qtcurve use the correct font."

My font size was 7 instead of 8, but the important part seems to be the font type.

arky (arky) on 2009-09-09
affects: ubuntu → kde-style-qtcurve (Ubuntu)
noisymime (josh-noisymime) wrote :

Just to assist others who may have this problem, I had to change the KDE 'General' font for this work. I was initially changing the 'Menu' font but this did not solve the problem.

Andy Barilla (andybarilla) wrote :

The workaround works for me as well as of 2009-09-30. The difference is this missing section from ~/.kde/share/config/kdeglobals:

[General]
XftHintStyle=hintmedium
font=DejaVu Sans,8.-1,5,50,0,0,0,0,0

Andrew's workaround works here on Karmic Beta.

I added the 'font' parameter and adjusted it on 'System Settings' general font to right size and GTK+ apps are working fine with the right font integration.

Gustavo A. Díaz (gdiaz) wrote :

The workaround fixed for me too adding:

font=DejaVu Sans,8,-1,5,50,0,0,0,0,0

Etienne Perot (etienneperot) wrote :

Confirming bug and confirming workaround here.

Particlese (particlese) wrote :

The GUI-based fix (changing and reverting the "General" font in systemsettings) worked for me, too, but I didn't check kdeglobals beforehand to confirm the text-based fix.

memartin (memartin) wrote :

Confirming both the bug and the workaround.

I'm seeing a very washed-out font though. Tried setting hinting to from "hintfull" to "hintmedium", but no real help. See attached screenshot.

memartin (memartin) wrote :

Update: the washed out font thing was gone after restart. Sorry I didn't test that.

molecule-eye (niburu1) wrote :

Sokraates' workaround worked for me in Karmic, changing DejaVu sans to Bitstream charter and back to DejaVu sans again.

Tsvi Mostovicz (tsvi) wrote :

Workaround worked for me as well according to Gustavio and Andrews note

Felix Geyer (debfx) on 2010-09-29
affects: kde-style-qtcurve (Ubuntu) → gtk2-engines-qtcurve (Ubuntu)
Felix Geyer (debfx) wrote :

Is this still an issue on maverick?

Changed in gtk2-engines-qtcurve (Ubuntu):
status: New → Incomplete
Felix Geyer (debfx) wrote :

Keeping the bug open as QtCurve should parse the settings from kubuntu-default-settings (and kubuntu-netbook-default-settings).

Changed in gtk2-engines-qtcurve (Ubuntu):
status: Incomplete → Confirmed

It's not anymore an issue in Maverick, qtcurve parses the settings from k-d-s

Changed in gtk2-engines-qtcurve (Ubuntu):
milestone: none → ubuntu-10.10
Changed in gtk2-engines-qtcurve (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers