thunderbird and firefox freeze at random : must be killed and restarted

Bug #963736 reported by A. Broustet on 2012-03-24
212
This bug affects 41 people
Affects Status Importance Assigned to Milestone
gtk2-engines-oxygen (Ubuntu)
Undecided
Rohan Garg
Raring
Undecided
Unassigned
Saucy
Undecided
Rohan Garg

Bug Description

[Impact]
Thunderbird freezes at random. I must kill it then reload it.
Sometimes the freeze happens when sending a mail. I had no problem in 11.10.

It happens several times a day. The only pattern that I can currently see is that the freeze happens frequently when thunderbird is using the network.

[Test Case]
* Install update
* Run Firefox/Thunderbird for a day
* Make sure it does not freeze

[Regression Potential]
* Minimal
* Upstream release for gtk2-engines-oxygen is only a bug fix release

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ dpkg-query -s thunderbird
Package: thunderbird
Status: install ok installed
Priority: optional
Section: mail
Installed-Size: 45256
Maintainer: Ubuntu Mozilla Team <email address hidden>
Architecture: amd64
Version: 11.0+build1-0ubuntu1
[...]

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/963736/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

add package affected by the bug

affects: ubuntu → thunderbird (Ubuntu)
A. Broustet (ubuntu-amael) wrote :

please note that the "choose" package is not able to find thunderbird : "too many package".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2013-02-10
tags: added: amd64 kubuntu raring
Paul White (paulw2u) wrote :

I'm seeing this frequently on both a desktop and a laptop running Kubuntu 13.04 (Alpha 1) with KDE 4.10.00. Thunderbird version is currently 17.0.2.

This seems to happen after leaving Thunderbird running in the background for several hours checking mail but not otherwise using the program. Whether the freeze occurs when Thunderbird is checking mail I can't say but the freeze has happened frequently enough for me to search for and add to existing bug reports.

Udo Schuermann (udo-schuermann) wrote :

I've noticed today that Dolphin refused to open a window for folders when I double clicked on the desktop icons. It just sat there, and sure enough both Firefox and Thunderbird were both frozen dead. As soon as I killed FF and TB, another double click on the folder icons responded instantly.

Might there be a lock (or lock process) involved that hangs and affects more than just FF and TB?

That said, I've seen Firefox and Thunderbird hang independently of the other (one was fine while the other was hung), but I find the observed behavior worth mentioning.

(Kubuntu Raring Ringtail, amd64, nvidia 310 (experimental) driver)

Paul White (paulw2u) wrote :

I'm seeing this problem a lot less now.

KDE is now at version 4.10.1, Firefox 19.0.2 and Thunderbird 17.0.4 but both Firefox and Thunderbird seem to freeze at the same time. No other applications seem to be affected here.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Petr Sedlacek (petr-sedlacek) wrote :

I'm also experiencing issue described by Paul White - both Firefox and Thunderbird freeze at the same time, no other application is affected. I'm also on Kubuntu Raring.

Mikael Gerdin (mgerdin) wrote :

I believe this is actually a bug in the Oxygen GTK engine.
Attached is some gdb output I took from a hung thunderbird.

It looks like Oxygen-gtk2 is spawning a new glib main loop when it's running "kde4-config --path config"

While writing this exact comment I got the exact same hang in Firefox.

Mikael Gerdin (mgerdin) wrote :

I just found 1142213, which looks like the issue that I saw in the GDB output.
This bug may or may not be a duplicate of 1142213 but the freezes I've experienced are most ceratainly due to 1142213.

David J. Wallace (katana-p) wrote :

I'm affected by this. Fresh installation of Kubuntu 13.04 64 bit. Thunderbird and FIrefox randomly hang, often after an idle period. Have tried changing theme to see if the oxygen-gtk theme may be the issue as suggested. This would seem to have solved the issue.

May be unrelated, but if thunderbird or firefox is launched from the command line they throw a critical glibc error:

(process:3400): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

New to this - what can I do to help?

Mark (mapk) wrote :

Same for me, everything ran great until I upgrade to Raring from 12.x

Firefox 20.0, Thunderbird 17.0.5

The only thing I recall about upgrading is that new nVidia drivers were install during the upgrade.

I was not using Oxygen GTK theme, I was using the Air Black Remix for Window Decorations and Glassified for desktop theme.

Switched both anyway to see if that helps.

Mark (mapk) wrote :

I've switch themes a few times - still happening regardless of desktop theme.

Larry Tate (cathect) wrote :

I can confirm David Wallace's assertion that this seems to happen after the computer wakes from idle.

The first email I try to send at that point freezes my machine for approximately 1.5 minutes. Then the email goes through and my system is back. It seems that it is actually going through the window animation in extreme slow motion...

Ian Brock (brock-physik) wrote :

I see the same effect with Kubuntu 13.04 64 bit. Clean install.
Thundrbird 17.0.5
Firefox 20.0
Desktop theme is Oxygen

The hang also seems to happen when Thunderbird and Firefox have been idle for a while. I do not see any such problems with other applications.

Mark (mapk) wrote :

Ok more tests. With the Oxygen theme I get the lockups. When I switch GTK-2 to Raleigh and GTK-3 to Emacs the lockups go away. But I'm stuck using themes that are, uh, just a bit too 1990's for my tastes - LOL.

Paul White (paulw2u) wrote :

I'm removing the duplicate status of this bug.

This bug is about Firefox and Thunderbird freezing after starting successfully.

Bug #1142213 is about GTK applications including Emacs not starting at all for which as fix has been found

Petr Sedlacek (petr-sedlacek) wrote :

FWIW, I haven't seen one of these freezes since I switched gtk2 theme from oxygen-gtk to Oxygen-Molecule-Flat. Normally I would experience at least one freeze every two days (usually more often).

I have now patched gtk2-engines-oxygen 1.3.3 with the changes mentioned in the Emacs bug report: https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/1142213 - the changes don't seem to be relevant to the issue we are experiencing here but let's see if the newest version of gtk2-engines-oxygen helps.

Rogi (rogi) wrote :

I can always reproduce this problem with taking a screen shot of Firefox (maximized) in Kubuntu (default KSnapshot) and after saving Firefox hangs. Switching to Raleigh and Emacs GTK themes solves this.

Mark (mapk) wrote :

Ok more tests. With the Oxygen theme I get the lockups. When I switch GTK-2 to Raleigh and GTK-3 to Emacs the lockups go away. But I'm stuck using themes that are, uh, just a bit too 1990's for my tastes - LOL. Emacs theme reminds us of Windows 3.0.... what a horrific memory !

Paul White (paulw2u) on 2013-05-15
summary: - thunderbird freezes at random : must be killed and reload
+ thunderbird and firefox freeze at random : must be killed and restarted
Mark (mapk) wrote :

I saw some Kubuntu updates come through last night one of which was related to kde-style-oxygen in some form or fashion. Installed all the available updates for Raring and this freezing issue with Firefox and Thunderbird still occurs with GTK oxygen in use. Does not happen with Chrome browser though.

Pacific Seascape (seascape) wrote :

I am affected by this as well. I use Firefox and Thunderbird extensively so this is a really serious problem. I thought I'd wait a few weeks before upgrading to Raring in the hopes that bugs like this would have been squelched. That plan worked out well...

Petr Sedlacek (petr-sedlacek) wrote :

Just an update to my comment #19 (a week ago) - I haven't experienced any of these freezes since I upgraded gtk2-engines-oxygen to version 1.3.3 with the patches mentioned in the Emacs bug report: https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/1142213. The patches might not be relevant so it's possible that the latest upstream version fixes the freezes.

I can provide amd64 package if there's interest.

Torsten Römer (dode) wrote :

Petr, I'd be interested in your amd64 package. FF and TB both are nearly unusable, I'd be very happy for a solution!

Petr Sedlacek (petr-sedlacek) wrote :

For anyone who would like to try the up-to date patched gtk2-engines-oxygen package, here it is:
https://dl.dropboxusercontent.com/u/50609214/gtk2-engines-oxygen_1.3.3-1ubuntu1-patched_amd64.deb
Please let us know your experience!

ronwilhoite (ronwilhoite) wrote :

Thank you Petr! No freezes in Thunderbird or Firefox since installing your deb. It has only been a few hours, but I would have already had at least one in that time before the update.

Does somebody have the 1.3.3 package for 32-bit system?

Petr Sedlacek (petr-sedlacek) wrote :

Glad to hear the new version helped.

I do not have an i386 raring vm to build the deb but here is a quick guide how to do it yourself:
# install debian build tools - not sure I didn't miss any
sudo apt-get install dpkg-dev debhelper
# install build dependencies
sudo apt-get build-dep gtk2-engines-oxygen
# get the source (version 1.3.1)
apt-get source gtk2-engines-oxygen
cd gtk2-engines-oxygen-1.3.1
# update the source to 1.3.3
wget http://launchpadlibrarian.net/139674367/gtk2-engines-oxygen_1.3.1-0ubuntu1_1.3.3-1ubuntu1.diff.gz -q -O- | gzip -dc | patch -p1
# patch the source - these are the changesets from oxygen-gtk git - see https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/1142213
wget https://dl.dropboxusercontent.com/u/50609214/oxygen-gtk-1-popen-changeset_r51b662b0cd86fd7a960cc2f0c436441d64b2dd44.diff | patch -p1
wget https://dl.dropboxusercontent.com/u/50609214/oxygen-gtk-2-changeset_r592490ea8d7dcd328b755cbb28b9be205d68168f.diff | patch - p1
wget https://dl.dropboxusercontent.com/u/50609214/oxygen-gtk-3-changeset_r878b0e626311cdf847e00dfd6ff96184021c1667.diff | patch -p1
# build the package
dpkg-buildpackage -b -us -uc -j2

Torsten Römer (dode) wrote :

Thanks also from me Petr, no freeze the whole day so far, while there was 5-20 each day before.

I'm glad we have a stable system again :-)

Pacific Seascape (seascape) wrote :

Just installed Petr's .deb package on my Kubuntu 13.04 installation. Wow, what a difference. Not seeing any freezes (fingers crossed!) and Thunderbird and Firefox both seem *much* more responsive - the UI slowness appears to be gone. What a relief. Thank you so much, Petr!

I built and tried 32bit version of gtk2-engines-oxygen_1.3.3 according to the Peter's instructions. Unfortunately it didn't solve the problem...

Andreas Tetzner (a-tetzner) wrote :

Petr's packages also worked for me, no freezes since installing them.

David J. Wallace (katana-p) wrote :

Yes - Petr's deb fixes the problem here. Thank you Petr.

Does somebody wants to test 32bit version of gtk2-engines-oxygen_1.3.3? It didn't fix the problem for me. I can provide the .deb for anybody who wants to test it.

Leonid: can you link the 32-bit .deb?

Thanks Leonid, for you it's still freezing?
Is only gtk2-engines-oxygen affected or also gtk3-engines-oxygen?

Gavin Sharpe (gavin77) wrote :

I've been using the patched package from comment #26 for the past 48+ hours and haven't had any crashes or lockups. It seems to have fixed it here.

Starbuck, unfortunately both Firefox and Thunderbird is still freezing on my 32bit Kubuntu. I didn't anything with gtk3-engines-oxygen. Neither Firefox nor Thunderbird use it.

Lars Bungum (s-lars) wrote :

I have been experiencing this since my last upgrade of a 64 bit problem.

$ lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

Rohan Garg (rohangarg) on 2013-05-31
affects: firefox (Ubuntu) → gtk2-engines-oxygen (Ubuntu)
Changed in gtk2-engines-oxygen (Ubuntu):
assignee: nobody → Rohan Garg (rohangarg)
Ruslan (b7-10110111) wrote :

Unfortunately, the fixes are not yet released. They can be accessed in latest git oxygen-gtk. For the record, here're the relevant commits:
http://commits.kde.org/oxygen-gtk/51b662b0cd86fd7a960cc2f0c436441d64b2dd44 for oxygen-gtk3
http://commits.kde.org/oxygen-gtk/a515ab451f54cbc930d0a09d250669255dd8a741 for oxygen-gtk2

Rohan Garg (rohangarg) wrote :

Both gtk2 and gtk3 fixed in Saucy. WIP to get both SRU'd for Raring.

no longer affects: thunderbird (Ubuntu)
no longer affects: thunderbird (Ubuntu Saucy)
no longer affects: thunderbird (Ubuntu Raring)
Changed in gtk2-engines-oxygen (Ubuntu Saucy):
status: Confirmed → Fix Committed
Rohan Garg (rohangarg) on 2013-05-31
description: updated
Changed in gtk2-engines-oxygen (Ubuntu Raring):
status: New → Incomplete
status: Incomplete → In Progress
description: updated

Hello A., or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk2-engines-oxygen (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Rohan Garg (rohangarg) wrote :

@Ruslan for gtk3 do I also need f272b269cd26e783ffb811c4a3584a675fac7a2b and a8b7085a657bd7f27978c3a2765310758382e60d ? Or will 5e22bbf8bf09663f2be9cd7510a956fc5ad4faba suffice ?

Ruslan (b7-10110111) wrote :

@Rohan
5e22bbf8bf09663f2be9cd7510a956fc5ad4faba is the core of the fix. The two follow-up patches are minor improvements on it. They are not required to have this work.

Also, if all goes as planned, oxygen-gtk{2,3} with this fix is expected to be released today.

Lupe Christoph (lupe) wrote :

Verified OK with gtk2-engines-oxygen_1.3.3-2ubuntu0.1_amd64.deb, emacs23 now starts. emacs24 will need a patched gtk3 package. emacs-snapshot is still OK.

Gavin Sharpe (gavin77) wrote :

gtk2-engines-oxygen:amd64 1.3.3-2ubuntu0.1
All working as it should be here, no problems with this version.

Rohan Garg (rohangarg) on 2013-06-01
tags: added: verification-done
removed: amd64 verification-needed
Rohan Garg (rohangarg) wrote :

@Ruslan thanks for the release, I'll just get oxygen-gtk3 1.1.4 SRU'd for Raring then.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk2-engines-oxygen - 1.3.3-2ubuntu0.1

---------------
gtk2-engines-oxygen (1.3.3-2ubuntu0.1) raring-proposed; urgency=low

  * No change backport to Raring (LP: #963736)

gtk2-engines-oxygen (1.3.3-2ubuntu1) saucy; urgency=low

  * Merge with debian, remaining changes:
    - Fix dh_shlibdeps to exclude libgtk2.0-0 from Depends

gtk2-engines-oxygen (1.3.3-2) unstable; urgency=low

  * Team upload.
  * Add popen-instead-of-g_spawn_command_line_sync.patch
    from upstream (Closes: #707699).

gtk2-engines-oxygen (1.3.3-1ubuntu1) saucy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Fix dh_shlibdeps to exclude libgtk2.0-0 from Depends

gtk2-engines-oxygen (1.3.3-1) unstable; urgency=low

  * Team upload.
  * New upstream release.
  * Refresh dont-build-demos.patch.
  * Bumped Standards-Version to 3.9.4, no changes needed.
 -- Rohan Garg <email address hidden> Fri, 31 May 2013 15:28:56 +0530

Changed in gtk2-engines-oxygen (Ubuntu Raring):
status: Fix Committed → Fix Released
Paul White (paulw2u) wrote :

Just cleaning up, clearly this bug has been fixed so marking as such.

Changed in gtk2-engines-oxygen (Ubuntu):
status: Fix Committed → Fix Released
Changed in gtk2-engines-oxygen (Ubuntu Saucy):
status: Fix Committed → Fix Released

Am getting something similar to this bug but I am on trusty and gtk2-engines-oxygen is not installed. Am using awesomevm as a window manager and here are the gtk-engines installed :

# dpkg -l gtk2-engines*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=============================-===================-===================-===============================================================
ii gtk2-engines-murrine:amd64 0.98.2-0ubuntu2 amd64 cairo-based gtk+-2.0 theme engine
ii gtk2-engines-pixbuf:amd64 2.24.23-0ubuntu1.1 amd64 pixbuf-based theme for GTK+ 2.x
ii gtk2-engines-xfce 3.0.1-2 amd64 GTK+-2.0 theme engine for Xfce

Paul White (paulw2u) wrote :

Arthur, this bug has been marked as "Fixed Released" and no-one has added anything to the bug report since June last year.

If you still have a problem or are experiencing a similar problem please submit a new bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers