Ubuntu

Murrine configuration option "gradients" is no longer supported and will be ignored

Reported by David Henningsson on 2010-02-07
100
This bug affects 18 people
Affects Status Importance Assigned to Milestone
human-netbook-theme
Undecided
Kenneth Wimer
gtk2-engines-murrine (Ubuntu)
Medium
Unassigned
human-theme (Ubuntu)
Low
Kenneth Wimer

Bug Description

Binary package hint: human-theme

After the latest lucid upgrades, I suddenly get this message everytime I startup a GUI program from the terminal:

/usr/share/themes/Human/gtk-2.0/gtkrc:85: Murrine configuration option "gradients" is no longer supported and will be ignored.

Somewhat annoying...

ProblemType: Bug
Architecture: amd64
Date: Sun Feb 7 10:35:58 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091209)
Package: human-theme 0.37
PackageArchitecture: all
ProcEnviron:
 LANG=sv_SE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: human-theme
Uname: Linux 2.6.32-11-generic x86_64

David Henningsson (diwic) wrote :
Vish (vish) wrote :

I can confirm this error in _all_ themes[human, dark room ,dust , dust sand] which use the Ubuntu murrine engine.

I'm opening the murrine task , since folks using the git version of murrine claim that they are not facing this error. [also, I cant find any reference in the git changelogs of this option being dropped]

@David, in the mean time , you can comment out that line. Seems the theme works even without that line

Changed in gtk2-engines-murrine (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Vish (vish) wrote :

Hmm , another member using git version [in Ubuntu] mentions the same error with the git murrine too.

Marking as incomplete for now. [Will confirm with Cimi.]

Changed in gtk2-engines-murrine (Ubuntu):
status: Confirmed → Incomplete

I experience it too. On karmic with the git version

On Feb 7, 2010 10:00 PM, "Vish" <email address hidden> wrote:

Hmm , another member using git version [in Ubuntu] mentions the same
error with the git murrine too.

Marking as incomplete for now. [Will confirm with Cimi.]

** Changed in: gtk2-engines-murrine (Ubuntu)
      Status: Confirmed => Incomplete

--
Murrine configuration option "gradients" is no longer supported and will be
ignored
https://bug...
Status in “gtk2-engines-murrine” package in Ubuntu: Incomplete

Status in “human-theme” package in Ubuntu: New

Bug description:
Binary package hint: human-theme

A...

Andrea Cimitan (cimi) wrote :

Yeah, is gonna be deprecated, you can remove it from the Human gtkrc

Vish (vish) on 2010-02-08
Changed in human-theme (Ubuntu):
assignee: nobody → Vish (vish...)
importance: Undecided → Low
status: New → In Progress
Changed in gtk2-engines-murrine (Ubuntu):
status: Incomplete → Invalid
Jean-Damien Bouvier (jdbouvier) wrote :

I've modified the display settings and now I get some weird colors and the same error message in my .xsession-errors file.
I had this error with 9.04 and now with 10.04 alpha.
I don't know how to get rid of this so I've deleted all my hidden files and directories (.something) to get back to normal colors.

Jean-Damien Bouvier (jdbouvier) wrote :

Doing it again, I found that it's the .dmrc file that put those weird colors.

<code>
[Desktop]
Session=gnome
Language=fr_FR.utf8
Layout=fr oss

</code>

I've got an AMD64 with Radeon HD 5750. My CRT monitor and graphic card are not supported nor detected.

Vish (vish) wrote :

Kenneth is updating the theme as well , this change will also be uploaded at the same time

Changed in human-theme (Ubuntu):
assignee: Vish (vish...) → Kenneth Wimer (kwwii)
Kenneth Wimer (kwwii) wrote :

Yes, we are working on an update (which includes other changes)

Kenneth Wimer (kwwii) on 2010-02-09
Changed in human-netbook-theme:
assignee: nobody → Kenneth Wimer (kwwii)
NicoInattendu (nico-inattendu) wrote :

I have the same problem with luciole.
Who generates the waning almost 100 times. And so it takes a while to start ( 1 min)

Whats is fun is if i run luciole directly from the source , i.e. without installing it happens just 3 times. With the installed inversion ( make install) it happens 100 times or more.

Kenneth Wimer (kwwii) on 2010-02-10
Changed in human-theme (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package human-theme - 0.38

---------------
human-theme (0.38) lucid; urgency=low

  * merging from vish's changes to fix LP: #518325
  * Changed humanlogin theme selected bg and fg colors per design team
    instructions

  [ K.Vishnoo Charan Reddy ]
  * Dropping "gradients" murrine style option in DarkRoom and Human theme,
    to fix LP: #518325
  * Changed link color in DarkRoom , to fix LP: #507632
  * Switching DarkRoom theme to use Humanity-Dark icon theme instead of Humanty
    icon theme , to fix LP: #495644
 -- Kenneth Wimer <email address hidden> Wed, 10 Feb 2010 14:50:36 +0100

Changed in human-theme (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Vish (vish) wrote :

human-netbook-theme (0.16) lucid; urgency=low

  * Dropping "gradients" style option , to fix LP: #518325

Changed in human-netbook-theme:
status: New → Fix Released
David Henningsson (diwic) wrote :

Confirming it is fixed. Thanks and keep up the good work!

papukaija (papukaija) wrote :

This bug *is not* fixed. I'm getting this error message in Lucid alpha 3 with the netbook-remix edition.

Vish (vish) wrote :

@papukaija: iirc, the netbook theme in Lucid is Dust theme. It needs to be fixed as well. Kindly file a separate bug for for Dust theme.

papukaija (papukaija) wrote :

@Vish: The Dust theme is provided by gnome-themes-ubuntu, do I open a new bug for it?

vish: are we going to open new bugs for every theme? It is also present in Albatross used in xubuntu.

James Schriver (dashua) wrote :

Dust had already been updated upstream in the 0.5 series. I'll prepare a merge proposal for gnome-themes-ubuntu later today with the updated version. Albatross is done and committed upstream, but we're testing various configuration options via murrine.

Vish (vish) wrote :

@Charlie Kravetz : well , _every_ theme that uses murrine is going to have this error.
So this would become a meta bug for all and folks would just get mails/progress about themes they have no interest about...
Also the themes mentioned here are fixed , so it seemed no point tagging more bugs to a closed report... ;)

Well , that was just my thought , since the artwork team mailing list is subscribed here...

dannymichel (xcingix) on 2010-04-22
Changed in gtk2-engines-murrine (Ubuntu):
status: Invalid → Confirmed
Vish (vish) wrote :

As already mentioned , Not a bug in Murrine

Changed in gtk2-engines-murrine (Ubuntu):
status: Confirmed → Invalid
Changed in gtk2-engines-murrine (Ubuntu):
status: Invalid → Fix Released
papukaija (papukaija) wrote :

This bug for this package as marked invalid between comment 5 and 6 as a result of comment 5. Please comment your change. Therefore I set this part of bug back to invalid.

Changed in gtk2-engines-murrine (Ubuntu):
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers