Human Theme needs some changes for murrine 0.9x

Bug #345410 reported by David Prieto on 2009-03-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Murrine
Invalid
Medium
human-theme
Undecided
Unassigned
gtk2-engines-murrine (Ubuntu)
Medium
Robert Ancell
human-theme (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gtk2-engines-murrine

I use Jaunty and I have noticed something weird when using the murrine themes since murrine was updated to 0.90: selected elements no longer have a dotted line but a "rubber band" resembling clearlooks'.

The weird part is, only the bottom part of the band is visible. Please see the attached screenshot.

From what I've read in Andrean Cimitan's blog the engine draws it like that by design:

># Tobias said:
>18 March, 2009 alle 20:42
>
>Cimi, is it supposed to look like that, i.e., only a dark blue line on the bottom?
># Cimi said:
>18 March, 2009 alle 20:45
>
>A line and a small colored rectangle above

URL to the blog post: http://www.cimitan.com/blog/2009/03/18/murrine-0901-and-happy-gnome-2260/

Cheers.

Ara Pulido (ara) wrote :

I also experience the same.

It looks particularly bad with scale widgets. See attached screenshots.

Ara Pulido (ara) wrote :
Changed in gtk2-engines-murrine:
status: New → Confirmed
Ara Pulido (ara) wrote :

From the upstream bug:

"This is not a bug.
Murrine now can parse trough-side-details Gtk+ option to draw the side details.

Please add
GtkScale::trough-side-details = 1

in the gtkrc of the theme (look at Clearlooks theme, it already adds it)
"

Changed in gtk2-engines-murrine:
status: Confirmed → Invalid
Changed in murrine:
status: Unknown → New

I added GtkScale::trough-side-details = 1 to human-theme's gtkrc file, and there seems to be no difference.

Kenneth Wimer (kwwii) wrote :

the fix suggested doesn't seem to work for me, taking a closer look

Changed in human-theme:
assignee: nobody → kwwii
Andrea Cimitan (cimi) wrote :

Please notice that in the volume applet it won't work because it was set to disabled in the application :)

Try with totem or the widget factory

Kenneth Wimer (kwwii) wrote :

I think there is some confusion about this bug. Cimi, did you look at the screenshot which shows the problem? Adding GtkScale::trough-side-details = 1 didn't help on any themes using murrine.

Andrea Cimitan (cimi) wrote :

Oh LOL!
I haven't read the bug description, I thought you were arguing about the lack of the filled color inside the scale trough!

That's the focus hint, it will change in the future, maybe a 0.90.3 release

Changed in murrine:
status: New → Unknown
Changed in murrine:
status: Unknown → New
Kenneth Wimer (kwwii) wrote :

So there is no way to fix the look of this for Jaunty?

Andrea Cimitan (cimi) wrote :

wait 0.90.3?
the patch is simple, I could release it in the next days... even if I'm a bit busy

Kenneth Wimer (kwwii) wrote :

The latest svn snapshot fixes this, thanks Andrea! Someone should build a package :-)

Ara Pulido (ara) wrote :

This should land in Jaunty, as it breaks the default theme in Ubuntu.

Changed in gtk2-engines-murrine (Ubuntu):
assignee: nobody → canonical-desktop-team
importance: Undecided → Medium
milestone: none → ubuntu-9.04
status: Invalid → Triaged

0.90.3 is released, providing the requested fixes.

Glad to see it fixed. I have noticed something else and I'm not sure if I should file a new bug about it, but I guess this bug's title is generic enough to do it here. Progress bars (think the one in Totem, or the volume control) no longer show one side coloured like they used to.

I guess this should be fixed too.

Andrea Cimitan (cimi) wrote :

That's quite easy to fix, someone just needs to add
GtkScale::trough-side-details = 1

in the Human gtkrc

Robert - could you please ensure that these changes are in well before final freeze?

Changed in gtk2-engines-murrine (Ubuntu):
assignee: canonical-desktop-team → robert-ancell

I have also noticed that when yoy click on certain elements they get the rubber band around them, BESIDES the typical colour of selected items. This does not happen if you select them through the keyboard, and looks especially weird in places like pidgin's buddy list.

Andrea Cimitan (cimi) wrote :

Did you read my comment?
I said I have fixed it in release 0.90.3.

Sorry Andrea, I figured you meant the version in the repos.

Robert Ancell (robert-ancell) wrote :

Confirmed fixed.

gtk2-engines-murrine (0.90.3-1) unstable; urgency=low

  * New upstream release.
  * debian/control:
    - add build-dep on intltool.
  * Cleanup the source git folder of spurious build files and thus build
    schema.xml. closes: #520515

 -- Yves-Alexis Perez <email address hidden> Sat, 04 Apr 2009 15:36:12 +0200

Changed in gtk2-engines-murrine (Ubuntu):
status: Triaged → Fix Released
Ara Pulido (ara) wrote :

The needed fix in murrine is already in Jaunty. Kenneth, please update now the theme with the required changes. Thanks.

Changed in human-theme:
status: New → Confirmed
Kenneth Wimer (kwwii) wrote :
Changed in human-theme:
assignee: kwwii → ubuntu-main-sponsors
status: Confirmed → Fix Committed
Ara Pulido (ara) wrote :

This was already fixed in Jaunty's package. If it does not apply for a SRU, it should be applied to the package in Karmic, at least.

Changed in human-theme (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Changed in human-theme:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package human-theme - 0.28.8ubuntu1

---------------
human-theme (0.28.8ubuntu1) karmic; urgency=low

  * Setting trough-side-details in Human gtkrc to 1 to fix LP: #345410

 -- Kenneth Wimer <email address hidden> Tue, 21 Apr 2009 15:46:55 +0200

Changed in human-theme (Ubuntu):
status: Fix Committed → Fix Released

Hi,
I bought a TV last week from a website:www.hkeles.com. I have
received the product. The quality is very good. They also sell
phones,motor,psp and so on. Because of the financial crisis, their
products are very cheap. by the way, they only sell new and original
products .If you need these products, you can have a look . I think
you will get many benefits.
Greetings!

tags: added: iso-testing
Changed in murrine:
status: New → Invalid
Changed in murrine:
importance: Unknown → Medium
Curtis Hovey (sinzui) on 2012-05-29
Changed in human-theme:
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.