VNC not working consistently with 9.10

Bug #465914 reported by coloradoz on 2009-10-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gtk-vnc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntuone-client

with 9.04, with remote desktop enabled, I was able to solidly perform VNC connect from windows xp (realvnc) to Ubuntu machine by machine name.

Machine Configuration

Workgroup = workgroup, both Win XP and Ubuntu configured on same workgroup.
VNC Client = Win XP running RealVNC
VNC Host = Ubuntu 9.x, configured with Remote Desktop
Allow other users to view = True
Allow other users to control = True
Security is unchecked on all options
Notification = Only display icon when someone is connected.

With 9.04
a) Can access from Win XP by IP address AND Ubuntu machine name without any issues.

After 9.10 upgrade, Ubuntu VNC is not working consistently.
a) Can still access from Win XP by IP address, however
b) Access via machine name no longer possible after cold boot
c) It appears that VNC announce or network announce not working on cold boot.

Upon reboot, it appears that VNC announce works and can access Ubuntu machine by name - however after trying this all day, I can't say that the aforementioned is the conclusive condition to repeat the error.

ProblemType: Bug
.home.derya..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.derya..config.ubuntuone.syncdaemon.conf:
 [bandwidth_throttling]
 on = True
 read_limit = -1
 write_limit = -1
.home.derya..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 connected = True
 connect = 0
 show_applet = 0
 bookmarked = True
Architecture: i386
Date: Fri Oct 30 19:39:01 2009
DistroRelease: Ubuntu 9.10
Package: ubuntuone-client 1.0.2-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:1673): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1770): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1797): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1769): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

coloradoz (ajsenol) wrote :
Matt Griffin (mattgriffin) wrote :

Hi - I don't think Ubuntu One is the cause of this bug.

affects: ubuntuone-client (Ubuntu) → gtk-vnc (Ubuntu)
coloradoz (ajsenol) wrote :

Update - Not sure that this is a vnc server issue either because I can perform vnc connect using just the IP address in the cold boot scenario. I did however notice that the Ubuntu machine does not show up on the Windows network until I reboot - when I reboot, the Ubuntu machine shows up in the network neighborhood and I can then do a vnc connect by machine name. This maybe an smb issue of some kind.

SkorMT (skormt) wrote :

I find a couple things going on actually

Since moving up to 9.10 -- the server never seems to restart itself after crashing.

Control - C or even just using right click and copying most of the times causes the server to crash ending the session.

I use both TightVNC -- off an XP machine remotely..

and REALVNC on my network, and both seem to be able to make the server go away. Would gladly post logs if I knew where to look.

It has gotten very frustrating, more so the server not restarting more so than the control C's making crash, cause that seems to have been around even before 9.10.. but now I can't re-login

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers