Cannot send any key with AltGr

Bug #212013 reported by Alexander Bürger on 2008-04-04
64
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Vinagre: VNC client for GNOME
Fix Released
Medium
Nominated for Trunk by adso58
gtk-vnc (Debian)
Fix Released
Unknown
gtk-vnc (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: vinagre

Using vinagre, I do not manage to send any character that is normally produced with AltGr on a german keyboard. Some of them ({[]}\@| on 7890ßq<) are essential, and any VNC client that cannot send them is therefore quite useless to me, and probably to others, too.

IMHO this is a serious bug which should either be fixed before hardy release, or vinagre should be replaced by some other program (like, e.g., vnc4viewer, which can send all keys and has a much better manual).

=========================
hardy (development branch) 8.04
vinagre version 0.5.0-1
libgtk-vnc-1.0-0 version 0.3.4-0ubuntu1

ProblemType: Bug
Architecture: i386
Date: Sat Apr 5 00:34:29 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: fglrx
Package: vinagre 0.5.0-1
PackageArchitecture: i386
SourcePackage: vinagre
Uname: Linux 2.6.24-14-generic i686

Alexander Bürger (acfb) wrote :
Dustin (dustinh) wrote :

I can confirm this bug.

hardy (development branch) 8.04
vinagre version 0.5.0-1
libgtk-vnc-1.0-0 version 0.3.4-0ubuntu1

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.04
Package: vinagre 0.5.0-1
PackageArchitecture: i386
SourcePackage: vinagre
Uname: Linux 2.6.24-15-generic i686

Emilio Pozuelo Monfort (pochu) wrote :

This is likely a gtk-vnc issue... Jonh?

Changed in vinagre:
status: New → Confirmed
Jonh Wendell (wendell) wrote :

I'll work on this for 2.24.

Changed in vinagre:
status: Confirmed → Triaged

Commenting out a part of the key handling in gtk-vnc/src/vncdisplay.c cures the AltGr problem for me.

As I have only one keyboard, a german one, some test should be made to confirm that this does not break anything.

Maybe the key handling function needs a review (can it be shortened?) if there is no breakage.

Changed in vinagre:
status: Unknown → New
Changed in vinagre:
status: New → Incomplete
Changed in vinagre:
status: Unknown → New
Changed in vinagre:
status: New → Confirmed

I think this should be fixed in Intrepid, could anybody check it?

Changed in vinagre:
importance: Undecided → Medium
status: Triaged → Incomplete

@Emilio

On Intrepid fully updated/upgraded... (client Intrepid connecting to server Intrepid)

Still no fixed Alt Gr + @ on remote pc i get an "ò"

Alt Gr is still not sent to remote server by client.

Today i get a vino server upgrade...

Using krdc on Intrepid using Alt Gr + @ works fine...

Hope this helps

Eero (eero+launchpad) wrote :

ALtGr is still broken (Finnish keyboard)

Changed in vinagre:
status: Incomplete → Confirmed
Changed in vinagre:
status: Incomplete → Fix Released
Maks Zbogar (maks-zlat) wrote :

Ubuntu Intrepid Ibex with Vinagre 2.24.1 and Logitech MX5000 keyboard with slovenian keyboard layout:

- No AltGr character is passed to host computer with Windows XP and Real VNC server installed
- NumPad with NumLock on in Ubuntu works ok, using Vinagre, host behaves as if NumLock is off

If possible, please fix, as Vinagre is on the other hand best VNC I have ever used.

Ubuntu 8.10 Intrepid Ibex with Vinagre 2.24.1 and Apple Pro Keyboard with Swedish keyboard layout:

 - No AltGr is passed to 2 different host computers, both running RealVNC Xvnc 4.1.1
 - NumPad with NumLock on in Ubuntu works ok, using Vinagre, host behaves as if NumLock is off
 - Pressing Ctrl-D to try and terminate a session results in a "Make bookmark" dialog instead of being sent to host. After dialog is closed Ctrl-C has to be pressed before control of the host is regained - otherwise all keyboard input is ignored or faulty.
I also second Maks opinion above of Vinagre!

Pavel Rojtberg (rojtberg) wrote :

this is fixed in the Jaunty version of Vinagre

Emilio Pozuelo Monfort (pochu) wrote :

Thanks, marking as fixed.

Changed in vinagre:
status: Confirmed → Fix Released
Maks Zbogar (maks-zlat) wrote :

Sorry for stupid question?
Should I upgrade to Jaunty? or is there a way to install new version of Vinagre only?

Maks Zbogar wrote:
> Sorry for stupid question?
> Should I upgrade to Jaunty? or is there a way to install new version of Vinagre only?

Jaunty is not stable yet. Anyway, this bug is in gtk-vnc. If I have time, I'll
see if we can backport the fix to Intrepid.

Maks Zbogar (maks-zlat) wrote :

Sorry again, I am really new to linux world...
I have installed: http://packages.ubuntu.com/jaunty/amd64/vinagre/download (Vinagre 2.24.2) and I still have exactly same problems ("ALT Gr" + "v" = "v", but i expect to be like this: "ALT Gr" + "v" = "@")
NumPad keys are arrows and not numbers, so I have to use xtightvncviewer for now, but I would really prefere Vinagre.

Maks Zbogar (maks-zlat) wrote :

Oh now I see it is not about Vinagre package, but gtk-vnc. I am really sorry to bother again.
Does it mean I will have to reinstall libgtk-vnc-1.0-0 package (after upgrade will be available) ?
Thank you again.

Emilio Pozuelo Monfort (pochu) wrote :

Maks Zbogar wrote:
> Oh now I see it is not about Vinagre package, but gtk-vnc. I am really sorry to bother again.
> Does it mean I will have to reinstall libgtk-vnc-1.0-0 package (after upgrade will be available) ?
> Thank you again.

If I can backport the fix, the update will show in the Update Manager as usual
updates do. If I can't, you will have to either wait for Jaunty, or request a
backport (see https://help.ubuntu.com/community/UbuntuBackports).

Emilio Pozuelo Monfort (pochu) wrote :

The attached patch is upstream gtk-vnc commit 247, which fixes this bug.

I've prepared gtk-vnc packages for Intrepid in my PPA: <https://launchpad.net/~pochu/+archive>.
If you test the packages and they work fine, I'll consider proposing an SRU for this.

Note that I haven't tested those packages myself.

If there's interest I can also look at backporting the fix to Hardy, although I'm not sure that will be possible (I'd have to check).

Enjoy!

Downloaded and tested... on a remote conn to Jaunty...

For me is working...

Thank you

Uwe Geuder (ubuntulp-ugeuder) wrote :

Thanks Emilio!

libgtk-vnc-1.0-0 version 0.3.7-0ubuntu2.1 from the PPA tested with the following setup

local machine (vinagre): Intrepid, Finnish keyboard
remote machine (vino): Hardy, Finnish keyboard

when using Emacs on the remote machine: All AltGr combinations work: @ £ $ { [ ] } \ € ~ |

However, when using Windows XP in Vmware Workstation in the remote machine, AltGr combinations don't work. AltGr
doesn't seem to be received, the "unaltered" characters are produced.

Of course there now 2 closed source products involved and it would be easy to blame them. However, what I don't understand is: Vmware is externally nothing else but an X Windows client, isn't it? This X Windows client can handle the input from the physical Finnish keyboard correctly. Shouldn't the input from vino be exactly the same? So the inner layers of closed source software shouldn't be able to tell the difference and should have no chance to screw anything up.

Any advice how to debug this is welcome.

Emilio Pozuelo Monfort (pochu) wrote :

Uwe Geuder wrote:
> Any advice how to debug this is welcome.

Try investigating the output for vinagre --gtk-vnc-debug both with the client
that works and the one that doesn't.

Uwe Geuder (ubuntulp-ugeuder) wrote :

One update: The problem can also be reproduced with Xubuntu 8.04 instead of Windows XP.

Emilio wrote:

> both with the client that works and the one that doesn't.

Hmm, when you say client do you refer to the vnc client (vinagre) on my machine 1 or the X clients on my machine 2?

There are too many clients here and maybe my configuration can be understood the easiest way be looking at the attached diagram.

I have the old vnc client (well actually it's the old library libgtk-vnc-1.0-0 version 0.3.7-0ubuntu2) and it does not work with any X client. (That's what this bug is all about.) It does not produce any debugging information about keycodes when starting it using the command vinagre --gtk-vnc-debug. (maybe the library needs to be built with an certain flag turned on???)

Next I have the new vnc client (well actually it's the new library libgtk-vnc-1.0-0 version 0.3.7-0ubuntu2.1) and it works with most X clients on the remote machine, but not with all. However, the debugging info from vinagre --gtk-vnc-debug, is always the same, regardless which X client on the remote machine has focus.

debugging info looks like this:

press keycode: 108 state: 0 group 0, keyval: 65027
press keycode: 20 state: 128 group 0, keyval: 92
release keycode: 20 state: 128 group 0, keyval: 92
release keycode: 108 state: 128 group 0, keyval: 65027

(Pressing AltGr, pressing the plus sign, which has the backslash in the AltGr position and releasing them in the opposite order)

I guess the vnc client side there is no knowledge about who has focus on the vnc server side. Key presses are just blindly transmitted from the vnc client to the vnc server.

But coming back to your question:

> Try investigating the output for vinagre --gtk-vnc-debug both with the client
> that works and the one that doesn't.

I could not do this, because
- only the new vnc client produced debugging output and
- the debugging output is the same for both X clients where AltGr works and X clients where AltGr doesn't work.

So I'm actually inclined to believe that your fix is valid for the vnc client side problem. (But there must be another bug somewhere in vino, the X server, or vmware running on my machine 2.)

Just to exclude any doubts: As mentioned erlier AltGr *does* work correctly for all clients on machine 2 when typing on the physical keyboard of machine 2.

Changed in vinagre:
importance: Unknown → Medium
Changed in gtk-vnc (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.