numeric keypad doesn't work inside KVM VM

Bug #209398 reported by Jan Claeys on 2008-03-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk-vnc (Ubuntu)
Medium
Anthony Liguori
kvm (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kvm

The number keys on the numeric keypad portion of my keyboard don't work inside a VM (using kvm / libvirt/ virt-manager). The other keys ("/", "*", etc.) work, so I guess something doesn't work with passing through Num Lock keypresses to the VM...

I'm using an up-to-date hardy install.

Changed in kvm:
assignee: nobody → anthony-codemonkey
Jan Claeys (janc) wrote :

Extra note: it's the NumLock key that doesn't seem to work (the numeric keys behave as if NumLock isn't on, pressing NumLock repeatedly doesn't help).

Jayson Rowe (jayson.rowe) wrote :

Just wanted to note that I can duplicate this in multiple VM's and multiple guest OSes.

Dustin Kirkland  (kirkland) wrote :

I'm marking 'Confirmed', as I can reproduce this in an up-to-date Intrepid system.

:-Dustin

Changed in kvm:
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

Actually, let me refine my last statement...

I was able to reproduce this problem when running the latest Ubuntu Intrepid install media in a KVM.

However, once I finished the installation and booted into the installed target, Num-lock and the number keys worked exactly as I expected.

Could the other commenters on this bug please:
 1) Specify whether they saw this behavior in the installation, or in an installed system
 2) Note whether they can reproduce this problem on Intrepid hosts and/or virtual machines.

:-Dustin

TRiSS (triss) wrote :

I can confirm this issue on an installed xp sp3, that's in gutsy though - not intrepid

TRiSS (triss) wrote :

my comment above is partly wrong: the numpad doesn't work on the xp logon screen, but once logged in it does work.

Confirmed, numlock does not work in winxp pro using intrepid as host.

Ok, go to start/programs/accesories/accessability/onscreen keyboard.
Turn numlock on

Also you can do this in your windows registry

HKEY CURRENT USER\Control Panel\Keyboard\InitialKeyboardIndicators

0 = numberlock off
2 = numberlock on

If you want the numlock on at the Welcome Screen you also need to change:

HKEY USERS\.DEFAULT\Control Panel\Keyboard\InitialKeyboardIndicators (same number values as above).

Daniel T Chen (crimsun) on 2008-12-07
Changed in kvm:
importance: Undecided → Low
Dustin Kirkland  (kirkland) wrote :

I'm marking this bug 'confirmed' against gtk-vnc, and importance medium. It's assigned to Anthony Liguori, who can fix this upstream. He has a handled on the issue, which involves correctly using hueristics to correctly understand toggle keypresses such as these, when they are directed at a guest vm, versus the host.

I'm marking this 'invalid' against KVM, as the issue must be solved at the gtk-vnc layer.

Thanks for the report!

:-Dustin

Changed in gtk-vnc:
importance: Undecided → Medium
status: New → Confirmed
Changed in kvm:
status: Confirmed → Invalid
ahannah12 (alondra-hannah) wrote :

well press shift-clear

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers