Ubuntu

Startup of gtk-recordmydesktop fails with "TrayPopupMenu instance has no attribute 'popupmenu_continueitem'" error

Reported by Thomas-Karl Pietrowski on 2010-08-03
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gtk-recordmydesktop
Undecided
Unassigned
gtk-recordmydesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gtk-recordmydesktop

Happens when starting recordmydesktop-gtk..
Here is the console output:

~$ gtk-recordMyDesktop
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
/usr/lib/pymodules/python2.6/recordMyDesktop/rmdMonitor.py:10: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
  import popen2
/usr/lib/pymodules/python2.6/recordMyDesktop/rmdSelectThumb.py:79: GtkWarning: IA__gdk_image_put_pixel: assertion `y >= 0 && y < image->height' failed
  im2.put_pixel(k/stride,i/stride,im1.get_pixel(k,i))
Traceback (most recent call last):
  File "/usr/bin/gtk-recordMyDesktop", line 43, in <module>
    main()
  File "/usr/bin/gtk-recordMyDesktop", line 40, in main
    tr=rmdSimple.simpleWidget()
  File "/usr/lib/pymodules/python2.6/recordMyDesktop/rmdSimple.py", line 514, in __init__
    self.trayIcon=trayIcon(self)
  File "/usr/lib/pymodules/python2.6/recordMyDesktop/rmdTrayIcon.py", line 394, in __init__
    self.tray_popup=iTP.TrayPopupMenu(self.parent,self.parent.values,self.optionsOpen)
  File "/usr/lib/pymodules/python2.6/recordMyDesktop/rmdTrayPopup.py", line 51, in __init__
    self.popupmenu_continueitem.hide()
AttributeError: TrayPopupMenu instance has no attribute 'popupmenu_continueitem'

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gtk-recordmydesktop 0.3.8-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Aug 3 10:28:31 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100130)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gtk-recordmydesktop

mollitz (mollitz) wrote :

Solution is to install python-appindicator.
A short look at the mentioned file tells that an import-exception for appindicator leads to set a variable to False. Due to this value the init-process of the class does not initialize all class-members so the member popupmenu_continueitem does not exist.
So add python-appindicator to dependencies and it will work

I had the same bug. The solution mollitz mentions also solved the problem. python-appindicator should be added to the list of dependencies.

hey all

same error here... installed python-appindicator and problem solved...
as above comments inform, add python-appindicator to dependencies...

kind regards
thomi

Lekensteyn (lekensteyn) wrote :

Confirmed, installing python-appindicator did indeed fix this. It should be a dependency.

Changed in gtk-recordmydesktop (Ubuntu):
status: New → Confirmed
summary: - Error at application startup of recordmydesktop-gtk
+ Startup of gtk-recordmydesktop fails with "TrayPopupMenu instance has no
+ attribute 'popupmenu_continueitem'" error
Lekensteyn (lekensteyn) wrote :

After further investigation, installing python-appindicator is just a workaround.
rmdTrayPopup.py is missing a check, whether indicator support is enabled or not.

tags: added: patch
Lekensteyn (lekensteyn) wrote :

The last patch I supplied provided a patch which can be used for understanding the bug. This patch can replace the one in debian/patches/add_indicator.patch. (tested & confirmed to work)

Daniel Holbach (dholbach) wrote :

Thanks a lot for your work on this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk-recordmydesktop - 0.3.8-3ubuntu2

---------------
gtk-recordmydesktop (0.3.8-3ubuntu2) natty; urgency=low

  * debian/patches/add_indicator.patch: updated patch by Lekensteyn.
  * debian/control: add python-appindicator dependency. (LP: #612885)
 -- Daniel Holbach <email address hidden> Thu, 10 Mar 2011 11:00:41 +0100

Changed in gtk-recordmydesktop (Ubuntu):
status: Confirmed → Fix Released
Lekensteyn (lekensteyn) wrote :

Please do not add `python-appindicator` as dependency. For some reason, the tray and tray menu icons are missing if I've it installed on Kubuntu 10.10 Maverick Meerkat 64 bits. Just using the provided patch is fine.

As the appindicator feature is not necessary and could break things, please make it a "suggests" or "recommends" instead of a dependency. Will this fix be added to Maverick?

Daniel Holbach (dholbach) wrote :

I just uploaded this change:
 gtk-recordmydesktop (0.3.8-3ubuntu5) natty; urgency=low
 .
   * debian/control: moved python-appindicator from Depends to Recommends to
     avoid dragging in the whole stack on other Ubuntu flavours.

To get it into maverick, please follow https://wiki.ubuntu.com/StableReleaseUpdates

Changed in gtk-recordmydesktop:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers