Ubuntu

gtk-recordmydesktop 'select window' does not include gnome panel

Reported by Anxious Nut on 2010-04-06
188
This bug affects 26 people
Affects Status Importance Assigned to Milestone
gtk-recordmydesktop (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gtk-recordmydesktop

Description: Ubuntu lucid (development branch)
Release: 10.04

  Installed: 0.3.8-1ubuntu1
  Candidate: 0.3.8-1ubuntu1
  Version table:
 *** 0.3.8-1ubuntu1 0
        500 http://kw.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

i tried to use the "select window" feature to select gnome panel, but this bug report appeared instead telling that it crashed

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: gtk-recordmydesktop 0.3.8-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: wl
Architecture: i386
CheckboxSubmission: 7eab32825001a108bd1ac6e3faaeb3eb
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Tue Apr 6 12:42:55 2010
ExecutablePath: /usr/bin/gtk-recordMyDesktop
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386 (20100318)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gtk-recordMyDesktop
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gtk-recordMyDesktop']
SourcePackage: gtk-recordmydesktop
Title: gtk-recordMyDesktop crashed with UnboundLocalError in __select_window__()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/pymodules/python2.6/recordMyDesktop/rmdSimple.py", line 250, in __select_window__
     if wid: xwininfo_com = ['xwininfo','-id',wid]
 UnboundLocalError: local variable 'wid' referenced before assignment
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Anxious Nut (anxiousnut) wrote :
description: updated
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
Mitch Towner (kermiac) wrote :

set to public as the automatic retracer has made this the "master" bug report & there is no private &/or sensitive information in the report.

visibility: private → public
Changed in gtk-recordmydesktop (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Daniel Mueller (dtmuller) wrote :

This seems to be caused by the call of xprop which says '_NET_FRAME_WINDOW: no such atom on any window.' The attached patch should solve this.

tags: added: patch
Didier Roche (didrocks) wrote :

Hey Daniel! Thanks a lot for your patch there. Seems to works well here modifying debian/patches/compiz.patch with your patch.
I'm sponsoring it in ubuntu. Can you also please post that upstream (the whole debian/patches/compiz.patch would make sense in fact) so that everyone benefits of your work? (website is http://recordmydesktop.sourceforge.net)

Thanks again :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk-recordmydesktop - 0.3.8-3ubuntu3

---------------
gtk-recordmydesktop (0.3.8-3ubuntu3) natty; urgency=low

  * Fix gtk-recordmydesktop 'select window' does not including gnome panel
    in debian/patches/compiz (LP: #556345)
    Thanks to Anxious Nut for the patch.
  * debian/patches/selectwindow.patch:
    - refresh for previous change
 -- Didier Roche <email address hidden> Fri, 11 Mar 2011 11:05:41 +0100

Changed in gtk-recordmydesktop (Ubuntu):
status: Confirmed → Fix Released
Sergey Glita (s-v-glita) wrote :

Still affect me in lucid. In synaptc i see only 0.3.8-1ubuntu-1 version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers