Recording cause system to slow down with ATI Graphics

Bug #509111 reported by Antonio Roberts on 2010-01-18
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
fglrx
Confirmed
Unknown
gtk-recordmydesktop
Undecided
Unassigned
recordmydesktop
Undecided
Unassigned
gtk-recordmydesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gtk-recordmydesktop

When I start recording my computer starts slowing down quite a lot. I've set the frame rate to 10 and even 5 frames per second, don't have Compiz effects enabled and still it's going sloppy. My computer stats are Dell Studio 1555: Pentium Dual Core T4300(2.1GHz,800MHz,1MB), 4096MB 800MHz DDR2 Dual Channel, 512 MB ATI Mobility RADEON HD 4570 and I'm using Ubuntu 9.10

Mitch Towner (kermiac) wrote :

I am also seeing this issue on a laptop with ATI graphics. Whenever recordmydesktop or gtk-recordmydesktop starts recording, xorg uses 100% cpu. This is still an issue in a fully updated lucid install.

Changed in gtk-recordmydesktop (Ubuntu):
status: New → Confirmed
Robert Martinez (mail-mray) wrote :

I also had the same issue (on karmic) - and it was completely gone after uninstaling the ATI drivers.
This is a major bug.

Changed in fglrx:
status: Unknown → Confirmed
TommyBoy (thomaslloyd) wrote :

Same here Radeon 2600 HD on desktop. Latest ATI driver from amd.com. Using updated Lucid.

tags: added: apport-collected

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
Package: gtk-recordmydesktop 0.3.8-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Tags: lucid
Uname: Linux 2.6.32-17-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev nopasswdlogin plugdev sambashare tape video

apport information

summary: - Recording cause system to slow down
+ Recording cause system to slow down with ATI Graphics
Thomas O. (thomas-tgohome) wrote :

This also affects me. With radeonhd driver, it works perfectly, I get almost 20 fps on screen recording, but then my GPU overheats eventually because radeonhd doesn't seem to switch on any kind of power saving (GPU hit 95°C, then it decided to shut down.)

Daniel Castro (castromd) wrote :

For me it's a bit worst. As soon as I start gtk-recordmydesktop everything freezes. I can move the mouse but nothing responds. The only way is to go to a terminal (either ctrl+alt+1 or from another computer throught ssh) and kill recordmydesktop.
I do have an ATI video card. I wonder is it the same issue.

Since ubuntu 10.04, and with the native given Ati driver (without
downloading any other driver) , this problem has diseappered. Now i can
record with gtk-recordmydesktop without any problem .. Thanks ubuntu !
-----
Saber OMRI
Enseignant TIC
Al Manhal Geek
Sabily designer team
Supporter ubuntu & edubuntu

2010/5/20 Daniel Castro <email address hidden>

> For me it's a bit worst. As soon as I start gtk-recordmydesktop everything
> freezes. I can move the mouse but nothing responds. The only way is to go to
> a terminal (either ctrl+alt+1 or from another computer throught ssh) and
> kill recordmydesktop.
> I do have an ATI video card. I wonder is it the same issue.
>
> --
> Recording cause system to slow down with ATI Graphics
> https://bugs.launchpad.net/bugs/509111
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in gtk-recordmydesktop: New
> Status in recordmydesktop: New
> Status in “gtk-recordmydesktop” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gtk-recordmydesktop
>
> When I start recording my computer starts slowing down quite a lot. I've
> set the frame rate to 10 and even 5 frames per second, don't have Compiz
> effects enabled and still it's going sloppy. My computer stats are Dell
> Studio 1555: Pentium Dual Core T4300(2.1GHz,800MHz,1MB), 4096MB 800MHz DDR2
> Dual Channel, 512 MB ATI Mobility RADEON HD 4570 and I'm using Ubuntu 9.10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/509111/+subscribe
>

Antonio Roberts (hellocatfood) wrote :

@Saber OMRI

The problem being reported is that *with* the driver (which is essential for some to use) the problem occurs

Daniel Castro (castromd) wrote :

Yes because without drivers there's no desktop effects (compiz) and I for one can't live without.

David JB (sk-random) wrote :

Having what seems like the same issue. Using the proprietary ATI drivers, just *running* gtk-recordmydesktop (it starts recording straight away for me) causes Xorg to hit 100% CPU and stay there until I kill it. Running Ubuntu 10.04.

David Ordenes D. (radioboy-2) wrote :

Same problem here, using fglrx 8.723.1.
If I uninstall the driver, recordmydesktop no longer hangs, and I can record at 25 fps, 100% quality plus audio.
With driver, gtk-recordmydesktop just freezes.

Antonio Roberts (hellocatfood) wrote :

I'm using the latest graphics driver as downloaded from the ati website (10.6) (http://support.amd.com/us/gpudownload/Pages/index.aspx) and compiz 0.8.6 from their ppa (https://launchpad.net/~compiz/+archive/ppa) and, when using gtk-recordmydesktop it now works perfectly.

I'm not sure if it is compiz or the newer graphics driver that is causing it to work. Can anyone else verify this?

David JB (sk-random) wrote :

@Antonio Roberts,

I just upgraded by graphics driver to 10.6 (using an ATI Radeon HD 2400 XT) and now it's working perfectly. I uninstalled the existing FireGL drivers, dumped my existing Xorg.conf and let the control centre do its thing during installation. No changes required to Compiz here -- just using the version provided with Lucid Lynx.

Now, recordmydesktop is perfect. Haven't tested it with audio as well, but video is 100%.

Daniel Castro (castromd) wrote :

YES!!!

gtk-recordmydesktop is also fixed for me!!!

I have a Thinkpad W500 with ATI Mobility Radeon HD 3650 and running Ubuntu 9.10. Before 10.5 I had to apply this patch https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/568988 and gtk-recordmydesktop would freeze my entire X session.

When 10.6 drivers came out I removed the xserver patch, I let synaptic install whatever version it's the supported one and then installed 10.6 by creating the deb packages from command line.

Antonio Roberts (hellocatfood) wrote :

@RockDJ any audio problems with gtk-recordmydesktop are usually blamed on the sound card or options in other programs. Sound is working here.

I'm having problems with full screen recording thouhg. Getting artifacts like these http://www.flickr.com/photos/hellocatfood/4769723866/ Also on the fly recording is dropping lots of frames. I suspect the latter could be problems with the software

Otherwise, glad this is finally fixed!

Mitch Towner (kermiac) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gtk-recordmydesktop (Ubuntu):
status: Confirmed → Invalid
Alex R (0k-ahux-f8) wrote :

I do all my recordings with the aid of an ancient pc that has a poor ati xpres1250 graphic card. I've done a lot of recordings with recordmydesktop both on ubuntu & fedora and i must say it's the best (of course there is also ffmpeg).

!!! Avoid "Encode on the FLY" !!!

Here is one of my latest tutorials, about RecordMydesktop, hope it works for you too :

http://itassistant.org/os-usage/os-tweaks/linux-os-tweaks/recordmydesktop-fedora-15-video-tutorial.html

Changed in recordmydesktop:
status: New → In Progress
Changed in gtk-recordmydesktop:
status: New → Fix Released
Changed in recordmydesktop:
status: In Progress → Fix Released
Changed in gtk-recordmydesktop (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.