gtk-recordMyDesktop hangs after a recording session

Bug #336878 reported by Jean-Paul Calderone on 2009-03-02
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
recordmydesktop
Undecided
Unassigned
gtk-recordmydesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gtk-recordmydesktop

Description: Ubuntu 8.04.2
Release: 8.04

gtk-recordmydesktop:
  Installed: 0.3.6-1
  Candidate: 0.3.6-1

After recording a session with gtk-recordMyDesktop, a dialog pops up claiming that encoding is in process and that closing the window or canceling will discard the record of the session. The dialog includes a progress bar which never advances. My current configuration for gtk-recordMyDesktop is to encode on the fly, and the session *is* recorded to an ogg file in my home directory, but gtk-recordMyDesktop doesn't seem to realize this and instead scares me by acting broken and claiming it is going to destroy my data.

My gtk-recordmydata configuration file (written automatically, I haven't edited it) is attached.

Jean-Paul Calderone (exarkun) wrote :
Nick Sarten (gen-battle) wrote :

I'm getting this bug with gtk-recordmydesktop in Ubuntu 9.10 Karmic. The program gets to the encoding step of the process and then hangs. Given that it works fine on my 9.04 machine, i think the problem may be related to this bug on sourceforge: http://sourceforge.net/tracker/?func=detail&aid=2888673&group_id=172357&atid=861428

It basically says that recordmydesktop is not compatible with "the new libtheora", which could have been added to 9.10.

Donald (donsmouse) wrote :

i am also getting the same thing,im using it on ubuntu 9.10 64 bit,the sound device is High Definition 8-channel audio

    * ALC 888S chipset

This is an hp pavilion m9500f with 8 gigs of ram

Predrag (martincom) wrote :

Its same in Ubuntu 10.04 :(

Sergiu BADAN (sergiu-badan) wrote :

I get absolutely the same result on ubuntu 10.10.
After stopping recording, recordmydesktop process seems to hang:
sb@linux:~$ sudo strace -p 13962
Process 13962 attached - interrupt to quit
futex(0xb27b4bd8, FUTEX_WAIT, 13964, NULL) = ? ERESTARTSYS (To be restarted)
--- SIGTERM (Terminated) @ 0 (0) ---
sigreturn() = ? (mask now [])
futex(0xb27b4bd8, FUTEX_WAIT, 13964, NULL) = 0
write(2, "Shutting down.", 14) = 14
write(2, ".", 1) = 1
futex(0xb17b2bd8, FUTEX_WAIT, 13966, NULL

Only killall -9 recordmydesktop solves that. It's rather recordmydesktop issue than gtk-recordmydesktop.

It was working some weeks ago.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk-recordmydesktop (Ubuntu):
status: New → Confirmed
joshyg6 (josheg) wrote :

 Did this get solved ever? Still happening at times..

Daryl Tucker (daryltucker) wrote :

I still experience this every time I use it (14.04).

Any suggestions? Any alternatives?

David Jameson (nospam19) wrote :

It's a bug in rmd_capture_sound.c. Just add "&& (pdata->running)" to the while loops on lines 111 and 146 of the latest code (0.3.8.1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.