gtk applications are crashing in kde

Bug #287601 reported by TentacleGuy on 2008-10-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk-kde4 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by TentacleGuy

Bug Description

For every GTK-Application I try to start a BadName error is triggered:

philipp@philipp-desktop:~$ firefox
FoxyProxy settingsDir = /home/philipp/.mozilla/firefox/33ynf63p.default
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 806 error_code 15 request_code 45 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
philipp@philipp-desktop:~$ gimp
The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 1699 error_code 15 request_code 45 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:16539): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
philipp@philipp-desktop:~$

It doesn't change if I switch the GTK-Style to QTCurve in System Settings

TentacleGuy (neuhaus-dodekatex) wrote :

philipp@philipp-desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid
philipp@philipp-desktop:~$

TentacleGuy (neuhaus-dodekatex) wrote :

Sry, but this bug is still present.

If you upgrade inteprid to 'stable', many of changers may get this problem...

Arodd (soilflames) wrote :

I've attached a dpkg --list as well as an strace output.

Damien Mascord (dmascord) wrote :

Hi,

This bug is fixed in the following patch https://bugzilla.redhat.com/attachment.cgi?id=313661, the same should be applied in Ubuntu/Debian and hopefully eventually fixed upstream.

Cheers,

Damien

TentacleGuy (neuhaus-dodekatex) wrote :

May you please close this bug, if it's fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers