In settings.ini, please set gtk-icon-sizes = panel-menu-bar=24,24

Bug #986969 reported by Jeremy Bicha on 2012-04-22
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Please add gtk-icon-sizes = panel-menu-bar=24,24 to settings.ini. Without this, in the GNOME Classic session the Ubuntu logo next to the Applications menu (currently disabled) appears at only 16px which is too small to be distinguishable.

The upstream change that caused this regression is http://git.gnome.org/browse/gnome-panel/commit/?id=12b371c4211ec

Because we use the indicators (since the notification area is rather broken), it's not possible to set the top panel less than 24px by default anyway.

To enable the Ubuntu icon to test this, open /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css and add
-PanelMenuBar-icon-visible: true; below the PanelMenuBar.menubar.menuitem { line.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libgtk-3-0 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
Date: Sun Apr 22 14:40:39 2012
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.gtk.3.0.settings.ini: 2012-04-22T14:35:17.608598

Jeremy Bicha (jbicha) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

(The attached branch has the fix committed, updated the status.)

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
Changed in gtk+3.0 (Ubuntu Precise):
status: Confirmed → Fix Committed
importance: Undecided → Low
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu1

---------------
gtk+3.0 (3.4.2-0ubuntu1) quantal; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Sebastien Bacher <email address hidden> Wed, 16 May 2012 12:25:50 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released

Hello Jeremy, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Jeremy, can you test the update? I'm unsure what the issue is and how to test the fix...

Dmitry Shachnev (mitya57) wrote :

The logo now has a correct size (as it was in oneiric), thanks!

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Hello Jeremy, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.2

---------------
gtk+3.0 (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2, it breaks the icon
      displayed in indicator-power because of the order the icons are searched
      in. It looks like ubuntu-mono should drop the old icon names and
      use the new -symbolic icons. We need to carry this patch until
      ubuntu-mono fixes it's handling of symbolic icons. (LP: #1001229)

gtk+3.0 (3.4.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Ken VanDine <email address hidden> Fri, 18 May 2012 13:38:04 -0400

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers