Ubuntu

Add annotation button missing

Reported by harrydb on 2012-04-18
102
This bug affects 21 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

TESTCASE:
- open a pdf in evince
- display the sidepane if it's not on screen (f9)
- select "annotations" in the sidepane combo
- select the "add" tab
- there should be a button to add an annotation in that tab, it's not there in precise, the update fixes that

According to the evince help it is possible to add annotation to PDF files using the 'Add' tab in the 'Annotations' side pane. The help file shows an image of the add button (the paper and pencil icon).

When I navigate to this tab there is no button where I would expect it.

harrydb (harrydeboer) wrote :
harrydb (harrydeboer) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, upstream says it's a known GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=673650

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Triaged
affects: evince (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream:
http://git.gnome.org/browse/gtk+/commit/?h=gtk-3-4&id=67e2e41907add988746f59857ef86d6ea37b8392

it will be fixed in a stable update in the next week

Changed in gtk+3.0 (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
Changed in gtk:
status: New → Fix Released
harrydb (harrydeboer) wrote :

Nice. And quicker than I expected :-).

description: updated
Changed in gtk+3.0 (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu1

---------------
gtk+3.0 (3.4.2-0ubuntu1) quantal; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Sebastien Bacher <email address hidden> Wed, 16 May 2012 12:25:50 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released

Hello harrydb, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
hanfkeks (c-weber23) wrote :

Confirming fix. Works for me now. Thanks everybody involved fixing!

I was affected. I can confirm that it works now.

2012/5/17 hanfkeks <email address hidden>:
> Confirming fix. Works for me now. Thanks everybody involved fixing!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/984878
>
> Title:
>  Add annotation button missing
>
> Status in GTK+ GUI Toolkit:
>  Fix Released
> Status in “gtk+3.0” package in Ubuntu:
>  Fix Released
> Status in “gtk+3.0” source package in Precise:
>  Fix Committed
>
> Bug description:
>  TESTCASE:
>  - open a pdf in evince
>  - display the sidepane if it's not on screen (f9)
>  - select "annotations" in the sidepane combo
>  - select the "add" tab
>  - there should be a button to add an annotation in that tab, it's not there in precise, the update fixes that
>
>  According to the evince help it is possible to add annotation to PDF
>  files using the 'Add' tab in the 'Annotations' side pane. The help
>  file shows an image of the add button (the paper and pencil icon).
>
>  When I navigate to this tab there is no button where I would expect
>  it.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/984878/+subscriptions

tags: added: verification-done
removed: verification-needed
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) on 2012-05-18
tags: added: verification-failed
removed: verification-done
Ken VanDine (ken-vandine) wrote :

I've uploaded a fix for the regression mentioned in bug 1001229 to -proposed

Hello harrydb, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.2

---------------
gtk+3.0 (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2, it breaks the icon
      displayed in indicator-power because of the order the icons are searched
      in. It looks like ubuntu-mono should drop the old icon names and
      use the new -symbolic icons. We need to carry this patch until
      ubuntu-mono fixes it's handling of symbolic icons. (LP: #1001229)

gtk+3.0 (3.4.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Ken VanDine <email address hidden> Fri, 18 May 2012 13:38:04 -0400

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.