Menu labels tremble/jitter as their height and placement changes on mouse-over

Bug #981084 reported by Fabio Marconi on 2012-04-13
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Medium
Unassigned

Bug Description

Hello
Testcase:
- right click somewhere
- slowly scroll down the entries till they start tremble
This happens in others situations and randomly
See attached screencast

Thanks
fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: nautilus 1:3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Fri Apr 13 21:06:22 2012
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '1280x662+84+77'
 org.gnome.nautilus.window-state maximized trueInstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Fabio Marconi (fabiomarconi) wrote :
tags: added: screencast
description: updated
Fabio Marconi (fabiomarconi) wrote :

Closed because no more reproducible
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in nautilus (Ubuntu):
status: New → Invalid
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Chris Coulson (chrisccoulson) wrote :

This is still happening randomly on current precise. It also happens with the window menus in the panel as well

affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Invalid → Confirmed
summary: - variable button's height
+ the menus label height varies sometime
Changed in gtk+3.0 (Ubuntu):
importance: Low → Medium
summary: - the menus label height varies sometime
+ Menu labels tremble/jitter as their height and placement changes on
+ mouse-over
Amr Ibrahim (amribrahim1987) wrote :

Is there going to be a fix for this bug? It's very annoying.

Heiko L (hl1) wrote :

This still happens. (12.04 (precise) (64-Bit), Kernel Linux 3.5.0-41-generic, GNOME 3.4.2)

As I have this bug on 3 very different computers for over a year and see this bug every day, I am wondering why it affects so few people according to launchpad. (Maybe some users haven't found this bug entry? It took me quite a while to find it, because this bug is a bit hard to describe in words.) I thought, it would affect every installation.
If it does not, does anyone have any hints what might trigger it?
I tried all eligible settings of gtk and compiz, to see if it would improve. No success.

I can only add a few things about the behavior of this bug (in this case observed with Nautilus context menu):

* Once it affects a specific menu entry, it sticks to that entry: If I close the menu and reopen it, it appears always at the same entry. It only goes away, if I do one of the following:
    - restart the affected application (Nautilus)
    - change the theme
    - change the font settings (size or anti-alias or hinting)
It does NOT go away, if I restart Unity and compiz. It then stays at that menu entry where it was.

* Sometimes, I get a wrong color of the menu entry, too: The highlight color (Ubuntu's orange) is missing and the entry stays in background color. (an entry which is selectable of course)

I would appreciate very much any hints or commitments to this bug.

Vadim Peretokin (vperetokin) wrote :

I don't think GTK+ developers look here. We'd have to forward this report onto their bugzilla.

Heiko L (hl1) wrote :

It possibly is the Unico theme engine.
I've set up two alternatives on my computers: A modified "Greybird" theme (from the Shimmer project) that uses no external GTK+3 theme engine and a modified "Adwaita" theme, using the Adwaita theme engine.
Both these themes have bugs, too. But they do not flicker and are reproducable. No stray random stuff.

(If I had not found these working alternatives, I would have had to ditch Unity sooner or later.)

Heiko L (hl1) wrote :

In case anyone likes to give Adwaita a try, too: It might not work with the overlay scrollbars. There are such comments on the web. Since I do not like the overlay scrollbars anyway, I don't care and haven't tested it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers