Regression - Menubar appears/disappears when launching an app

Bug #971459 reported by Andrea Cimitan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Fix Released
Undecided
Unassigned
appmenu-gtk (Ubuntu)
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

gtk+3.0 (3.3.18-0ubuntu3) precise; urgency=low

  * debian/patches/043_ubuntu_menu_proxy.patch:
    - Add back 'ubuntu-local' property for GtkMenuBar to allow apps to
      opt-out of the global bar on a per-menubar basis. (Used for glade,
      freeciv, and maybe others)

 -- Michael Terry <email address hidden> Fri, 16 Mar 2012 11:55:09 -0400

This revision introduces a regression cause the ubuntu-local signal triggers the menubar in/out.

It affects all apps, but most of them are fast enough not to notice it. I can see it all of the times on gnome terminal and eog. On slower machines the effect is more noticeable.

Since this updated was proposed to fix glade, I simply will go back to the previous revision we have in 3.3.18ubuntu2 and blacklist the menubar in appmenu-gtk.

The change will cause glade to look slightly less integrated, but glade is an advanced tool used by a minority of people, while the current regression affects all our users and make the experience look cheap unfortunately.

I will chat with mike trying to find a different solution, otherwise we will need to do what I explained before, with the revert.

Related branches

Andrea Cimitan (cimi)
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.0-0ubuntu3

---------------
gtk+3.0 (3.4.0-0ubuntu3) precise; urgency=low

  * debian/patches/043_ubuntu_menu_proxy.patch:
    - Revert my changes to add back ubuntu-local. It caused a new bug
      (LP: #971459) that caused menubars to pop in and out on startup.
      Since the patch was added largely for glade's benefit, we can
      just blacklist glade in appmenu-gtk instead.
 -- Michael Terry <email address hidden> Mon, 02 Apr 2012 10:39:28 -0400

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.3.91-0ubuntu2

---------------
appmenu-gtk (0.3.91-0ubuntu2) precise; urgency=low

  * src/bridge.c:
    - Pull patch from upstream to blacklist glade (LP: #971459)
 -- Michael Terry <email address hidden> Mon, 02 Apr 2012 11:21:09 -0400

Changed in appmenu-gtk (Ubuntu):
status: New → Fix Released
Michael Terry (mterry)
Changed in appmenu-gtk:
status: New → Fix Committed
Charles Kerr (charlesk)
Changed in appmenu-gtk:
status: Fix Committed → Fix Released
milestone: none → 0.3.92
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers