Scrolling directing is hard-coded/reversed from xinput

Bug #966237 reported by Curtis Hovey on 2012-03-27
274
This bug affects 76 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
naturalscrolling
Undecided
auto-zedtux
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

My computer is set to use natural scrolling like my phone and tablet. I use .Xmodmap and I can
    ! Note that 4 5 and 6 7 are reversed to behave like a table.
    xinput set-button-map 11 1 2 3 5 4 7 6 8 9 10 11 12

A combination of upgrades to unity, compiz, and xorg over the last few days has caused some apps (gedit and gwibber) to scroll the opposite direct of chromium and thunderbird. This is maddening. I can see that the apps that scroll the wrong way have very smooth scrolling indicative of unity and MT.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue Mar 27 09:45:32 2012
DistUpgraded: 2012-01-15 12:15:48,512 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Apple Inc. MacBookAir4,2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=be18758e-a70e-4fbd-b26b-0cab706d92f0 ro quiet splash i915.i915_enable_rc6=1 vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-01-15 (71 days ago)
dmi.bios.date: 01/24/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA41.88Z.0077.B0F.1201241549
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-742912EFDBEE19B3
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir4,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-742912EFDBEE19B3
dmi.modalias: dmi:bvnAppleInc.:bvrMBA41.88Z.0077.B0F.1201241549:bd01/24/2012:svnAppleInc.:pnMacBookAir4,2:pvr1.0:rvnAppleInc.:rnMac-742912EFDBEE19B3:rvrMacBookAir4,2:cvnAppleInc.:ct10:cvrMac-742912EFDBEE19B3:
dmi.product.name: MacBookAir4,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.7.2-0ubuntu4
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Curtis Hovey (sinzui) wrote :
Curtis Hovey (sinzui) wrote :

I can see the issue relates to the synaptics driver with unity and MT favours. the mtrack driver honours the xinput/xmodmap setting.

David Barth (dbarth) wrote :

Thanks for the bug report. That's annoying indeed.

I'm re-directing this report to Chase first, to have someone from the touch team analyze the details. For ref. you should ping Jason as I think he then knows the code inside Compiz that deals with MT.

Changed in unity (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: New → Triaged
importance: Undecided → Medium
Chase Douglas (chasedouglas) wrote :

The issue is most likely with GTK smooth scrolling. It likely doesn't honor the xmodmap button mappings, as that's sort of a hack that has worked because of the poor scrolling implementation in X. I don't know what the proper resolution is, but I'm pretty certain it's a bug that needs to be resolved in GTK somehow, or marked as "won't fix" by them.

affects: unity (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gtk+3.0 (Ubuntu):
importance: Medium → Low
Mjumbe Wawatu Ukweli (mjumbewu) wrote :

I've added a bug upstream. It is at https://bugzilla.gnome.org/show_bug.cgi?id=675047

Chascon (chascone) wrote :

There's a solution for trackpads.

 xinput list-props will give you something like this:
Code:
Device 'SynPS/2 Synaptics TouchPad':
   Device Enabled (133): 1
...
   Synaptics Two-Finger Pressure (269): 282
   Synaptics Two-Finger Width (270): 7
   Synaptics Scrolling Distance (271): 112, 112
   Synaptics Edge Scrolling (272): 0, 0, 0
   Synaptics Two-Finger Scrolling (273): 1, 1
...

The interesting bit being the scrolling distance; replace that with a negative value (with xinput set-int-prop), and you get inverted scrolling.

Sebastien Bacher (seb128) wrote :

upstream wrote:

"So, the command to play around with for xi2.2 is

xinput set-prop <deviceid> "Synaptics Scrolling Distance" -<vert> -<horiz>

to find good values for vert and horiz, look at the current values with
xinput list-props <deviceid>

Note that this only works with the synaptics driver currently, and only with
version 1.6 (or 1.5.99.something).

Also note that the interia calculation in the driver seems to be broken for
negative deltas, so you'll have to set "Synaptics Coasting Speed" to 0 0 for
now, or else you'll get 'infinite scrolling'."

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Stefan Björk (bluebirch) wrote :

There's an option in Ubuntu Tweak to fix this, obviosly: http://ubuntuforums.org/showthread.php?p=11776523

Chascon (chascone) wrote :

Stefan: You sure about that? Did you even test it?

Felix Dreissig (f30) wrote :

@Stefan: See Comment #26 in Bug #951123 – the option is there, but it seems to suffer from the issue discussed here as well, so doesn't affect GTK smooth scrolling.
For completeness: The Ubuntu Tweak Bug is Bug #995748.

Changed in naturalscrolling:
status: New → Confirmed
Arend van Beelen jr. (arendjr) wrote :

I can confirm this bug is still relevant, at least on Ubuntu 12.10 on a Gazelle Professional laptop from System76 (has Ubuntu preinstalled).

In my opinion the option to reverse the scrolling direction should be available by default in System Settings, as this will affect pretty much any user with experience with a MacBook.

Steven Roose (stevenroose) wrote :

Indeed, this bug is still relevant. Seems to be triaged, though...

Jon Schewe (jpschewe) wrote :

This isn't just a problem with track pads. I have a microsoft mouse that exhibits the same behavior. I've modified my .Xmodmap file and most apps respect it, but nautilis and gedit don't.

aleandro (aleandrodasilva) wrote :

ubuntu 12.10 update 2 days ago. Nautilus does not follow the natural scrolling. Annoying bug.

Cheers

Miguel Mendes Ruiz (migmruiz) wrote :

Confirmed in Ubuntu 13.04. This release has the natural scrolling option in system settings for the touchpad, and it seems to work if you don't want to natural scroll with your mouse wheel. The xinput method in other hand, which would work for the mouse too, doesn't behave as expected in nautilus, software-center and perhaps others.

Download full text (4.0 KiB)

Will an option for natural scrolling with mouses also be added to the
system settings in the future?
On Apr 27, 2013 9:31 AM, "Miguel Mendes Ruiz" <email address hidden>
wrote:

> Confirmed in Ubuntu 13.04. This release has the natural scrolling option
> in system settings for the touchpad, and it seems to work if you don't
> want to natural scroll with your mouse wheel. The xinput method in other
> hand, which would work for the mouse too, doesn't behave as expected in
> nautilus, software-center and perhaps others.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/966237
>
> Title:
> Scrolling directing is hard-coded/reversed from xinput
>
> Status in GTK+ GUI Toolkit:
> New
> Status in Natural Scrolling for Linux:
> Confirmed
> Status in “gtk+3.0” package in Ubuntu:
> Triaged
>
> Bug description:
> My computer is set to use natural scrolling like my phone and tablet. I
> use .Xmodmap and I can
> ! Note that 4 5 and 6 7 are reversed to behave like a table.
> xinput set-button-map 11 1 2 3 5 4 7 6 8 9 10 11 12
>
> A combination of upgrades to unity, compiz, and xorg over the last few
> days has caused some apps (gedit and gwibber) to scroll the opposite
> direct of chromium and thunderbird. This is maddening. I can see that
> the apps that scroll the wrong way have very smooth scrolling
> indicative of unity and MT.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: unity 5.8.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> NonfreeKernelModules: wl
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> CompizPlugins:
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom,unityshell]
> CompositorRunning: compiz
> Date: Tue Mar 27 09:45:32 2012
> DistUpgraded: 2012-01-15 12:15:48,512 DEBUG enabling apt cron job
> DistroCodename: precise
> DistroVariant: ubuntu
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64
> (20111012)
> MachineType: Apple Inc. MacBookAir4,2
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic
> root=UUID=be18758e-a70e-4fbd-b26b-0cab706d92f0 ro quiet splash
> i915.i915_enable_rc6=1 vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to precise on 2012-01-15 (71 days ago)
> dmi.bios.date: 01/24/2012
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MBA41.88Z.0077.B0F.1201241549
> dmi.board.asset.tag: Base Board Asset Tag#
> dmi.board.name: Mac-742912EFDBEE19B3
> dmi.board.vendor: Apple Inc.
> dmi.board.version: MacBookAir4,2
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-742912EFDBEE19B3
> dmi.modalias:
> dmi:bvnAppleInc.:bvrMBA41.88Z.0077.B0F.1201241549:bd01/24/2012:svnAppleInc.:pnMacBookAir4,2:pvr1.0:rvnAppleInc.:rnMac-742912EFDBEE19B3:rvrMacBookAir4,2:cvnAppleInc.:ct10:cvrMac-742912EFDBEE19B3:
> dmi.product.name: MacBookAir4,2
> dmi.product.version: 1.0
> ...

Read more...

Umang Varma (umang) wrote :

Just to clarify, even in 13.04, if you enable "content sticks to fingers", nautilus doesn't respect the option.

Jens (jens-launchpad-net) wrote :

Same problem here. Neither the "naturalscrolling" app nor an .Xmodmap "pointer" setting helps with nautilus (or Nemo), but both settings work for other apps (e.g. Chrome, Firefox, ...). Ubuntu 12.04.02 LTS on a Toshiba R850-19Z business notebook (ALPS/2 touchpad).

rg (rob-themayfire) wrote :

GNOME users who want natural scrolling for your mousewheel, this is the case to watch: https://bugzilla.gnome.org/show_bug.cgi?id=682457

Changed in gtk:
status: New → Fix Released
Steven Roose (stevenroose) wrote :

Is anyone still looking into this? It seems to boil down to Nautilus not listening to X. Why is this? Why would Nautilus have different scrolling settings than all other apps?

Timo Reimerdes (timorei) wrote :

It's not just nautilus, as it seems it's basically anything gtk3

Running elementary os freya here.

Chascon (chascone) wrote :

@Timo
Yeah, I believe it's gnome, more so.

It's part of a long time attitude on the part of gnome developers, constantly breaking their own software, be it simple themes, standard desktop norms, or as we have here ... mouse configurability, all against user wishes.

Apparently it's fixed as reported on https://bugzilla.gnome.org/show_bug.cgi?id=682457. I'll look into it and try to report back. It took them 3 years to find a fix, and it's tentative at this point. Gees, gnome!

cazacugmihai (cazacugmihai) wrote :

It is also reproduced in Ubuntu 16.04. Except of nautilus, everything else works as expected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.