Enable broadway (HTML5) backend

Bug #933641 reported by Zdenek Dlauhy
148
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Precise Backports
Undecided
Unassigned
gtk+3.0 (Debian)
Fix Released
Unknown
gtk+3.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Will final package for gtk+3.0 for precise have enabled [--enable-broadway-backend] ?

This feature looks like it will be really good, and possibly can create nice working environment for some applications.

more discussed at
http://askubuntu.com/questions/93580/will-it-be-possible-to-use-gtk3-2s-html5-extension-in-12-04/104798#104798

Thank you.

Zdenek Dlauhy (e-tast-k)
tags: added: gnome3 gtk3 html5 services upgrade-software-version web
Robert Roth (evfool)
Changed in gtk+3.0 (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Micah Gersten (micahg) wrote :

upgrade-software-version is used for requesting new versions, not enabling features, thanks

tags: removed: upgrade-software-version
summary: - gtk+3.0 - HTML5 broadway
+ Please backport/enable HTML5 (broadway) gdk backend for gtk+3.0
Revision history for this message
Savvas Radevic (medigeek) wrote : Re: Please backport/enable HTML5 (broadway) gdk backend for gtk+3.0

A ppa exists with gdk broadway enabled: https://launchpad.net/~malizor/+archive/gtk-broadway

Revision history for this message
Iain Lane (laney) wrote :

Not really appropriate for backports I'm afraid.

Changed in precise-backports:
status: New → Won't Fix
Revision history for this message
Daniel Di Sarli (danieleds0) wrote :

It seems it's not enabled in Quantal too

Changed in gtk+3.0 (Debian):
status: Unknown → New
Revision history for this message
Rico Tzschichholz (ricotz) wrote :

I think with GTK+3.0 3.7/3.8 it will be appropriate to enable it.
It won't require any additional dependencies.

summary: - Please backport/enable HTML5 (broadway) gdk backend for gtk+3.0
+ Enable broadway (HTML5) backend
Revision history for this message
Benjamin Drung (bdrung) wrote :

<ricotz> bdrung, the stipped gdk lib would grow by ca. 90kb

Revision history for this message
Nicolas Delvaux (malizor) wrote :

Now that GTK+3.0 >= 3.8 is in Saucy, what else is missing to enable the Broadway backend?

Changed in gtk+3.0 (Debian):
status: New → Fix Released
Revision history for this message
Nicolas Delvaux (malizor) wrote :

It is enabled in Vivid (and it works fine).
So, except if developers decide to remove the broadway support before the release, this bug is now fixed.

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.