Gnome-screenshot fails to save pictures in the good folder

Bug #916577 reported by Pierre-Olivier Megret on 2012-01-14
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

How to reproduce .

1. In /home/user : create a folder named A with two subfolders AA and BB
2. Take a screenshot and try to save it in folder A
3 The picture is saved in one of the two subfolders . impossible to save in Folder A

If there's no subfolder then it's OK to save in folder A

Thanks for all your job for us !

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-screenshot 3.2.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Sat Jan 14 20:46:58 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-utils (Ubuntu):
status: New → Confirmed

In fact , picture seems to be saved in the subfolder with higer inode ...

Thanks !

Eric Zig (zuric) wrote :

i've got the same issue, i cant save my screenshot in ~/Picture because there are subfolders , I'm contrain to save in a folder where there are not a subfolder.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, you mean gnome-screenshot, not screensaver right?

summary: - Gnome-screesaver fails to save pictures in the good folder
+ Gnome-screenshot fails to save pictures in the good folder
Changed in gnome-utils (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

gnome-utils didn't change a lot this cycle, that's likely to be rather a gtk issue

@Sebastien .. oh Yeah .. i'm confused .. Indeed , I mean gnome-screenshot ;)

affects: gnome-utils (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.3.8-0ubuntu1

---------------
gtk+3.0 (3.3.8-0ubuntu1) precise; urgency=low

  * New upstream version
    * GtkApplication:
      - Supports logout notification and inhibiting
      - Buttons, toolbuttons and switches can now be connected to GActions
    * GtkSpinButton no longer allows to change the value when not editable
    * GtkLabel link support has been rewritten to be be more robust
    * GtkBuilder:
      - Supports the 'id' in GtkComboBoxText
      - Can parse GVariant-valued properties
      - Support loading from a GResource
    * GtkImage: Support loading from a GResource
    * GtkUIManager: Support loading from a GResource
    * Accessibility: key snooping support has been removed
    * Wayland backend and Theming improvements
    * Miscellaneous:
      - Turn default theme css files and dnd cursors into GResources
    * Bugs fixed:
      - "Drag & Drop broken for remote X sessions" (lp: #587856)
      - "Folder selector broken in Precise" (lp: #914356)
      - "Save file dialog arbitrary selects file name" (lp: #912420)
      - "Gnome-screenshot fails to save pictures in the good folder"
        (lp: #916577)
      - "Changing selection no longer sets cursor" (lp: #911905)
  * debian/control.in:
    - updated glib requirement
  * debian/libgtk-3-0.symbols:
    - updated for the new version and the overlay scrollbar update
  * drop patches included in the new version
  * debian/patches/100_overlay_scrollbar_loading.patch:
    - updated patch from Cimi (lp: #911263)
 -- Sebastien Bacher <email address hidden> Tue, 17 Jan 2012 13:47:37 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers