Folder selector broken in Precise

Bug #914356 reported by Marc Deslauriers on 2012-01-10
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)

Bug Description

The folder selector seems to be broken in Precise. When attempting to select a particular directory or Bookmarked folder, it selects the wrong one, or a random one.

Steps to reproduce:

1- Make sure you have a few bookmarked folders in nautilus
2- Press Alt-PrtSc to pull up the screenshot tool
3- Attempt to select a folder in the "Save in folder" widget (may require multiple attemps)
4- Notice the wrong directory (or even a random subdirectory) gets selected

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libgtk-3-0 3.3.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Tue Jan 10 17:28:16 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
SourcePackage: gtk+3.0
UpgradeStatus: Upgraded to precise on 2012-01-03 (6 days ago)

Marc Deslauriers (mdeslaur) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.3.8-0ubuntu1

gtk+3.0 (3.3.8-0ubuntu1) precise; urgency=low

  * New upstream version
    * GtkApplication:
      - Supports logout notification and inhibiting
      - Buttons, toolbuttons and switches can now be connected to GActions
    * GtkSpinButton no longer allows to change the value when not editable
    * GtkLabel link support has been rewritten to be be more robust
    * GtkBuilder:
      - Supports the 'id' in GtkComboBoxText
      - Can parse GVariant-valued properties
      - Support loading from a GResource
    * GtkImage: Support loading from a GResource
    * GtkUIManager: Support loading from a GResource
    * Accessibility: key snooping support has been removed
    * Wayland backend and Theming improvements
    * Miscellaneous:
      - Turn default theme css files and dnd cursors into GResources
    * Bugs fixed:
      - "Drag & Drop broken for remote X sessions" (lp: #587856)
      - "Folder selector broken in Precise" (lp: #914356)
      - "Save file dialog arbitrary selects file name" (lp: #912420)
      - "Gnome-screenshot fails to save pictures in the good folder"
        (lp: #916577)
      - "Changing selection no longer sets cursor" (lp: #911905)
  * debian/
    - updated glib requirement
  * debian/libgtk-3-0.symbols:
    - updated for the new version and the overlay scrollbar update
  * drop patches included in the new version
  * debian/patches/100_overlay_scrollbar_loading.patch:
    - updated patch from Cimi (lp: #911263)
 -- Sebastien Bacher <email address hidden> Tue, 17 Jan 2012 13:47:37 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released

This isn't fixed for me. For those of us stumbling around and trying to find the right bug report, hop on bug 915165.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers