Save file dialog arbitrary selects file name

Bug #912420 reported by Sam_ on 2012-01-05
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Released
gtk+3.0 (Ubuntu)

Bug Description

Since updates yesterday the save file dialog arbitrary selects a file name although a different file name was already given.
Result, the file name has to be changed again.
The video hopefully better visualizes the odd behaviour.
Not sure if it's from upstream or any other lib issue, in the meantime rather wait for triage.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.2.1-2ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Jan 5 19:17:34 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
 PATH=(custom, no user)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

An example video when there is no existing file in a folder.
If an empty folder is selected it saves the file and doesn't rename, well, nothing to rename.
If there already exist lots of other files the dialog arbitrary selects a given file.
As side effect it shows it also highlights always an arbitrary preselected folder.

Attached also term.log regarding recent updates.

Sam_ (and-sam) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the issue is an upstream gtk one

affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk+3.0 (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.3.8-0ubuntu1

gtk+3.0 (3.3.8-0ubuntu1) precise; urgency=low

  * New upstream version
    * GtkApplication:
      - Supports logout notification and inhibiting
      - Buttons, toolbuttons and switches can now be connected to GActions
    * GtkSpinButton no longer allows to change the value when not editable
    * GtkLabel link support has been rewritten to be be more robust
    * GtkBuilder:
      - Supports the 'id' in GtkComboBoxText
      - Can parse GVariant-valued properties
      - Support loading from a GResource
    * GtkImage: Support loading from a GResource
    * GtkUIManager: Support loading from a GResource
    * Accessibility: key snooping support has been removed
    * Wayland backend and Theming improvements
    * Miscellaneous:
      - Turn default theme css files and dnd cursors into GResources
    * Bugs fixed:
      - "Drag & Drop broken for remote X sessions" (lp: #587856)
      - "Folder selector broken in Precise" (lp: #914356)
      - "Save file dialog arbitrary selects file name" (lp: #912420)
      - "Gnome-screenshot fails to save pictures in the good folder"
        (lp: #916577)
      - "Changing selection no longer sets cursor" (lp: #911905)
  * debian/
    - updated glib requirement
  * debian/libgtk-3-0.symbols:
    - updated for the new version and the overlay scrollbar update
  * drop patches included in the new version
  * debian/patches/100_overlay_scrollbar_loading.patch:
    - updated patch from Cimi (lp: #911263)
 -- Sebastien Bacher <email address hidden> Tue, 17 Jan 2012 13:47:37 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gtk:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.