hitting enter on install screen 1 forces language to top selection

Bug #911905 reported by Charlie Kravetz on 2012-01-04
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

When choosing "install xubuntu" from the cd menu, hitting enter on the first screen causes the language to jump to the topmost language.

Verified using both VirtualBox and Hardware, this can be reproduced in both Ubuntu and Xubuntu desktop images.

TESTCASE:

1. when cd spins up, hit enter to accept default language
2. hold right shift in Ubuntu for cd menu, menu is default in Xubuntu
3. Select "Install Xubuntu" or "Install Ubuntu"
4. At first screen in Ubiquity, hit enter to select English and continue
5. Note next screen is not in English.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.10
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic-pae 3.2.0-rc7
Uname: Linux 3.2.0-7-generic-pae i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CasperVersion: 1.296
Date: Wed Jan 4 18:04:56 2012
LiveMediaBuild: Xubuntu 12.04 "Precise Pangolin" - Alpha i386 (20120104)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :

Screenshot of actual screen right after hitting Enter

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) wrote :

I can confirm it also affect lubuntu

Erick Brunzell (lbsolost) wrote :

Just thinking out loud here after trying this in a VM ............ could this be due to 'language-pack-gnome-en-base' being in a state of flux?

If you use synaptic, which Lubuntu does, just search that and see if it's in a state of flux - that is upgradeable - but not yet.

Charlie Kravetz (charlie-tca) wrote :

Setting to high importance, since once the new language takes effect, the center button (back in English) takes me to a desktop in that language. Not being able to read the language, it makes it difficult to back up and change back to English. This can have detrimental effects for those not expecting a desktop in a language they can not read.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Erick Brunzell (lbsolost) wrote :

Maybe I need a better explanation of how to reproduce this behavior. Just now I've tried both the Ubuntu and Lubuntu i386 20120116 images, both choosing "try me first" and "install", and I couldn't reproduce this. I've not tried Xubuntu.

The only "glitch" I've encountered is that the Precise CD/DVD wants to add itself to my base Oneiric systems sources if I choose "boot first hard drive" from the live boot menu, but that's only been with todays image.

Charlie Kravetz (charlie-tca) wrote :

To reproduce this issue,
1. insert a cd in the drive
2. when the cd starts, select the default language.
3. Make sure you are at the cd menu, not the later selection screen that has only two choices. This has the F-keys across the bottom and at least 4 items in the menu
4. Select the second item in the menu, "Install ???"
5. At the next screen, hit Enter on the keyboard.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Erick Brunzell (lbsolost) wrote :

I swear I just did exactly that with Lubuntu i386-20120106, it's installing as I type this.

I booted the Live CD (actually DVD due to size) and the first screen I was presented with was the language selection screen. I left it on the default English and selected "Install". From there things went pretty much as expected, but some screens were "drawn" twice or out of place.

I don't think any of this is ubiquity or casper related but rather something to do with other elements being added to the live image in a haphazard way as is typical during heavy development.

tags: added: rls-mgr-l-tracking
Colin Watson (cjwatson) on 2012-01-11
tags: added: rls-mgr-p-tracking
removed: rls-mgr-l-tracking
Erick Brunzell (lbsolost) wrote :

I'm just now installing the AMD64-20120111 Ubuntu iso for some totally unrelated testing (boot info script stuff) and all seems well. Has anyone tried any of the other *ubuntu flavors in recent days?

Charlie Kravetz (charlie-tca) wrote :

Erick - myself and others can reproduce this issue every image since I reported it. It happens with the desktop cd for precise Ubuntu, Xubuntu, Lubuntu in both VirtualBox and on hardware. I don't know why you can not reproduce it. However, it is still happening with the images dated 2012-01-11.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

On Wed, Jan 11, 2012, at 10:52 PM, Charlie Kravetz wrote:

> Erick - myself and others can reproduce this issue every image since I
> reported it. It happens with the desktop cd for precise Ubuntu,
> Xubuntu, Lubuntu in both VirtualBox and on hardware. I don't know why
> you can not reproduce it. However, it is still happening with the
> images dated 2012-01-11.

Unable to reproduce here in a Virtualbox 4.1.8 VM using the Lubuntu
2012-01-
11 image downloaded from
http://cdimage.ubuntu.com/lubuntu/daily-live/current/precise-desktop-i386.iso
with an MD5SUM of 6fb4f7c035d2be3416ec675b8cba5552 .

For me, it works fine, language stays as English.

Jonathan
--
  Jonathan Marsden
  <email address hidden>

Colin Watson (cjwatson) wrote :

It's reproducible in this morning's Xubuntu image, which is enough for me to work with. It's probably not worth further attempts to try to narrow down which images it does and doesn't appear on.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I think this is a regression in GTK+. I'm trying to come up with a reduced test case now.

Colin Watson (cjwatson) wrote :

I've forwarded this upstream as https://bugzilla.gnome.org/show_bug.cgi?id=667765, with a reduced test case.

affects: ubiquity (Ubuntu) → gtk+3.0 (Ubuntu)
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: Colin Watson (cjwatson) → nobody
affects: ubuntu → gtk+3.0 (Ubuntu)
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.3.8-0ubuntu1

---------------
gtk+3.0 (3.3.8-0ubuntu1) precise; urgency=low

  * New upstream version
    * GtkApplication:
      - Supports logout notification and inhibiting
      - Buttons, toolbuttons and switches can now be connected to GActions
    * GtkSpinButton no longer allows to change the value when not editable
    * GtkLabel link support has been rewritten to be be more robust
    * GtkBuilder:
      - Supports the 'id' in GtkComboBoxText
      - Can parse GVariant-valued properties
      - Support loading from a GResource
    * GtkImage: Support loading from a GResource
    * GtkUIManager: Support loading from a GResource
    * Accessibility: key snooping support has been removed
    * Wayland backend and Theming improvements
    * Miscellaneous:
      - Turn default theme css files and dnd cursors into GResources
    * Bugs fixed:
      - "Drag & Drop broken for remote X sessions" (lp: #587856)
      - "Folder selector broken in Precise" (lp: #914356)
      - "Save file dialog arbitrary selects file name" (lp: #912420)
      - "Gnome-screenshot fails to save pictures in the good folder"
        (lp: #916577)
      - "Changing selection no longer sets cursor" (lp: #911905)
  * debian/control.in:
    - updated glib requirement
  * debian/libgtk-3-0.symbols:
    - updated for the new version and the overlay scrollbar update
  * drop patches included in the new version
  * debian/patches/100_overlay_scrollbar_loading.patch:
    - updated patch from Cimi (lp: #911263)
 -- Sebastien Bacher <email address hidden> Tue, 17 Jan 2012 13:47:37 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gtk:
status: New → Fix Released
tags: added: iso-testing

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/911905

Phill Whiteside (phillw) wrote :

This has solved the problem in lubuntu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.