Gnome-terminal continues to show outline cursor after getting focus

Bug #890784 reported by Marius Gedminas on 2011-11-15
118
This bug affects 25 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

Normall, it works like this: When a terminal is focused its cursor is solid (and blinking). When a terminal is not focused, its cursor is an outline (and doesn't blink).

Sometimes (but increasingly more often in Oneiric than with older versions) I get the outline cursor even when my GNOME Terminal is focused.

Steps to reproduce:
1. Open two windows on different workspaces: say, a browser on workspace 1, and a terminal on workspace 2
2. Focus the browser window
3. Trigger the Scale plugin for windows on all workspaces (<Super>W is the default keybinding for this, I believe)
4. Click on the terminal to focus it (and switch to workspace 2)

Expected behavior: cursor in terminal is filled solid and blinking

Actual behaviour: cursor in terminal is an empty, non-blinking outline.

This does not appear to happen when the terminal is on the same workspace as the window I'm switching from.

Marius Gedminas (mgedmin) wrote :

I've also seen this happen (about 1/3 of the time) when gnome-terminal gets focus when I switch between workspaces with Ctrl+Alt+arrow keys.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Rafael García (rgo) wrote :

To recover from the outline cursor I press meta key/ubuntu logo (show lens) and back to terminal again but anyways it's a annoying.

Marius: I mainly have this problem changing the workspace as you says and to avoid this you should key up Ctrl-Alt-Arrow before to change the workspace(if you change the workspace and follow with this keys pressed you "lost the focus").

Rafael García (rgo) wrote :

I have found a partial fix changing the cursor blinking behaviour.

With gconf-editor (or your prefered tool) look for /apps/gnome-terminal/profiles/Default/cursor_blink_mode and set the value to off.

The cursor doesn't blink but also doesn't show the outline.

Rafael García (rgo) wrote :

Forgot my last comment it doesn't fix nothing, sorry :(

Rafael García (rgo) on 2012-01-17
Changed in gnome-terminal (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
pablomme (pablomme) wrote :

Still present in Precise.

Miëtek Bak (mietek) wrote :

Still a problem in 12.04 LTS.

Dmitri Bachtin (damg) wrote :

Does it still occur in 12.04 and or 12.10 ? I can't reproduce it on 12.10.

g-t 3.6.0

pablomme (pablomme) wrote :

True, I haven't seen this in 12.10 or 13.04. It's probably been fixed in gnome-terminal 3.6.

Marwan Tanager (marwan-tngr) wrote :

No, I just upgraded to 12.10 a couple of days ago, and I encountered the same issue multiple times. Actually I'am here because I was going to file a bug report against gnome-terminal.

Just installed 12.04 yesterday; I can confirm the bug still exists.

Marwan Tanager (marwan-tngr) wrote :

As a workaround, there is another terminal emulator called 'terminator' that is
based on the same virtual terminal widget used by gnome-terminal but doesn't
suffer from this problem. Basically, it's the same as gnome-terminal, but with
many more advanced features.

Matt Hellige (hellige) wrote :

#12 is incorrect. AFAICS, this is actually a libvte bug and all libvte-based terminals suffer from this issue on my 12.04 machine. I've used gnome-terminal, terminator, sakura, and I think evilvte and lilyterm as well.

FWIW, I haven't yet tried 12.10.

Marwan Tanager (marwan-tngr) wrote :

On Tue, Jan 29, 2013 at 05:36:59PM -0000, Matt Hellige wrote:
> #12 is incorrect. AFAICS, this is actually a libvte bug and all libvte-
> based terminals suffer from this issue on my 12.04 machine. I've used
> gnome-terminal, terminator, sakura, and I think evilvte and lilyterm as
> well.
>
> FWIW, I haven't yet tried 12.10.
>

It's correct on 12.10.

This is the version of terminator on my system:

marwan@host:~$ terminator --version
terminator 0.96

Actually, I had installed terminator out of frustration with this bug almost a
month ago, and it hasn't shown any sign for this issue since then. That's why I
stayed with it.

May be you're using a version less than 0.96 where this issued apparently got
fixed.

Mantas Zimnickas (sirex) wrote :

Using Ubuntu 12.04.2 LTS and gnome-terminal 3.4.1.1, on Gnome Shell 3.4.1-0ubuntu2, bug still exists.

Matt Hellige (hellige) wrote :

#14: The issue exists in Terminator 0.96 on Ubuntu 12.04. As I said, this is not a bug in terminator, gnome-terminal, etc. It's a bug in libvte. On my 12.04 box, I have libvte-2.90-9 (1:0.32.1-0ubuntu1). Perhaps that has been updated in 12.10, I don't know.

Note, though, that this is an intermittent issue in every terminal based on libvte.

Adam Wolfe Gordon (awg) wrote :

I'm seeing this bug multiple times a day these days. Using gnome-session with xmonad, and sakura as my terminal. Seems to happen sometimes when I switch workspaces, and sometimes when I lock/unlock the screen.

 guys, I met this when I am using awesome window manager, so any solution now?

Adolfo Jayme (fitojb) on 2016-02-17
Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
Robie Basak (racb) wrote :

Looks like the fix is in gtk+2.0, but will need backporting. The upstream commit is:

https://git.gnome.org/browse/gtk+/commit/?id=d55b815
https://bug677329.bugzilla-attachments.gnome.org/attachment.cgi?id=321036&action=diff&collapsed=&context=patch&format=raw&headers=1

I think these are identical but have not checked.

Should be fixed in Xenial by the libgtk-3-0_3.18.9-1ubuntu1 package.

affects: gnome-terminal → gtk
affects: gnome-terminal (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
Sven Mueller (smu-u) wrote :

Is there a chance to have this fgix backported to Trusty? It affects some of our users.

Michael Schaller (misch-9) wrote :

We would also like to see a backport to Trusty. Should we open a new bug to request this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.