Ubuntu

dnd pointer lock when dragging tab between two gedit instances

Reported by Gerd Katzenbeisser on 2011-10-24
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gedit
Confirmed
Medium
gtk+3.0 (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

TESTCASE:
- run gedit from unity (launcher or dash) or from a command line
- open a new tab in that gedit
- open a text file in nautilus (that should open a new gedit dialog rather than adding a tab to the previous one)
- dnd one of the tabs from the first gedit to the second one

-> without the update the cursor locks in dnd mode (go to a vt and stop gedit to get your session back), with the update it doesn't lock

When I start two instances of gedit (for example manual opening and opening a file) and dragging from one tab to the other freezes the complete unity desktop. When i look at the processes i only see one gedit instance running. If i kill it the gui is free.

Thank you for your bug report, I can confirm the issue there

Changed in gedit (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: - Gui freezes when dragging tab between two instances
+ unity dnd pointer lock when dragging tab between two instances
summary: - unity dnd pointer lock when dragging tab between two instances
+ unity dnd pointer lock when dragging tab between two gedit instances
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in gedit (Ubuntu Oneiric):
importance: Undecided → High
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
Changed in gedit (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in gedit (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in gedit (Ubuntu):
status: Confirmed → Triaged
Andrea Azzarone (andyrock) wrote :

@Gerd
Can you make a screencast please?

Sebastien Bacher (seb128) wrote :

Is there anything you want from the screencast andrea? I can reproduce here, the mouse pointer changes to an hand when the drag start but something seems to stop the dnd on its way, the widget stays floating and stop moving and the mouse cursor stays stucked in grab state

Sebastien Bacher (seb128) wrote :

you need to start the 2 instances from different ways, i.e one from the unity launcher and one from nautilus by clicking on something for example

Andrea Azzarone (andyrock) wrote :

Ok now i can reproduce it, but I'm not sure if it's a unity bug. There is a freeze problem with unity dnd and web browser that looks like this, but i'm quite sure this is not the same.

Andrea Azzarone (andyrock) wrote :

I can reproduce it in Gnome Shell too... I am now even more secure that it's not a Unity bug.

Sebastien Bacher (seb128) wrote :

Thanks Andrea, closing the unity components, I though it might have to do with the launcher reveal but seems not

Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in gedit (Ubuntu Oneiric):
status: Triaged → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in gedit (Ubuntu):
status: Triaged → Confirmed
Andrea Azzarone (andyrock) wrote :

If he had anything to do with the launcher reveal, the freeze would be temporary. If it was a unity crash, killing gedit would not solve the freeze.

Andrea Azzarone (andyrock) wrote :

*If it had...

Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=664646

summary: - unity dnd pointer lock when dragging tab between two gedit instances
+ dnd pointer lock when dragging tab between two gedit instances
Changed in gedit (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in gedit:
importance: Undecided → Unknown
status: New → Unknown
Changed in gedit (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) on 2011-11-24
no longer affects: unity (Ubuntu)
no longer affects: unity (Ubuntu Oneiric)
Changed in gedit:
importance: Unknown → Medium
status: Unknown → New
Changed in gedit:
status: New → Incomplete
Changed in gedit:
status: Incomplete → Confirmed
Greg Merchan (gregory-merchan) wrote :

I added comments on GNOME bugzilla, but I have more comments relevant to just Ubuntu.

When this locks up, there is almost no way out for me. Ctrl+Alt+Backspace hasn't worked in a long time, so that's not an option. Ctrl+Alt+1 (or 2-6) works, but because of some other bug (NVIDIA, perhaps) the VT is invisible. (I also get a sort of "backlight bleed" effect sometimes.) The VT is present so I can log in and `killall gedit`, but I have to do it blindly. There's also no sshd by default, so I couldn't even log in remotely to kill the process.

There needs to be a way for a user who doesn't know these tricks to get back to working system without pulling the power.

tags: added: precise rls-mgr-p-tracking
bitinerant (bitinerant) wrote :

I think this is the same bug:

    https://bugzilla.redhat.com/show_bug.cgi?id=808789

The comments mention it could be related to a mismatched DISPLAY environment variable.

Also:

    http://comments.gmane.org/gmane.linux.redhat.fedora.testers/98401

affects: gedit (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in gtk+3.0 (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu1

---------------
gtk+3.0 (3.4.2-0ubuntu1) quantal; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Sebastien Bacher <email address hidden> Wed, 16 May 2012 12:25:50 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released

Hello Gerd, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Gerd, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.2

---------------
gtk+3.0 (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2, it breaks the icon
      displayed in indicator-power because of the order the icons are searched
      in. It looks like ubuntu-mono should drop the old icon names and
      use the new -symbolic icons. We need to carry this patch until
      ubuntu-mono fixes it's handling of symbolic icons. (LP: #1001229)

gtk+3.0 (3.4.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Ken VanDine <email address hidden> Fri, 18 May 2012 13:38:04 -0400

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.