gnome-terminal crashed with SIGSEGV in g_object_notify()

Bug #864813 reported by pascal germroth on 2011-10-02
66
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Critical
gtk+3.0 (Ubuntu)
Medium
Unassigned
vte (Ubuntu)
Medium
Unassigned

Bug Description

zsh-beta was about to do tab-completion on a path

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sun Oct 2 21:21:02 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcCmdline: gnome-terminal
SegvAnalysis:
 Segfault happened at: 0xb7014aca <g_object_notify+42>: cmpl $0x50,(%eax)
 PC (0xb7014aca) ok
 source "$0x50" ok
 destination "(%eax)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-terminal
StacktraceTop:
 g_object_notify () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 gtk_range_accessible_value_changed () from /usr/lib/libgtk-3.so.0
 g_cclosure_marshal_VOID__VOID () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 signal_emit_unlocked_R () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: gnome-terminal crashed with SIGSEGV in g_object_notify()
UpgradeStatus: Upgraded to oneiric on 2011-09-26 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 g_object_notify (object=0x866e350, property_name=0xb7684722 "accessible-value") at /build/buildd/glib2.0-2.30.0/./gobject/gobject.c:1003
 gtk_range_accessible_value_changed (adjustment=0x85ea658, data=0x866e350) at /build/buildd/gtk+3.0-3.2.0/./gtk/a11y/gtkrangeaccessible.c:38
 g_cclosure_marshal_VOID__VOID (closure=0x884f168, return_value=0x0, n_param_values=1, param_values=0x8653938, invocation_hint=0xbf975280, marshal_data=0x0) at /build/buildd/glib2.0-2.30.0/./gobject/gmarshal.c:85
 g_closure_invoke (closure=0x884f168, return_value=0x0, n_param_values=1, param_values=0x8653938, invocation_hint=0xbf975280) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=0x856f8c0, detail=0, instance=0x85ea658, emission_return=0x0, instance_and_params=0x8653938) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Jeremy Bicha (jbicha) on 2011-10-08
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=661521

description: updated
Changed in gnome-terminal:
importance: Unknown → Critical
status: Unknown → New
Dmitry Shachnev (mitya57) wrote :

> --- Comment #1 from Christian Persch <email address hidden> 2011-10-12 14:49:18 UTC ---
> You need to use vte 0.30 with gtk 3.2, while ubuntu only has 0.28.
> If the same were to happen with 0.30, it would be either a bug in the gtk a11y impl, or in vte's.

Can we backport a patch from 0.30 as a SRU?
http://bugzilla-attachments.gnome.org/attachment.cgi?id=193993

affects: gnome-terminal (Ubuntu) → vte (Ubuntu)
Jeremy Bicha (jbicha) on 2011-10-12
Changed in vte (Ubuntu):
status: Confirmed → Fix Released
Dmitry Shachnev (mitya57) wrote :

@Jeremy: I'll open gtk task for now because this crash still exists (see today's bug 872693).

affects: gnome-terminal → gtk
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
tags: added: quantal
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in gtk:
status: New → Confirmed
Changed in gtk:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.