Ubuntu

GEdit is the only choice as Calendar application in Default Applications dialog

Reported by igi on 2011-09-04
292
This bug affects 61 people
Affects Status Importance Assigned to Milestone
gnome-control-center
New
Medium
desktop-file-utils (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned

Bug Description

In Ubuntu Oneiric (11.10) beta1, opening the Default Applications dialog (System Settings -> System Information), GEdit is selected (and only possible choice) for Calendar items.
I think this is not expected, since it is not so useful to open calendar data as standard text).

In Oneiric Thunderbird is default email client. Currently Thunderbird7 beta is installed, and I noticed the Lightning extension for Calendar is not compatible with it yet.
Will Thunderbird/Lightining be possible values for Calendar applications?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.90-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
Architecture: i386
Date: Mon Sep 5 00:56:27 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-09-03 (1 days ago)

igi (igor-cali) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, confirming the issue but not sure we can do a lot out there...

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jeremy Bicha (jbicha) wrote :

Please open a new bug against lightning for it to show up in Default Applications. I'm not sure whether Lightning supports calendar links and such yet but that needs to work for Ubuntu 12.04 at least. You should be able to run ubuntu-bug xul-ext-lightning .

I'm looking into why Gedit is showing up since that doesn't seem to be the Right Thing at all.

Robert Roth (evfool) on 2011-09-29
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed

I can confirm this. I now do have Thunderbird with Lightning 1.0b7 installed and working, but it still won't show in Default Applications. This seems like a regression from Natty where Evolution supported calendars (including Google Calendar) right out of the box, while Thunderbird needs a plugin manually installed by the user (two if you want Google Calendar support, as in my case).

Rodrigo Moya (rodrigo-moya) wrote :

The .desktop file for lightning needs to provide a MimeType value, AFAIK

Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → Won't Fix
igi (igor-cali) on 2011-11-09
summary: - GEdit is the only choise as Calendar application in Default Applications
+ GEdit is the only choice as Calendar application in Default Applications
dialog
Changed in gnome-control-center (Ubuntu Precise):
status: Confirmed → Triaged
Rainer Rohde (rainer-rohde) wrote :

This is still true with the current Precise alpha built - and frankly, very frustrating considering that under "Online Accounts" I have Google Calendar configured, expecting it to work system-wide.

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Incomplete
Changed in gnome-control-center:
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.19-0ubuntu2

---------------
desktop-file-utils (0.19-0ubuntu2) precise; urgency=low

  * debian/defaults.list: set evolution as the default calendar applications
    to avoid having gedit listed instead (lp: #841409)
 -- Sebastien Bacher <email address hidden> Mon, 09 Jan 2012 15:24:29 +0100

Changed in desktop-file-utils (Ubuntu Precise):
status: New → Fix Released
Changed in desktop-file-utils (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Low
Changed in desktop-file-utils (Ubuntu Oneiric):
status: New → Invalid
importance: Undecided → Low
status: Invalid → Won't Fix
Sam_ (and-sam) wrote :

Not fixed when evolution isn't installed, still displays gedit.
desktop-file-utils:
  Installed: 0.19-0ubuntu2
  Candidate: 0.19-0ubuntu2
  Version table:
 *** 0.19-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

> Not fixed when evolution isn't installed, still displays gedit.

right, which is why the gnome-control-center bug is still open and set as triaged

Sebastien Bacher (seb128) wrote :

turns out the issue is a gtk one

affects: gnome-control-center (Ubuntu Oneiric) → gtk+3.0 (Ubuntu Oneiric)

Still present in 12.04 Beta 2. I surely hope this doesn't show up in an LTS release.

tags: added: precise
Sebastien Bacher (seb128) wrote :

@Christopher: what do you suggest? changing back from thunderbird to evolution so you get a calendar listed?

Nekhelesh Ramananthan (nik90) wrote :

Can we get it to at least display "No Application Available" since it is embarrassing for it to show gedit in an LTS release.

Sebastien Bacher (seb128) wrote :

sure we can, patches are welcome, it's just that we have segfault bugs and session not starting bugs still and they are higher importance that the third combo in the 5th subscreen of the system settings having a combo entry listing "gedit" ...

I wish I could make a patch for this, but I have neither the time nor the know-how. @Sebastien my apologies for my earlier comment, no offense was intended.

Ok, this bug seems to disappear when a proper calendar application is installed (e.g. Maya in my case) (see the attached screenie).
Also, this is a bug is not a gedit one (captain obvious), cuz gedit's category are:
Categories=GNOME;GTK;Utility;TextEditor;
and no:
Categories=GTK;Office;Calendar;
It's most likely caused by the fact that there is no out of the box calendar app which makes me think - is there really a need for Calendar application in Default Applications dialog?

The screenie ... :P

Sam_ (and-sam) wrote :

@nik90 Upstream developer already said 'We should still make sure to display something meaningful...' which would also hit the second combo - currently plain empty when no mail app is installed.
Although imho it's rather an aesthetic matter if the combo is just empty or featuring a text telling me their is no app, which I already know.
If I understand git master correctly the option of no available app wasn't considered at all.

If categories would matter then 'osmo' should be available from combo, but it isn't.
.desktop file says
Categories=GTK;Office;Calendar;ContactManagement;

It just isn't among recommended.
~$ gvfs-mime --query text/calendar
Default application for 'text/calendar': gedit.desktop
Registered applications:
 gedit.desktop
No recommended applications

Sebastien Bacher (seb128) wrote :

@Christopher: don't worry there is no offense, we would like to be able to fix all the bugs, we just have to go through priorities, while this one can be confusing it's a detail, most users will never go to change their default applications in that dialog and stick to default installed softwares

Rainer Rohde (rainer-rohde) wrote :

How hard can it be to add a Google Calendar app there? Considering that we now have Online Accounts in the System Settings... Hard to believe that this is still there...

tags: added: all future quantal releases
Robert Lange (rcl24) wrote :

For those who do not wish to wait for a patch to fix this, you can add the following line to the [Default Applications] section of the file $HOME/.local/share/applications/mimeapps.list:

text/calendar=thunderbird.desktop

I also added the same line to the [Added Associations] section, but I am not sure if that is necessary.

Once you do this, Thunderbird becomes a recommended application for that file type, and shows up in the list. If the Google Calendar app, or any other calendar app has a .desktop file, you can do the same for that app.

igi (igor-cali) on 2012-10-27
description: updated
Vinay (vinay-wagh) wrote :

Bug confirmed on Ubuntu Raring (alpha). The workaround given in Comment 21 (https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/841409/comments/21) works perfectly.

However, when clicked on "Open Calender" it opens (or highlights) Thunderbird, but does not open the calendar tab.

Thanks for the workaround though.

VInay

Rainer Rohde (rainer-rohde) wrote :

This issue still persists as of today, March 18 2013.

I find it hard to believe that Canonical is unable to fix this. Gedit is *not* a calendar application and should thus *not* appear in the "Default Applications" settings as the default calendar.

Not sure what's needed here, but this issue has been lingering for far to long. I wonder if Canonical proposes to use Gedit as the default calendar up on Ubuntu Touch as well...?

Sebastien Bacher (seb128) wrote :

> I find it hard to believe that Canonical is unable to fix this

thanks for keeping the bug as a constructive forum, if you want to fix the issue patches are welcome, that's just a minor cosmetic problem and doesn't rank high enough on the priority list to be worked on at the moment

Rainer Rohde (rainer-rohde) wrote :

Well, Sebastien,

as a mere user of Ubuntu, who also gets the word out quiet a bit about trying and adopting Ubuntu, I have to say that responses like "fix it yourself" don't really help because I am not a programmer. My wife isn't a programmer either, but she recently (finally!) adopted Ubuntu at her office and one of the first things she mentioned was "Why doesn't the Calendar called Gedit not work? It's just an empty file when I open it...".

So, from a end-user standpoint, this is not cosmetic and not minor, considering that, in my wife's case, she has to have a calendar option. Needless to say, the Workaround is Thunderbird with Lightning and Google Calendar provider, however, it would be far nicer to have Google Calendar integrated into the Ubuntu's notification area and from the dropdown beneath the clock.

For a new Ubuntu user it's very confusing to see that -- yeah, there's a calendar available, but non of my appointments show up there, because Gedit is the default calendar app...

Thanks.

Sebastien Bacher (seb128) wrote :

@Rainer: your issue there is mostly the lack of calendar solution in the default installation, fixing the ui to display "no calendar available" might remove some confusion but will still not be a solution for those users who want a calendar. Note that if you install evolution you get a calendar and the ui issue will be "resolved" for you...

Rainer Rohde (rainer-rohde) wrote :

I am with you, Sebastien. However, having to install Evolution alongside with Thunderbird doesn't make much sense from an end-user standpoint either. In order for Evo's calendar function to work, one has to at least set up one email account first, which is redundant with what that user might already have set up for Thunderbird.

If Evolution would offer to only install the calendar portion, which then could be configured individually and detached from email, it would work.

However, I believe it would be smart to use the existing Online Accounts option that already allow for Google accounts to be set up. Why not extend this towards Google Calendar as well? Once that Online Account was set up, it should ask the user of they want to integrate Google Calendar in Ubuntu... That would be nice. Very nice indeed. :)

Rainer Rohde (rainer-rohde) wrote :

PS: After adding Evolution and configuring a "fake" email account, I was able to set up Google Calendar in Evolution, which becomes the default calendar. Again, this is old news, and should not be required considering that Evolution was ditched as the default email/calendaring app in support of Thunderbird. Why Thunderbird + Lightning is not supported towards the default calendar app -- just like Evolution used to -- is beyond me... :)

Rainer Rohde (rainer-rohde) wrote :

Well, scratch everything I said about Evolution ... lol. No wonder why I don't use it as the default calendar. Apparently, it doesn't work well, and doesn't display the events, then asks for the password, and, even though the password is right, it insists on telling me that the password is wrong (works great online and from Thunderbird).

Then, to top it off, it comes back with the following error message: HTTP Error: Method Not Allowed (see screenshot).

Yikes... yes, go ahead, throw that at new Ubuntu users, will ya? ;)

Again, the issue still persists -- We need a working default calendar app besides Gedit. :D

Nekhelesh Ramananthan (nik90) wrote :

Rainer, we understand the situation however there are no proper calendar applications available. Sure there is Lightning as an add-on for Thunderbird, however I don't think it is included by default. Probably a bug report is to be opened in Thunderbird to include. We are working on a calendar app for the Ubuntu Touch phone. And if it becomes mature, sure it might even become default on the desktop but until then we just have to wait a bit.

Rainer Rohde (rainer-rohde) wrote :

Thanks for the feedback, Nekhelesh.

It's a shame that only with Ubuntu Touch is there some movement towards a calendar app. I wonder why in Ubuntu Touch good old "gedit" wasn't chosen as Default Calendar App. ;) Got any insights on that?

Anyway, desktop Ubuntu needs such calendar app asap -- and it should be customizable to accept many different providers.

BTW - what ever happened to this Gnome Calendar: https://live.gnome.org/Design/Apps/Calendar ?

John Mills (jmills59) wrote :

Hello Rainer,

I have to agree with you on this bug report. I have been subscribed to this for well over a year and as an end user I have not seen any progress. I advocate Ubuntu to a lot of people and generally I am happy in the direction Ubuntu is taking. However I feel that this shows a lack of commitment to detail.

I would not expect to find something like this in OSX or Microsoft Windows. It is the little details that make the overall experience. Defaulting a calendar to open Gedit is simply not good practise. A calendar is a very basic item to have built in to your desktop and I was astounded when it was removed in Ubuntu and even more so that it is given such prominence in the touch edition of Ubuntu. Can any developer explain this disparity?

It was stated that Thunderbird would provide the same level of functionality as Evolution did when the switch was first mooted and that Thunderbird would ship with a calendar. This is cleary an example of a regression in Ubuntu when a feature is removed and not replaced with an equivalent.

Let me just ask, why is it essential for my phone that a calendar be a default application but not my desktop which I probably spend 10 times longer using in a day? Surely you would want to link your calendar across both devices in order to be productive.

I think it is time that Canonical take a holistic approach to the totality of their computing experience and provide a consitent experience.

Best regards,

J Mills

Rainer Rohde (rainer-rohde) wrote :

John, that was a well presented notion. You sum up exactly my sentiment and I support your opinion wholeheartedly. I wonder what we, the end-users, could do to get this issue noted.

I believe Google+ is a good starting point, as Ubuntu is well represented there by various circles. Thoughts?

Thanks.

hey folks: there's a blueprint you can subscribe to in order to keep up to date with progress on calendar integration with the default install. see: https://blueprints.launchpad.net/ubuntu/+spec/desktop-p-calendar-integration.

fwiw, i agree that this is a major pain point for most users, even though it's minor relative to show-stoppers like application crashing. however, this is the wrong forum for those concerns. this bug is about a defect in gnome-control-center causing it to show something unreasonable when there isn't a reasonable option available. anything not directly related is a distraction that makes the bug harder to understand, and therefore fix.

for now, the bug has been reported upstream. once fixed there, it benefits everyone, not just Ubuntu. hugs all around. ;)

cheers.

Thomas C. (thomas-creutz) wrote :

Its just easy to add thunderbird to the default calendar client:

Edit /usr/share/applications/thunderbird.desktop
and add text/calendar;text/x-vcard; to MimeType

at least run: update-desktop-database -q

Now you see Thunderbird in the Default Applications dialog.

Source: http://askubuntu.com/a/305904/10756

Pls include this in Ubuntu Dist Packages ;)

Rainer Rohde (rainer-rohde) wrote :

@Thomas --

of course this is just a pseudo fix, as it doesn't integrate Thunderbird into the Unity Panel and its Calendar Indicator. That means, I can't see any of my events from the indicator, nor can I click on "Add Event..." from the Calendar Indicator and hope that Thunderbird launches from there... ;)

I really hope that there will be a real calendar that integrates with Ubuntu and the indicator well enough, and lets the user pick what backend the want their calendar data to be displayed from.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.