gtk_widget_destroy reports error

Bug #1816032 reported by Anthony Buckley on 2019-02-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
Buggy warnings are displayed in some cases, which can confuses users/coders

* Test case
Build and use the small program attached in the comments, it should display no warning

* Regression potential
The change is a simple null check in the combo widget code, the regression potential is low but make sure combos work in a few softwares just in case

------------------------------

I have recently installed Ubuntu 18.04 on a new computer and have a Gtk+3.0 program that reports an error:-

Gtk-CRITICAL gtk_widget_is_drawable: assertion 'GTK_IS_WIDGET (widget)' failed

The same program runs without error on another computer with 16.04.

The problem occurs when a ComboBoxText widget in a container (grid) is destroyed using gtk_widget_destroy.
Other widgets may be affected but the problem does not occur for GtkScale widgets. The widget does actually get destroyed, but the message is produced in the process.
I have also found that using gtk_container_remove avoids the error, but the docs indicate that this is
inefficient and not preferred.

I have attached a test program to reproduce the error. It also includes a few other things that I tried to see if they made any difference but to no avail. 'Destroy cbox' is the essential test to reproduce.

System details:
Description: Ubuntu 18.04.1 LTS
Release: 18.04

libwxgtk3.0-dev:
  Installed: (none)
  Candidate: 3.0.4+dfsg-3
  Version table:
     3.0.4+dfsg-3 500
        500 http://au.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, but how is that a bug in the network indicator? Also you didn't attach the example you mentioned?

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Anthony Buckley (tony-buckley) wrote :

Apologies for the mess up. I was looking at a similar bug listed for the network applet. I thought I had changed it, but the first time I tried to save I had a timeout and had to re-enter the details all over. Somehow the network applet must have been set when I re-entered. It was meant to a problem with Gtk+3.0 Dev.
Sample code to reproduced is attached.

affects: network-manager-applet (Ubuntu) → ubuntu
Anthony Buckley (tony-buckley) wrote :

The original package noted was a mistake. The nearest I can guess at for this problem is as above. I couldn't find anything that was obvious for a problem Gtk+3.0 development

affects: ubuntu → libcanberra (Ubuntu)
Sebastien Bacher (seb128) wrote :

Looking upstream it seems similar to https://gitlab.gnome.org/GNOME/gtk/issues/125 , the warning is indeed fixed in the current Ubuntu serie, could be a candidate to include if we do a SRU update for gtk but doesn't seem an high importance one/probably not worth an update by itself

affects: libcanberra (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Incomplete → Fix Released

It certainly does look related and absolutely agree that its not really
a high priority.

Thanks. Regards.

On 19/2/19 2:20 am, Sebastien Bacher wrote:
> Looking upstream it seems similar to
> https://gitlab.gnome.org/GNOME/gtk/issues/125 , the warning is indeed
> fixed in the current Ubuntu serie, could be a candidate to include if we
> do a SRU update for gtk but doesn't seem an high importance one/probably
> not worth an update by itself
>
>
> ** Package changed: libcanberra (Ubuntu) => gtk+3.0 (Ubuntu)
>
> ** Changed in: gtk+3.0 (Ubuntu)
> Status: Incomplete => Fix Released
>

Sebastien Bacher (seb128) wrote :

I'm updating the bug to be SRU compliant and staging in the vcs, not going to do an upload for that but it's queued to be included next time we do one

description: updated

Hello Anthony, or anyone else affected,

Accepted gtk+3.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.22.30-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gtk+3.0 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Using the current bionic-updates version the warning is displayed, after upgrading to 3.22.30-1ubuntu3 clicking the button works without any warning display, the fix is verified

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.30-1ubuntu3

---------------
gtk+3.0 (3.22.30-1ubuntu3) bionic; urgency=medium

  [ Sebastien Bacher ]
  * d/p/Check-for-NULL-priv-popup_window-in-gtk_combo_box_popdown.patch:
    - Check for NULL priv->popup_window in gtk_combo_box_popdown()
    (lp: #1816032)

  [ Andrea Azzarone ]
  * d/p/restore_filechooser_typeaheadfind.patch:
    - Disable typeahead if in search mode (LP: #1592177)

 -- Sebastien Bacher <email address hidden> Tue, 02 Apr 2019 17:30:09 +0200

Changed in gtk+3.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers