Tooltips flicker constantly in GTK3 applications

Bug #1798861 reported by John Lindgren on 2018-10-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Debian)
Fix Released
Unknown
gtk+3.0 (Ubuntu)
Low
Unassigned
Cosmic
Low
Unassigned

Bug Description

Tooltips are flicker constantly (i.e. repeatedly shown and the hidden again) in GTK3 applications under XFCE.

It is a regression in the recent GTK 3.24.

This is the upstream report and fix:
https://gitlab.gnome.org/GNOME/gtk/issues/1371
https://gitlab.gnome.org/GNOME/gtk/commit/9b7d886b723132eade2e76f3fd179cf81b7601f2

A workaround for XFCE is as follows:

Open Settings Editor.
Set xsettings -> Gtk -> CursorThemeSize to 16.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: libgtk-3-0 3.24.1-1ubuntu2
Uname: Linux 4.19.0-041900rc8-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
Date: Fri Oct 19 12:23:53 2018
InstallationDate: Installed on 2017-02-01 (624 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gtk+3.0
UpgradeStatus: Upgraded to cosmic on 2018-10-18 (0 days ago)

John Lindgren (john-lindgren) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in hash-it:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Jeremy, you might want to consider distro patching that one as well if you are still doing gtk changes?

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Jeremy Bicha (jbicha) on 2018-12-12
affects: hash-it → acorn (Ubuntu)
no longer affects: acorn (Ubuntu)
Jeremy Bicha (jbicha) wrote :

I discussed this issue briefly on #xubuntu-devel today. This issue does not affect the default Xubuntu session which has set a cursor size for a long time. It only affects Ubuntu 18.10 users using the plain Xfce session. (In fact, I had to create a new user to see this bug for myself in an Xubuntu 18.10 live ISO. Simply choosing "Xfce" after already logging in with "Xubuntu" was not sufficient.)

This bug will be fixed for Ubuntu 19.04 and never affected Ubuntu 18.04 LTS.

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
tags: added: rls-cc-notfixing
Changed in gtk+3.0 (Debian):
status: Unknown → Confirmed
Changed in gtk+3.0 (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.24.2-2ubuntu2

---------------
gtk+3.0 (3.24.2-2ubuntu2) disco; urgency=medium

  * Cherry-pick x11-Fix-deprecation-macro-use.patch:
    - Fix deprecation macro use to fix crashes seen on Xfce

gtk+3.0 (3.24.2-2ubuntu1) disco; urgency=medium

  * Merge from Debian. Remaining changes:
    + Install a settings.ini file to set our themes
    + Update debian/libgtk-3-0.symbols
    + debian/control.in:
      - Build-depend on adwaita-icon-theme-full for icon name check test
    + autopkgtest: installed-tests: Depend on adwaita-icon-theme-full
    + debian/control.in, debian/rules:
      - use dh-translations for language packs integration
    + Ubuntu-specific patches:
      - 073_treeview_almost_fixed.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind.patch
      - 0001-calendar-always-emit-day-selected-once.patch
      - 0001-gtkwindow-set-transparent-background-color.patch
      - unity-border-radius.patch
      - unity-headerbar-maximized-mode.patch

gtk+3.0 (3.24.2-2) unstable; urgency=medium

  * Add Revert-update-some-a11y-test-results.patch:
    - Revert a late change that broke our build tests
  * Use xvfb-run for build tests

gtk+3.0 (3.24.2-1) unstable; urgency=medium

  * New upstream release (LP: #1808233)
    - Fix tooltip flickering regression in Xfce (Closes: #911148) (LP: #1798861)
  * Drop patches applied in new release:
    - wayland-Avoid-crashes-inside-wl_proxy_marshal.patch
    - Force-emoji-presentation.patch
    - emojichooser-Pass-chooser-to-add_emoji.patch
  * Cherry-pick Revert-Fix-deprecation-warnings.patch:
    - Fix typo that broke the build
  * debian/libgtk-3-0.symbols: Add new symbol

 -- Jeremy Bicha <email address hidden> Thu, 13 Dec 2018 18:01:53 -0500

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2019-01-15
Changed in gtk+3.0 (Ubuntu Cosmic):
status: New → In Progress
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

I am marking this fixed since we have a proposed fix in progress tracked at https://launchpad.net/bugs/1808233

Changed in gtk+3.0 (Ubuntu Cosmic):
status: In Progress → Fix Released
Jeremy Bicha (jbicha) wrote :

The fix for this has completed verification and is rolling out as an update to Ubuntu 18.10 computers over the next few days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.