Duplicate apps in Open With Other Application

Bug #1763763 reported by Jeremy Bicha on 2018-04-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Test Case
=========
1. Create a text file foo.txt
2. Open your file browser (nautilus) and right-click on the file.
3. Select Open Application With
4. In the dialog, click Show All Applications

Duplicates
==========
There are duplicates for at least
Archive Manager
Files (3 versions!)
Rhythmbox
Videos
Text Editor (I see this when I right-click on something that isn't a text file)

Other Info
==========
This is triggered by:
1. The system shows apps with NoDisplay=true. This is a useful feature because it allows for a vim.desktop to be able to open files without cluttering the Activities Overview (but that's a different topic. See Debian 879157)

2. We specifically added compatibility .desktop file for upgraders for several main apps. The .desktop files were renamed upstream for better compatibility with Flatpak. (AppStream recommends the reverse-domain org.gnome.gedit.desktop style too).

Seb suggested this issue can be fixed with a blacklist in gtk.

Related branches

Sebastien Bacher (seb128) wrote :

Thanks, that's worth fixing but not really a release blocked issue, tagging rls-bb-notfixing

tags: added: rls-bb-notfixing
removed: rls-bb-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Low
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.4-0ubuntu4

---------------
nautilus (1:3.26.4-0ubuntu4) cosmic; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * gbp.conf: update default settings as per debian suggested
  * debian: remove legacy nautilus.desktop and use new one everywhere (LP: #1763763)

  [ Iain Lane ]
  * Delete debian/nautilus-{folder-handler,home}.desktop. They are now unused.

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 28 Sep 2018 16:25:37 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

Marco, dropping the legacy .desktop is not what this bug was about. Those are in bionic and can't be removed there so the bug is about patching gtk to filter those specific files out, which is a workaround but should do the job for the stable serie

Changed in nautilus (Ubuntu):
status: Fix Released → Invalid
Changed in gtk+3.0 (Ubuntu):
status: Invalid → Triaged

Ah, ok sorry... I was pointed here by the trello card, thus I attached nautilus to it.

Want me to look at the issue in gtk itself?

Sebastien Bacher (seb128) wrote :

Thanks Marco but it should be fine, that gtk change is low priority and I can have a look, it should be easy enough (basically adding a static list of .desktop names to ignore)

Sebastien Bacher (seb128) wrote :

The issue is fixed in >= Cosmic. We could workaround it in bionic but it's low priority at this point

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers