Update gtk+3.0 to 3.22.25

Bug #1728421 reported by Jeremy Bicha on 2017-10-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

Impact
======
There is a new gtk3 release, 3.22.25.

Highlights
----------
* Allows dropping these cherry-picked patches:
  - 0001-Adwaita-Fix-typo-.backgrounf-.background.patch
  - 0002-theme-Fix-Adwaita-headerbars.patch
 - 0003-display-x11-Unset-tiled-state-if-_GTK_EDGE_CONSTRAIN.patch
* Fixes crash with GNOME Online Accounts (LP: #1720400)
* Fixes menu forwarding over SSH (LP: #1700319)
* Fixes log spam about cursor when running gnome-terminal on Wayland (LP: #1681910)
* Support KDE SSD (server-side decorations) handling on Wayland
* Restores middle-click to do the opposite of primary (usually left-) click in scrollbars, GTKRange
* Some theme fixes for the gtk3 High Contrast theme
* Allow more key buttons in the GNOME Settings > Keyboard panel to be translatable
* A fix to not show duplicate printers in some cases
* Improves the GNOME 3.26 tiling feature for GNOME Terminal

For more changes since 3.22.24, see
https://git.gnome.org/browse/gtk+/log?h=gtk-3-22
https://git.gnome.org/browse/gtk+/tree/NEWS?h=gtk-3-22

Test Case
=========
Install the update. Run a variety of apps in the default Ubuntu install with the Ambiance theme.

Also check that the Adwaita and High Contrast themes still look ok. You can change the theme with the GNOME Tweaks app (gnome-tweak-tool). For the window buttons to look as designed, you should change the icon theme to Adwaita when you set the theme to Adwaita or High Contrast. Afterwards, you can reset your theme back to the defaults with
gsettings reset org.gnome.desktop.interface gtk-theme
gsettings reset org.gnome.desktop.interface icon-theme

Regression Potential
====================
Quite a few changes, but mostly it's bug fixes.

Earlier gtk3 releases had some regressions (that's why we had those cherry-picked patches), but that was mostly related to the late GNOME 3.26 tiling feature that was rushed in. This release does not have any major new features like that.

Unfortunately, very few people run gtk3 from git master so regressions often aren't seen until distros start shipping the gtk3 update.

The GNOME stack has an SRU Micro-release exception
https://wiki.ubuntu.com/StableReleaseUpdates#GNOME

We haven't done micro-release SRUs for gtk3.22 yet. This might be a good trial run to see how well it works before 18.04 LTS. Fedora does keep their gtk3 up to date throughout the life of their releases.

Other Info
==========
This update also drops a few old patches that weren't listed in debian/patches/series. Sorry about the noise but this makes it a bit cleaner in the future.

0001-Update-the-GDK-Mir-backend-to-fix-a-few-problems.patch
0001-Improve-external-drives-detection.patch
0002-fix-other-locations-with-glib-249.patch
0003-use-null-for-generic-marshallers.patch

Jeremy Bicha (jbicha) on 2017-10-29
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
Changed in gtk+3.0 (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
tags: added: artful upgrade-software-version
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.25-0ubuntu1

---------------
gtk+3.0 (3.22.25-0ubuntu1) bionic; urgency=medium

  [ Simon McVittie ]
  * New upstream release (LP: #1728421)
    - Fix tiling behaviour with Mutter/Shell 3.26 (Closes: #879566)
    - Fix crash when adding Google online account (LP: #1720400)
    - Update symbols file
    - d/p/0001-Adwaita-Fix-typo-.backgrounf-.background.patch,
      d/p/0002-theme-Fix-Adwaita-headerbars.patch,
      d/p/0003-display-x11-Unset-tiled-state-if-_GTK_EDGE_CONSTRAIN.patch:
      Drop patches, applied upstream
    - d/p/gdk-wayland-protocol-server-decoration.patch:
      Add server-decoration.xml from upstream git. It is missing from the
      tarball release.

  [ Jeremy Bicha ]
  * Drop 0004_fix-gtkentry-wayland-regression.path:
    Because this caused a totem regression, we're fixing the
    bug in mutter instead.

 -- Andrea Azzarone <email address hidden> Wed, 25 Oct 2017 11:16:44 +0000

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2017-10-30
description: updated
Jeremy Bicha (jbicha) on 2017-10-30
description: updated
Jeremy Bicha (jbicha) on 2017-10-30
Changed in gtk+3.0 (Ubuntu Artful):
status: Triaged → In Progress

Hello Jeremy, or anyone else affected,

Accepted gtk+3.0 into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.22.25-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Jeremy Bicha (jbicha) wrote :

I have been using gtk 3.22.25-0ubuntu0.1 for several days on Ubuntu 17.10 and haven't noticed any regressions. The Adwaita, Ambiance and HighContrast themes look as expected.

tags: added: verification-done-artful
removed: verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.25-0ubuntu0.1

---------------
gtk+3.0 (3.22.25-0ubuntu0.1) artful; urgency=medium

  [ Simon McVittie ]
  * New upstream release (LP: #1728421)
    - Fix tiling behaviour with Mutter/Shell 3.26 (Closes: #879566)
    - Fix crash when adding Google online account (LP: #1720400)
    - Fixes log spam about cursor when running gnome-terminal on Wayland
      (LP: #1681910)
    - Update symbols file
    - d/p/0001-Adwaita-Fix-typo-.backgrounf-.background.patch,
      d/p/0002-theme-Fix-Adwaita-headerbars.patch,
      d/p/0003-display-x11-Unset-tiled-state-if-_GTK_EDGE_CONSTRAIN.patch:
      Drop patches, applied upstream
    - d/p/gdk-wayland-protocol-server-decoration.patch:
      Add server-decoration.xml from upstream git. It is missing from the
      tarball release.

  [ Jeremy Bicha ]
  * Drop 0004_fix-gtkentry-wayland-regression.path:
    Because this caused a totem regression, we're fixing the
    bug in mutter instead.
  * Drop some unapplied patches from the package source

 -- Jeremy Bicha <email address hidden> Mon, 30 Oct 2017 16:07:23 -0400

Changed in gtk+3.0 (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers