GTK+3 doesn't show FUSE/GVFS, smb (SMB/CIFS), sftp (SFTP/SSH) network shares in file chooser

Bug #1714518 reported by Colin Leroy on 2017-09-01
154
This bug affects 60 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned
Xenial
Low
Unassigned
Artful
Low
Unassigned

Bug Description

Steps to reproduce:
1. Install any Gtk3 application such as Firefox or Chromium which use modern file-chooser dialog.
2. Mount network location through fstab or file-manager ("smb://" = SMB/CIFS, "sftp://" = SFTP/SSH and so on)
3. Try to save/open file to/from the remote location from Gtk3 application.

Expected results:
* user is able to find network folder and save/open file to/from it with GtkFileChooser dialog

Actual results:
* user is unable to find network folder and save/open file to/from it with GtkFileChooser dialog and many user applications are affected

-------------------------------------------------------------------------
Original bug description is below:

GTK+3 doesn't show FUSE network shares in file chooser - it used to do so in GTK+2, and the GTK+3 documentation still mentions it should do it.

In the mean time, every user of every application switching to GTK+3 -- including Chromium, at some point between 58 and 60 -- (a change which happened in 16.04 LTS!!), loses the functionality to open or save directly to a network share.

I had chosen 16.04 LTS for deploying our workstations at work, and my 50 users have been suddenly unable to do a simple operation they have to do dozens of times a day.
They now have to "buffer" these files to their local filesystem when saving them and before uploading them, and then copy them to the company's network shares.
They were already a little bit grumpy when it stopped working with Firefox, and are now really side-eyeing me when they apply updates and find Chromium broken.

I have reported the bug upstream and provided a patch to fix this. I hope you'll be able and willing to include it to Ubuntu's GTK+3 package.

Thanks in advance.

Colin

Colin Leroy (colin-colino) wrote :

Here's the patch.
It's also been provided upstream at https://bugzilla.gnome.org/show_bug.cgi?id=787128

description: updated

The attachment "gtk_3_fix_fuse_mounts.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Colin Leroy (colin-colino) wrote :

Here is a debdiff with that patch integrated. I hope it'll help.

Changed in gtk+3.0 (Ubuntu):
assignee: nobody → Colin Leroy (colin-colino)
status: Confirmed → In Progress
Jeremy Bicha (jbicha) wrote :

Why do you think showing network shares is supposed to be the default in GTK+ 3?

My understanding is that it is documented that only local files are shown:
https://developer.gnome.org/gtk3/stable/GtkFileChooser.html#gtk-file-chooser-set-local-only

I think the comment about FUSE was more of "on some systems, you may get network files showing anyway even though we try to follow the setting."

Colin Leroy (colin-colino) wrote :

Hi,

No - I think the default is to show everything accessible via POSIX paths.

There is some code in GTK+2 that specifically verifies if volumes are accessible via POSIX paths in local only mode, and adds them if they are. This includes FUSE-mounted network shares.

in gtk/gtkfilechooserdefault.c: shortcuts_add_volumes() for example.

Colin Leroy (colin-colino) wrote :

I would also add that even though asking for GTK3 applications like Chromium, Firefox, Thunderbird to call gtk_file_chooser_set_local_only(FALSE) seems like an easy fix, it is not:

when such applications then call for gtk_file_chooser_get_filename() (and _get_filenames), they could end up with NULL for remote files that are not fuse-mounted.

Similarly, gtk_file_chooser_get_uri() (and _get_uris) behaves differently when local-only is set or not. With local-only set, _get_uri() returns a native file:/// path, without it returns a normal uri (smb:// ...)

My understanding of the "show FUSE mounts in local-only mode" is that it helps numerous applications easily handle I/O with remote volumes without having to use GIO everywhere.

Colin Leroy (colin-colino) wrote :

Hello,

Here is a (different) patch to fix the problem on Artful's GTK 3.22.

The difference with the previous patch for GTK 3.18 is that there is now an "Other Locations" entry in the sidebar, which displays mounts via GtkPlacesView. This puts them in the correct place.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Norbert (nrbrtx) on 2017-10-31
tags: added: bionic xenial
Norbert (nrbrtx) wrote :

Some Ubuntu users are newbies, they do not know about GVFS, FUSE and so on, so they can't suppose to use /media folder for network filesystems.

This bug should be fixed as soon as possible. Xenial and Bionic are affected.
Most Gtk3 applications are affected - the most common are Firefox, Google Chrome.

description: updated
summary: - GTK+3 doesn't show FUSE network shares in file chooser
+ GTK+3 doesn't show FUSE/GVFS, SMB/CIFS, SFTP/SSH network shares in file
+ chooser

What is interesting gnome-mplayer shows my SMB/CIFS share.

Norbert (nrbrtx) wrote :

And baobab shows my SMB/CIFS share.

Norbert (nrbrtx) wrote :

Gedit and Evince show my SMB/CIFS share. So some applications have problems in their GtkFileChooser dialog code.

Norbert (nrbrtx) on 2017-10-31
description: updated
summary: - GTK+3 doesn't show FUSE/GVFS, SMB/CIFS, SFTP/SSH network shares in file
- chooser
+ GTK+3 doesn't show FUSE/GVFS, smb (SMB/CIFS), sftp (SFTP/SSH) network
+ shares in file chooser
Norbert (nrbrtx) wrote :

For meld see bug 1335457.

Norbert (nrbrtx) on 2017-10-31
description: updated
description: updated
Norbert (nrbrtx) on 2017-11-03
no longer affects: brasero (Ubuntu)
Colin Leroy (colin-colino) wrote :

Hi,
Yeah. That bug hits a lot of applications because GTK+3 does things differently than GTK+2 in this regard, which is why I submitted the bugreport (and a patch) to GTK+3 instead of all these applications.

Olivier Tilloy (osomon) on 2017-11-06
no longer affects: chromium (Ubuntu)
Changed in gtk:
status: Confirmed → Fix Released
Colin Leroy (colin-colino) wrote :

Requesting a sponsor to upload the fix's backport :)

Richard Béneyt (rbeneyt-j) wrote :

When will this fix be available in an updated version of the 16.04.3 LTS libgtk-3 package ?

Colin Leroy (colin-colino) wrote :

Hi Richard,
Well, somebody from the Ubuntu Sponsors Team would need to notice that patch I've prepared and care enough to handle it...

Chris Rainey (ckrainey) wrote :

In case any Ubuntu/GNOME Dev's are confused about the urgency of this and they don't work in a LAN/WAN-based environment:

1. Switching business users from MS Windows to Ubuntu Linux carries an expectation that they can still access LAN/WAN resources from the 'file chooser' dialogs(i.e. Chrome browser --> Gmail --> upload attachment from an SMB/CIFS location, etc.)

2. Having consistent GUI interfaces imparts a sense of confidence to Admins(like me) that they won't be burned-at-the-stake on a huge bonfire by those same users _and_ management for trying to move the company onto GNU/Linux systems !!

Colin Leroy (colin-colino) wrote :

GNOME devs accepted my patch upstream. I made a debdiff to fix the Ubuntu package .Now we're just waiting for an Ubuntu dev with some motivation to fix this.
Chris is right. This regression *in an LTS release even!* and the time it takes to fix it is awfully long.

Chris Rainey (ckrainey) wrote :

@colin-colino Awesome! Thanks for your work on this.

Chris Rainey (ckrainey) wrote :

OK .... so I'm _really_ glad to see the work on this bug progressing and, as such, I've been attempting to "add myself" to this bug's "affected user" list. However, I have _not_ been able to do so for the past 2-weeks with the error message: "timeout, please try again later". Does anybody know how to create a bug-report for Launchpad, itself?

Screenshot of bug, attached.

Chris Rainey (ckrainey) wrote :

Never mind, found it: https://bugs.launchpad.net/launchpad/+bug/1747469

Sorry for the SPAM!

Jeremy Bicha (jbicha) on 2018-02-15
no longer affects: chromium-browser (Ubuntu)
no longer affects: deja-dup (Ubuntu)
no longer affects: firefox (Ubuntu)
no longer affects: gdebi (Ubuntu)
no longer affects: meld (Ubuntu)
no longer affects: remmina (Ubuntu)
no longer affects: thunderbird (Ubuntu)
no longer affects: transmission (Ubuntu)
no longer affects: usb-creator (Ubuntu)
no longer affects: vinagre (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: In Progress → Fix Committed
assignee: Colin Leroy (colin-colino) → nobody
Changed in gtk+3.0 (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
Changed in gtk+3.0 (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Low
Chris Rainey (ckrainey) wrote :

Thanks @jbicha --- you are moving mountains in Ubuntu theses past few months!

Colin Leroy (colin-colino) wrote :

Thanks a bunch, Jeremy. Should I provide a backport to the patch for 16.04 ?

Jeremy Bicha (jbicha) wrote :

Colin, yes please. If you want to fix this issue in Ubuntu 16.04 LTS, you also need to fix it in Ubuntu 17.10. (That's because we don't want to introduce avoidable regressions when people upgrade.)

See https://wiki.ubuntu.com/StableReleaseUpdates for more information.

Still affecting Thunderbird in 14.04LTS.

I'm just a Ubuntu user affected by this (very new to Ubuntu) so I was
waiting for the fix to come via one of the many automatic updates. Do I
have to patch something manually? Any pointers for us newbies would be
very helpful.

Thanks,

Jon

On 15/02/18 11:04, Jeremy Bicha wrote:
>
> ** No longer affects: thunderbird (Ubuntu)
>
>

Jeremy Bicha (jbicha) on 2018-02-15
Changed in gtk+3.0 (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.28-1ubuntu1

---------------
gtk+3.0 (3.22.28-1ubuntu1) bionic; urgency=medium

  * Merge with Debian. Remaining changes:
    + Install a settings.ini file to set our themes
    + Enable Mir backend
    + Update debian/libgtk-3-0.symbols
    + debian/control.in:
      - Build-depend on adwaita-icon-theme-full for icon name check test
    + debian/rules: Mark additional known test failures:
      - box-shadow-changes-modify-clip.ui
      - label-text-shadow-changes-modify-clip.ui
    + Ubuntu-specific patches:
      - 073_treeview_almost_fixed.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind.patch
      - 0001-calendar-always-emit-day-selected-once.patch
      - 0001-gtkwindow-set-transparent-background-color.patch
      - ubuntu_fileselector_behaviour.patch
      - unity-border-radius.patch
      - unity-headerbar-maximized-mode.patch
      - gtksocket-unscale-before-sending-configurenotify.patch
      - no_content_hub.patch

gtk+3.0 (3.22.28-1) unstable; urgency=medium

  * New upstream release (LP: #1698270) (LP: #1714518)
  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.3
  * Update Vcs fields for migration to https://salsa.debian.org/
  * Drop git_text-view-support-emoji-chooser.patch: Applied in new release

 -- Jeremy Bicha <email address hidden> Thu, 15 Feb 2018 10:15:34 -0500

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Jon (g-john-i) wrote :
Download full text (4.8 KiB)

Ok,

If it was fixed why didn't the updates in 14.04LTS fix it. I've installed
everything offered up and including yesterday's updates.

Once again, I'm a humble *user*. A lot of this is gobbledegook to me. I
simply reported the bug when my network shares disappeared from
Thunderbird.

Can someone please explain in plain English how my 14.04LTS gets this fix?

Thanks

On 15 Feb 2018 8:11 p.m., "Launchpad Bug Tracker" <
<email address hidden>> wrote:

> This bug was fixed in the package gtk+3.0 - 3.22.28-1ubuntu1
>
> ---------------
> gtk+3.0 (3.22.28-1ubuntu1) bionic; urgency=medium
>
> * Merge with Debian. Remaining changes:
> + Install a settings.ini file to set our themes
> + Enable Mir backend
> + Update debian/libgtk-3-0.symbols
> + debian/control.in:
> - Build-depend on adwaita-icon-theme-full for icon name check test
> + debian/rules: Mark additional known test failures:
> - box-shadow-changes-modify-clip.ui
> - label-text-shadow-changes-modify-clip.ui
> + Ubuntu-specific patches:
> - 073_treeview_almost_fixed.patch
> - bzg_gtkcellrenderer_grabbing_modifier.patch
> - ubuntu_gtk_custom_menu_items.patch
> - print-dialog-show-options-of-remote-dnssd-printers.patch
> - uimanager-guard-against-nested-node-updates.patch
> - x-canonical-accel.patch
> - message-dialog-restore-traditional-look-on-unity.patch
> - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
> - restore_filechooser_typeaheadfind.patch
> - 0001-calendar-always-emit-day-selected-once.patch
> - 0001-gtkwindow-set-transparent-background-color.patch
> - ubuntu_fileselector_behaviour.patch
> - unity-border-radius.patch
> - unity-headerbar-maximized-mode.patch
> - gtksocket-unscale-before-sending-configurenotify.patch
> - no_content_hub.patch
>
> gtk+3.0 (3.22.28-1) unstable; urgency=medium
>
> * New upstream release (LP: #1698270) (LP: #1714518)
> * Update Vcs fields for conversion to git
> * Add debian/gbp.conf
> * Bump Standards-Version to 4.1.3
> * Update Vcs fields for migration to https://salsa.debian.org/
> * Drop git_text-view-support-emoji-chooser.patch: Applied in new release
>
> -- Jeremy Bicha <email address hidden> Thu, 15 Feb 2018 10:15:34 -0500
>
> ** Changed in: gtk+3.0 (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1694129).
> https://bugs.launchpad.net/bugs/1714518
>
> Title:
> GTK+3 doesn't show FUSE/GVFS, smb (SMB/CIFS), sftp (SFTP/SSH) network
> shares in file chooser
>
> Status in GTK+:
> Fix Released
> Status in gtk+3.0 package in Ubuntu:
> Fix Released
> Status in gtk+3.0 source package in Trusty:
> Triaged
> Status in gtk+3.0 source package in Xenial:
> Triaged
> Status in gtk+3.0 source package in Artful:
> Triaged
>
> Bug description:
> Steps to reproduce:
> 1. Install any Gtk3 application such as Firefox or Chromium which use
> modern file-chooser dialog.
> 2. Mount network location through fstab or file-manager ("smb://" =
> SMB/CIFS, "sftp://" = SFTP/SSH and so on)
> 3...

Read more...

Jeremy Bicha (jbicha) wrote :

Jon, the changelog message said that this bug was fixed in bionic (which is Ubuntu 18.04 Alpha). The bug is not fixed in Ubuntu 14.04 LTS "Trusty" yet.

Maybe it's a bit more clear if you look at the bug page: https://launchpad.net/bugs/1714518

I closed the Thunderbird task because we believe this bug can be fixed in the gtk+3.0 package without needing to update Thunderbird and several other packages.

Michele Bordi (mik-bordi) wrote :

Thank you to all for your work, from another "simple user" really looking
into this fix update :)

2018-02-16 15:20 GMT+01:00 Jeremy Bicha <email address hidden>:

> Jon, the changelog message said that this bug was fixed in bionic (which
> is Ubuntu 18.04 Alpha). The bug is not fixed in Ubuntu 14.04 LTS
> "Trusty" yet.
>
> Maybe it's a bit more clear if you look at the bug page:
> https://launchpad.net/bugs/1714518
>
> I closed the Thunderbird task because we believe this bug can be fixed
> in the gtk+3.0 package without needing to update Thunderbird and several
> other packages.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1579543).
> https://bugs.launchpad.net/bugs/1714518
>
> Title:
> GTK+3 doesn't show FUSE/GVFS, smb (SMB/CIFS), sftp (SFTP/SSH) network
> shares in file chooser
>
> Status in GTK+:
> Fix Released
> Status in gtk+3.0 package in Ubuntu:
> Fix Released
> Status in gtk+3.0 source package in Trusty:
> Triaged
> Status in gtk+3.0 source package in Xenial:
> Triaged
> Status in gtk+3.0 source package in Artful:
> Triaged
>
> Bug description:
> Steps to reproduce:
> 1. Install any Gtk3 application such as Firefox or Chromium which use
> modern file-chooser dialog.
> 2. Mount network location through fstab or file-manager ("smb://" =
> SMB/CIFS, "sftp://" = SFTP/SSH and so on)
> 3. Try to save/open file to/from the remote location from Gtk3
> application.
>
> Expected results:
> * user is able to find network folder and save/open file to/from it with
> GtkFileChooser dialog
>
> Actual results:
> * user is unable to find network folder and save/open file to/from it
> with GtkFileChooser dialog and many user applications are affected
>
> ------------------------------------------------------------
> -------------
> Original bug description is below:
>
> GTK+3 doesn't show FUSE network shares in file chooser - it used to do
> so in GTK+2, and the GTK+3 documentation still mentions it should do
> it.
>
> In the mean time, every user of every application switching to GTK+3
> -- including Chromium, at some point between 58 and 60 -- (a change
> which happened in 16.04 LTS!!), loses the functionality to open or
> save directly to a network share.
>
> I had chosen 16.04 LTS for deploying our workstations at work, and my 50
> users have been suddenly unable to do a simple operation they have to do
> dozens of times a day.
> They now have to "buffer" these files to their local filesystem when
> saving them and before uploading them, and then copy them to the company's
> network shares.
> They were already a little bit grumpy when it stopped working with
> Firefox, and are now really side-eyeing me when they apply updates and find
> Chromium broken.
>
> I have reported the bug upstream and provided a patch to fix this. I
> hope you'll be able and willing to include it to Ubuntu's GTK+3
> package.
>
> Thanks in advance.
>
> Colin
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/1714518/+subscriptions
>

Jon (g-john-i) wrote :

+1, Thanks for the clarification Jeremy!

On 16 February 2018 at 15:00, Michele Bordi <email address hidden> wrote:

> Thank you to all for your work, from another "simple user" really looking
> into this fix update :)
>
> 2018-02-16 15:20 GMT+01:00 Jeremy Bicha <email address hidden>:
>
> > Jon, the changelog message said that this bug was fixed in bionic (which
> > is Ubuntu 18.04 Alpha). The bug is not fixed in Ubuntu 14.04 LTS
> > "Trusty" yet.
> >
> > Maybe it's a bit more clear if you look at the bug page:
> > https://launchpad.net/bugs/1714518
> >
> > I closed the Thunderbird task because we believe this bug can be fixed
> > in the gtk+3.0 package without needing to update Thunderbird and several
> > other packages.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1579543).
> > https://bugs.launchpad.net/bugs/1714518
> >
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.