Remove hard dependencies on libmir* in relevant packages

Bug #1701747 reported by Nazar Mokrynskyi on 2017-06-30
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Wishlist
Unassigned
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

I think everyone will agree that Mir is not used by majority of users.
So I don't understand why many packages have hard dependencies on libmir* packages. I don't want them in my system because I'll never user them.
Make them optional, please.

summary: - Remove dependencies on libmir* in relevant packages
+ Remove hard dependencies on libmir* in relevant packages
Daniel van Vugt (vanvugt) wrote :

This sounds perfectly reasonable. However the bug is logged against project "Mir" and needs to instead be logged against the affected packages. Please add tasks (or just list) the packages whose dependencies you would like fixed. Thanks...

Changed in mir:
status: New → Incomplete
Nazar Mokrynskyi (nazar-pc) wrote :

I think in 17.10 these 2 packages are the only ones that require libmir* packages:
libgtk-3-0
libegl1-mesa

Created corresponding issues here:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1702000
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1702001

Daniel van Vugt (vanvugt) wrote :

Thanks for that.

However Mir is still under active development and is supported in Ubuntu. Mesa is central to that effort and possibly GTK is too. So Mesa will be set to "Won't Fix" for now. And GTK might also follow.

affects: mir → gtk+3.0 (Ubuntu)
Changed in mesa (Ubuntu):
status: New → Won't Fix
Changed in gtk+3.0 (Ubuntu):
status: Incomplete → New
Nazar Mokrynskyi (nazar-pc) wrote :

I have nothing against Mir itself, but why can't those packages be optional dependencies?

Alan Griffiths (alan-griffiths) wrote :

IMO this is a design issue in Mesa - it hard links to all the backends enabled at build time. That also means, for example that a Mir based system pulls in a bunch of X libraries. The same is true for Wayland. A runtime dependency would be more satisfactory for everyone.

Sebastien Bacher (seb128) wrote :

the libraries are tiny, why are they an issue for you? it's the way linux binaries work, if you use symbols from a library it needs to be installed. the library doesn't pull in the server though so it shouldn't be an issue. you have a probably other libraries installed on your system for similar reasons since that's something quite usual. Nautilus for example leads to have libsmb installed for people who need to connect to samba/windows remote share...

Nazar Mokrynskyi (nazar-pc) wrote :

I just want to keep my system clean. I don't have ubuntu-desktop and lots of standard packages and noticed these Mir-related packages but was unable to remove them. Not a big deal in general, but still a number of packages that will never be used.

Also installation ISO contains these packages and everyone downloads something that will not be used in most if not all desktop setups.

Sebastien Bacher (seb128) wrote :

right, as said libraries being used need to stay installed, you have remote share support in the filemanager even if you never use that, you have audio libraries installed even if you don't have a sound device, etc.
That said the GTK mir backend is unmaintained and we might decide to stop building it this cycle, which would resolve your immediate issue

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.28-1ubuntu3

---------------
gtk+3.0 (3.22.28-1ubuntu3) bionic; urgency=medium

  * debian/control.in, debian/libgtk-3-0.symbols, debian/rules:
    - disable the MIR backend, it's unmaintained and the mir team
      confirmed they don't it since they talk wayland now.
      That removes the dependency of mir libraries (lp: #1701747)
  * debian/patches/no_content_hub.patch:
    - removed, that was only needed to be able to build the mir backend

 -- Sebastien Bacher <email address hidden> Thu, 22 Feb 2018 16:00:01 +0100

Changed in gtk+3.0 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers