gnome-terminal constantly logs "Unable to load blank_cursor from the cursor theme" under gnome/wayland

Bug #1681910 reported by Jamie Strandboge on 2017-04-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned
Artful
Low
Unassigned

Bug Description

Impact
======
The systemd journal gets full of useless messages about "Unable to load blank_cursor from the cursor theme" when using GNOME Terminal in Wayland on Ubuntu 17.10. Ubuntu 17.10 uses Wayland by default when the hardware supports it.

Test Case
=========
1.Install the gtk3 updates to Ubuntu 17.10.
2. Log out then log into "Ubuntu" or "GNOME" on a computer that supports Wayland.
3. Open the default terminal app.
4. Verify that you are running Wayland by running this command. If there is output, you are running Wayland.

 env | grep -i wayland

5. Run this command to check for the useless messages from gnome-terminal:

journalctl -f

Regression Potential
===================
This fix is part of the gtk3 3.22.25 update (LP: #1728421) and seems unlikely to cause problems.

https://git.gnome.org/browse/gtk+/commit/?h=gtk-3-22&id=fc741adbb

Original Bug Report
===================
Under GNOME/Wayland, regardless of cursor theme (I'm using 'DMZ-White', but confirmed with 'Adwaita'), whenever the terminal obtains focus and the user starts entering input, gnome-terminal will generate two log entries:

Apr 11 13:39:22 localhost gnome-terminal-[28979]: Unable to load blank_cursor from the cursor theme
Apr 11 13:39:22 localhost gnome-terminal-[28979]: Unable to load blank_cursor from the cursor theme

This seems to be:
https://bugzilla.redhat.com/show_bug.cgi?id=1417490

and related to:
https://bugzilla.gnome.org/show_bug.cgi?id=775217

(though in Ubuntu 17.04 the log doesn't contain 'gdkcursor-wayland.c:170' like in the gnome bug.

Changed in gnome-terminal:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: wayland
Jamie Strandboge (jdstrand) wrote :

This bug is *super* annoying. Here is a workaround to make rsyslog discard this messages:

Create /etc/rsyslog.d/49-lp1681910.conf with:
# workaround LP: #1681910
:msg,contains,"Unable to load blank_cursor from the cursor theme" ~
& stop

Restart rsyslog: sudo service rsyslog restart

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Changed in gnome-terminal:
status: Confirmed → Fix Released
Jamie Strandboge (jdstrand) wrote :
affects: gnome-terminal → gtk
affects: gnome-terminal (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Triaged
Jamie Strandboge (jdstrand) wrote :

Here is the upstream patch as a debdiff that I compiled locally. Preliminary testing shows that it fixes the gnome-terminal issue. I won't be chasing this all the way through the SRU process, but hope that you consider it in a future 17.10 SRU.

Jeremy Bicha (jbicha) on 2017-10-26
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: Triaged → Fix Committed
Changed in gtk+3.0 (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Low
tags: added: patch
Jeremy Bicha (jbicha) wrote :

fixed for Ubuntu 18.04 LTS with gtk+ 3.22.25. I'm proposing updating Ubuntu 17.10 to gtk+ 3.22.25 in LP: #1728421

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-10-30
description: updated
Jeremy Bicha (jbicha) on 2017-10-30
Changed in gtk+3.0 (Ubuntu Artful):
status: Triaged → In Progress

Hello Jamie, or anyone else affected,

Accepted gtk+3.0 into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.22.25-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Jeremy Bicha (jbicha) wrote :

I can no longer duplicate this bug with 3.22.25-0ubuntu0.1 on Ubuntu 17.10.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.25-0ubuntu0.1

---------------
gtk+3.0 (3.22.25-0ubuntu0.1) artful; urgency=medium

  [ Simon McVittie ]
  * New upstream release (LP: #1728421)
    - Fix tiling behaviour with Mutter/Shell 3.26 (Closes: #879566)
    - Fix crash when adding Google online account (LP: #1720400)
    - Fixes log spam about cursor when running gnome-terminal on Wayland
      (LP: #1681910)
    - Update symbols file
    - d/p/0001-Adwaita-Fix-typo-.backgrounf-.background.patch,
      d/p/0002-theme-Fix-Adwaita-headerbars.patch,
      d/p/0003-display-x11-Unset-tiled-state-if-_GTK_EDGE_CONSTRAIN.patch:
      Drop patches, applied upstream
    - d/p/gdk-wayland-protocol-server-decoration.patch:
      Add server-decoration.xml from upstream git. It is missing from the
      tarball release.

  [ Jeremy Bicha ]
  * Drop 0004_fix-gtkentry-wayland-regression.path:
    Because this caused a totem regression, we're fixing the
    bug in mutter instead.
  * Drop some unapplied patches from the package source

 -- Jeremy Bicha <email address hidden> Mon, 30 Oct 2017 16:07:23 -0400

Changed in gtk+3.0 (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.