opening menu for certain types of GtkComboBox causes Gdk-CRITICAL assertion 'GDK_IS_WINDOW (window)' failed

Bug #1647174 reported by Triniton Adam on 2016-12-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Debian)
Fix Released
Unknown
gtk+3.0 (Ubuntu)
Medium
Unassigned

Bug Description

It happens when try to open any ComboBox or a CellRendererCombo:

Gdk-CRITICAL **: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gtk+3.0 (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) on 2016-12-10
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
tags: added: zesty
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Medium
Changed in gtk+3.0 (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.5-1ubuntu1

---------------
gtk+3.0 (3.22.5-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1647174). Remaining changes:
    + Install the settings.ini file to set our themes
    + Install a gsettings override to start filechoosers in the cwd
    + Enable Mir backend
    + debian/control.in:
      - Build-depend on adwaita-icon-theme-full for icon name check test
    + debian/rules: Mark additional known test failures:
      - box-shadow-changes-modify-clip.ui
      - label-text-shadow-changes-modify-clip.ui
    + Ubuntu-specific patches:
      - 073_treeview_almost_fixed.patch
      - 074_eventbox_scroll_mask.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind
      - 0001-calendar-always-emit-day-selected-once.patch
      - 0001-gtkwindow-set-transparent-background-color.patch
      - ubuntu_fileselector_behaviour.patch
      - unity-border-radius.patch
      - unity-headerbar-maximized-mode.patch
  * Drop 'Use dh_strip --dbgsym-migration for proper upgrades'
    added in 3.22.4-1ubuntu1 since there is no file conflict here.
    Anyone with obsolete -dbg packages installed will need to manually
    remove the old -dbg packages, enable the ddebs repository, and
    install the appropriate -dbgsym packages.

gtk+3.0 (3.22.5-1) unstable; urgency=medium

  * New upstream release.

 -- Jeremy Bicha <email address hidden> Sat, 10 Dec 2016 13:52:57 -0500

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.