Strange font issue after awakening from suspend

Bug #1596698 reported by Wise Melon on 2016-06-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Unknown
High
Ubuntu GNOME
Undecided
Unassigned
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

When I awoke my computer from suspend last week on Thursday (23/06/2016) I found that all the text from all the title bars was missing, so I restarted gnome-shell as this normally fixes such problems, doing so seemed to make some text appear, but most not, as you can see from these images until I restarted my machine it was almost impossible to use:

    System_Monitor_No_Text.png
    Shutter_Main_Window_Font_Issue.png
    File_Chooser_Font_Issue.png
    Title_Bar_Partly_Missing.png
    Settings_Text_Issue.png

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libgtk-3-0 3.20.6-1ubuntu1~ppa1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Jun 27 21:23:02 2016
InstallationDate: Installed on 2016-05-15 (43 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)

summary: - Strange font issue after awake from suspend
+ Strange font issue after awakening from suspend
Changed in gtk:
importance: Unknown → High
status: Unknown → Confirmed
Tim Lunn (darkxst) wrote :

does this only happen with the dark theme?

Changed in ubuntu-gnome:
milestone: none → yakkety
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
status: New → Triaged

I will test it and get back to you when it next occurs, but Firefox doesn't use the dark theme, it simply refuses as Mozilla decided not to get it to use it. And that's where I first noticed the issue so does that count?

Changed in ubuntu-gnome:
status: New → Confirmed

Actually, I remember when the bug occurred going into the gnome-tweak-tool and changing the theme as well as turning the dark theme off. But neither change made any difference to the fonts problem.

Changed in gtk:
status: Confirmed → Unknown

This issue has now occurred again after awakening from a suspend.

Upstream said it's likely to be a driver problem, where should I report this issue then? And is there any way to reload the driver or something to fix this issue without having to completely restart the machine as it is a bit annoying?

It should also be noted that this issue does not seem to affect gnome-shell areas, that is it is not seemingly present in the Activities Overview nor the Top Bar.

Here I have the same issues, usually after suspend.
Had it on the mate-Desktop too, so it might not be very gnome3-specific.

There are some messages in the syslog, maybe that can help to further dig into a direction?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.