Update to 3.20 needs work and coordination

Bug #1576576 reported by Sebastien Bacher on 2016-04-29
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
adwaita-icon-theme (Ubuntu)
Wishlist
Unassigned
gtk+2.0 (Ubuntu)
Wishlist
Unassigned
gtk+3.0 (Ubuntu)
Wishlist
Unassigned
ubuntu-settings (Ubuntu)
Wishlist
Unassigned

Bug Description

The current upstream stable/Debian version is 3.20 but that includes quite some changes in the css handling which means we are going to need to update/fix the unity themes and make sure you main application look fine before landing.
The transition needs to be prepared in a staging ppa before being considered, help is welcome since it's likely the desktop team is not going to have lot of cycles to work on that.

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
summary: - Update to 3.20
+ Update to 3.20 needs work and coordination
Tim Lunn (darkxst) on 2016-04-29
Changed in ubuntu-gnome:
milestone: none → yakkety
dino99 (9d9) wrote :

Here is my feedback with a gnome-shell session. I'm using gnome3-staging ppa since a couple months now, and have not met issue.
The journalctl indeed log some warnings, but have no sad viewable effect:

org.gnome.Shell.desktop[1910]: (gnome-shell:1910): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:31:18: The :insensitive pseudo-class is deprecated. Use :disabled instead.

org.gnome.Shell.desktop[1910]: (gnome-shell:1910): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:226:33: The :focused pseudo-class is deprecated. Use :focus instead.

 org.gnome.Shell.desktop[1910]: (gnome-shell:1910): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:16:33: The style property GtkMenu:horizontal-padding is deprecated and shouldn't be used anymore. It will be removed in a future version

..... The style property GtkMenu:vertical-padding is deprecated and shouldn't be used anymore. It will be removed in a future version
.... The style property GtkMenuItem:arrow-scaling is deprecated and shouldn't be used anymore. It will be removed in a future version
...The style property GtkNotebook:tab-overlap is deprecated and shouldn't be used anymore. It will be removed in a future version
... The style property GtkWidget:separator-width is deprecated and shouldn't be used anymore. It will be removed in a future version
....The style property GtkWidget:separator-height is deprecated and shouldn't be used anymore. It will be removed in a future version
...The style property GtkWidget:wide-separators is deprecated and shouldn't be used anymore. It will be removed in a future version
....The style property GtkWidget:link-color is deprecated and shouldn't be used anymore. It will be removed in a future version
...The style property GtkWidget:visited-link-color is deprecated and shouldn't be used anymore. It will be removed in a future version
.... unity.css:109:15: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'
.... gedit.css:65:67: The :prelight pseudo-class is deprecated. Use :hover instead.
......

That is: lot of warning spams but nothing else.

Tim Lunn (darkxst) wrote :

Dino99, the GNOME Stuff is not really an issue upstream are already on that, it would be the unity/xfce themes and other apps that are installed by default but not GNOME apps.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed
Simon Steinbeiß (ochosi) wrote :

Not that this is really avoidable - more a question of time and effort - but the Gtk3.20 update will most likely result in the need for a rewrite of the default Xubuntu Gtk+ theme (Greybird), but as its codebase is comparable to that of the light-themes those would be hit by the same fate.

Naturally we can all switch to new and different themes, which already support 3.20. However this is something that shouldn't go unmentioned and unplanned.

Changed in firefox:
status: Confirmed → Fix Released
Robert Ancell (robert-ancell) wrote :

Blocking babob 3.20 update (bug 1580849)

Robert Ancell (robert-ancell) wrote :

Blocking gnome-contacts 3.20 update (bug 1581238)

Robert Ancell (robert-ancell) wrote :

Blocks eog 3.20 update (bug 1580007)

Robert Ancell (robert-ancell) wrote :

Blocking devhelp 3.20 update (bug 1582440)

Robert Ancell (robert-ancell) wrote :

Blocking gedit 3.20 update (bug 1582449)

Robert Ancell (robert-ancell) wrote :

Blocking gnome-logs 3.20 update (bug 1582454)

Sebastien Bacher (seb128) wrote :

gtk 3.19 seems to create g-i api change, see bug #1548425 in update-manager, we might want to have a look to what function changes and grep the archive for their use

Jeremy Bicha (jbicha) wrote :

Theming! Tracking bugs...
Ubuntu:
bug 1593048

Ubuntu MATE:
mate-themes is updated for GTK 3.20; it just needs to be synced from Debian when ready.
But Ubuntu MATE actually uses ubuntu-mate-themes by default, derived from ubuntu-themes, bug 1593054

Xubuntu:
greybird needs to be updated, see bug 1586691
numix-gtk-theme is updated but the update needs to be packaged

Ubuntu GNOME:
gnome-themes-standard, done in the GNOME 3 Staging PPA

tags: added: needs-packaging
Changed in ubuntu-gnome:
status: New → Confirmed
Iain Lane (laney) wrote :

I'm uploading this to proposed today, but let's keep it blocked there until more things are ready.

tags: added: block-proposed
Iain Lane (laney) wrote :

gtk2 because the merge brings package reorganisation

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Update to 3.20 needs work and coordination
+ [needs-packaging] Update to 3.20 needs work and coordination
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Wishlist
Iain Lane (laney) on 2016-08-01
Changed in adwaita-icon-theme (Ubuntu):
status: New → Confirmed

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in adwaita-icon-theme (Ubuntu):
importance: Undecided → Wishlist
Iain Lane (laney) wrote :

I added ubuntu-settings because you get warnings when upgrading otherwise

Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu-settings (Ubuntu):
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) on 2016-08-03
tags: removed: needs-packaging
Iain Lane (laney) wrote :

Let's do this

tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 16.10.1

---------------
ubuntu-settings (16.10.1) yakkety; urgency=medium

  * data/ubuntu-settings.override: Some changes for Nautilus 3.20 (LP:
    #1576576):
    - Do not open subfolders on hover
    - Change the default zoom level to small
  * Remove ancient Conflicts & Replaces.

 -- Iain Lane <email address hidden> Tue, 02 Aug 2016 12:10:40 +0100

Changed in ubuntu-settings (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adwaita-icon-theme - 3.20-3ubuntu2

---------------
adwaita-icon-theme (3.20-3ubuntu2) yakkety; urgency=medium

  * No-change rebuild in PPA to work around uninstallable BDs.

adwaita-icon-theme (3.20-3ubuntu1) yakkety; urgency=low

  * Merge from Debian unstable (LP: #1576576), remaining changes:
    - Split into adwaita-icon-theme and adwaita-icon-theme-full.
    - debian/rules: No need to drop /usr/share/locale, we don't install it.
  * debian/control{,.in}: In a PPA upload, I forgot the tilde on the version
    which meant that the PPA version of -full wasn't installable (but the
    archive one would have been). Let's try to Break and Replace the
    binary:Version instead so it always works, as long as apt can deal with
    that.

adwaita-icon-theme (3.20-3) unstable; urgency=medium

  * Replace dependency on libgtk-3-bin with gtk-update-icon-cache to break a
    dependency cycle when building src:gtk+3.0, see #824999. (Closes: #763669)
  * Bump Standards-Version to 3.9.8.
  * Bump debhelper compatibility level to 9.

adwaita-icon-theme (3.20-2) unstable; urgency=medium

  * Upload to unstable.
  * Drop Build-Depends on icon-naming-utils, no longer needed.

adwaita-icon-theme (3.20-1) experimental; urgency=medium

  * New upstream release.

adwaita-icon-theme (3.19.91-1) experimental; urgency=medium

  * New upstream release.
  * Drop intltool build-dependency
    - upstream no longer builds translations.
  * debian/rules: drop removal of translations which no longer gets built.
  * Bump Standards-Version to 3.9.7.

 -- Iain Lane <email address hidden> Mon, 01 Aug 2016 10:36:59 +0100

Changed in adwaita-icon-theme (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package gtk+3.0 - 3.20.6-1ubuntu1

---------------
gtk+3.0 (3.20.6-1ubuntu1) yakkety; urgency=medium

  * Merge with Debian (LP: #1576576). Remaining changes:
    + Install the settings.ini file to set our themes
    + Enable parallel builds
    + Ubuntu specific patches:
      - 073_treeview_almost_fixed.patch
      - 074_eventbox_scroll_mask.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind
      - 0001-calendar-always-emit-day-selected-once.patch
      - 0001-gtkwindow-set-transparent-background-color.patch
      - ubuntu_fileselector_behaviour.patch
      - unity-border-radius.patch
      - unity-headerbar-maximized-mode.patch
    + Install a gsettings override to start filechoosers in the cwd
    + Enable Mir backend

gtk+3.0 (3.20.6-1) unstable; urgency=medium

  * New upstream release.
  * Drop revert-scrolledwindow-Remove-child-before-destroying.patch, merged
    upstream.
  * Re-enable test-suite.

gtk+3.0 (3.20.5-4) unstable; urgency=medium

  * Work around a bug in cdbs which causes the package to FTBFS; see #825135
    for further details.

gtk+3.0 (3.20.5-3) unstable; urgency=medium

  * Make it simpler to bootstrap the package by marking the build dependencies
    which are required to run the test-suite with <!nocheck>.
    (Closes: #747392)
  * Bump Build-Depends on debhelper to (>= 9.20141010) and dpkg-dev to
    (>= 1.17.14) for build dependency restrictions support.
  * Temporarily disable the test suite (and its build-dependencies) to allow
    building the new gtk-update-icon-cache package. Our buildds don't support
    build profiles yet, so we'll have to bootstrap manually for now.

gtk+3.0 (3.20.5-2) unstable; urgency=medium

  * Split gtk-update-icon-cache utility out of libgtk-3-bin into a separate
    package called gtk-update-icon-cache to break a dependency cycle with
    adwaita-icon-theme when building the package. (Closes: #824999)
    As the gtk-update-icon-cache binary doesn't actually have any libgtk-3-0
    dependency, there is no longer a reason to ship a gtk2 and gtk3 variant.
    So from now on we will only ship one implementation built from src:gtk+3.0
    and drop the Debian specific -3.0 suffix. To simplify the transition make
    libgtk-3-bin depend on gtk-update-icon-cache. Once all theme packages have
    been updated, this dependency can be dropped.
  * Cherry-pick patch from upstream Git which reverts a commit that was
    causing crashes in the filechooser in some applications.

gtk+3.0 (3.20.5-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.
  * Bump Standards-Version to 3.9.8.

gtk+3.0 (3.20.4-1) unstable; urgency=medium

  * New upstream release.

gtk+3.0 (3.20.3-2) unstable; urgency=medium

  * Restore debian/patches/reftest-known-fail.patch so we can mark known
    failing te...

Read more...

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package gtk+2.0 - 2.24.30-4ubuntu1

---------------
gtk+2.0 (2.24.30-4ubuntu1) yakkety; urgency=medium

  * Merge with Debian unstable (LP: #1576576). Remaining changes:
    - d/libgtk2.0-0.symbols: update symbols file.
    - d/libgtk2.0-dev.manpages: add gtk-builder-convert.1 manpage.
    - d/rules: enable manpage.
    - d/update-icon-caches: run with "--include-image-data" flag.
    - add Ubuntu patches:
      + debian/patches/012_ubuntu-set-grab-add.patch
        - Added ubuntu_gtk_widget_set_has_grab so we can grab sliders and
          things in menus, needed by ido
      + debian/patches/062_dnd_menubar.patch:
        - Allow click on menubars for dnd
      + debian/patches/063_treeview_almost_fixed.patch:
        - Add an ubuntu-almost-fixed-height-mode property, (required for
          software-center)
      + debian/patches/071_no_offscreen_widgets_grabbing.patch:
        - Don't let offscreen widgets do grabbing
      + debian/patches/090_logging_file_saves.patch:
        - improve the logging of saved files
      + debian/patches/092_default_to_xdg_document_dir.patch:
        - Use $XDG_DOCUMENTS_DIR as default directory rather than the home
          directory for the 'Print to File' function.
      + debian/patches/093_gtk3_gtkimage_fallbacks_use.patch:
        - Backported gtk3 patch to add a "use-fallback" property to GtkImage,
          using it "icon-name and GIcon type of GtkImages can use automatic
          fallback names.", it will be useful for the indicator stack
      + debian/patches/095_git_menus_scrolling.patch:
        - backported gtk3 commit to fix menu scrolling issues
      + debian/patches/096_git_gtkprintsettings.patch:
        - upstream git commit backported from the gtk3 serie, don't ignore the
          gtkprintsettings resolution settings
      + debian/patches/097_statusicon_image_fallback.patch: Make GtkStatusIcon
        images use fallbacks by default if the property is available.
      + debian/patches/098_multiarch_module_path.patch:
        - Fallback to the pre-multiarch directory for compatibility
      + debian/patches/099_printer_filename_fix.patch
        - Fix to the print dialog for print to file, make sure a non-hidden filename
          is the default
      + debian/patches/100_overlay_scrollbar_loading.patch
        - support for dynamically loading overlay scrollbars
      + debian/patches/gtk-shell-shows-menubar.patch:
        - list gtk-shell-shows-menubar setting, that's required to have the local
          menubars hidding under unity in favor of the unity ones,
      + debian/patches/print-dialog-show-options-of-remote-dnssd-printers.patch:
        - Make printing on remote DNS-SD/Bonjour-shared printers work
      + debian/patches/backport_search_printer_location.patch
        - The list of printers should be searchable/sortable
      + debian/patches/menubar_toolbar_dragging.patch:
        - Allow windows to be dragged using blank spaces in the toolbar as
          well as the menubar
      + debian/patches/use-secrets-service-for-cups-auth_info.patch

gtk+2.0 (2.24.30-4) unstable; urgency=medium

  [ Laurent Bigonville ]
  * debian/control.in: Bump hi...

Read more...

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
affects: ubuntu-gnome → ubuntu
Changed in ubuntu:
milestone: yakkety → none
no longer affects: ubuntu
affects: firefox → ubuntu
Changed in ubuntu:
importance: Medium → Undecided
status: Fix Released → New
no longer affects: ubuntu
summary: - [needs-packaging] Update to 3.20 needs work and coordination
+ Update to 3.20 needs work and coordination
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers