unity dialogues split between 2 monitors

Bug #1575128 reported by Jamison Phillips on 2016-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Medium
Unassigned
xorg (Ubuntu)
Low
Unassigned

Bug Description

Since upgrading from Ubuntu 15.10 to 16.04, Unity is now shown across both my monitors in a hard to use manner: unity dialogues, such as the log-out and shutdown popups, are displayed centered between both monitors, so the left half is on one monitor, and the right half on another. Also, the unity top panel indicators and clock used to be on both monitors, but are now only on the right monitor.

More info since it is likely relevant:
I have a Dell laptop with an NVidia Prime GPU and Intel built-in GPU. This laptop has always been trouble configuring for dual monitors. The nvidia-settings controls only shows one monitor, though it is supposed to show two. I have never been able to get a working xorg.conf for the two monitors, despited 2 days of trying (and I am a software developer well versed in reading docs). The instructions in the nvidia docs simply don't work as stated for this hardware (Dell XPS 17 L702X). Purging all graphics settings doesn't help. Upgrading to a newer nvidia driver didn't help (I've tried the latest official nvidia package as well as one newer). As a result, I've been using an xrandr command and compiz display settings since Ubuntu 15.10. This worked perfectly in 15.10. But, as stated, the unity top panel and dialogues are not working properly in 16.04.

I tried Nvidia 361.42 and 364.19 from the PPA at http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu.

The xrandr command in use is:
xrandr --fb 3520x1080 --output HDMI-0 --preferred --primary --mode 1920x1080 --pos 0x0 --panning 3520x1080+0+0/3520x1080+0+0/0/0/-3520/0 --output LVDS-1 --mode 1600x900 --pos 1920x180 --panning 0x0

(I know the fb sets up a wide virtual screen, but as stated, in 15.10, that worked perfectly for unity)

In compiz display settings I have the following "Outputs" set:
1920x1080+0+0
1600x900+1920+180

It would appear in 16.04, Unity ignores the compiz outputs whereas in 15.10 it does not. But that's just a guess.

Sorry I cannot get a screenshot of the dialogues. They seem to block Ubuntu's screenshot program due to their modal nature.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 364.19 Tue Apr 19 14:44:55 PDT 2016
 GCC version: gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2)
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Apr 26 07:01:26 2016
DistUpgraded: 2016-04-25 10:00:42,012 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.2.0-35-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-21-generic, x86_64: installed
 nvidia-364, 364.19, 4.4.0-21-generic, x86_64: installed
 vboxhost, 5.0.18, 4.2.0-35-generic, x86_64: installed
 vboxhost, 5.0.18, 4.4.0-21-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:0571]
 NVIDIA Corporation GF116M [GeForce GT 550M] [10de:1246] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell GF116M [GeForce GT 550M] [1028:0571]
InstallationDate: Installed on 2016-03-22 (35 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Dell Inc. Dell System XPS L702X
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=f4247c67-52eb-4dd4-988d-b09205d3c0a1 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to xenial on 2016-04-25 (0 days ago)
dmi.bios.date: 02/22/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0K4H3G
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd02/22/2012:svnDellInc.:pnDellSystemXPSL702X:pvr:rvnDellInc.:rn0K4H3G:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L702X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2

affects: xorg (Ubuntu) → unity (Ubuntu)
Andrea Azzarone (azzar1) wrote :

Can you please run this python script and post here the output?

Changed in unity (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Andrea Azzarone (azzar1) on 2016-04-26
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)

the result of get_screens.py is:

('# monitors: ', 2)
3520x1080+0+0
1600x900+1920+180

------

This clearly shows the issue. The first monitor res should be 1920 wide, not 3520. Any suggestions on how to fix it?

Andrea Azzarone (azzar1) wrote :

What's the output of "xrandr"?

Download full text (15.2 KiB)

output of "$ xrandr --verbose":

Screen 0: minimum 8 x 8, current 3520 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (0x2c1) normal (normal left inverted right x axis y axis) 598mm x 336mm panning 3520x1080+0+0 tracking 3520x1080+0+0 border 0/0/-3520/0
 Identifier: 0x2c0
 Timestamp: 212002
 Subpixel: unknown
 Gamma: 1.0:1.0:1.0
 Brightness: 1.0
 Clones:
 CRTC: 0
 CRTCs: 0 1
 Panning: 3520x1080+0+0
 Tracking: 3520x1080+0+0
 Border: 0/0/-3520/0
 Transform: 1.000000 0.000000 0.000000
             0.000000 1.000000 0.000000
             0.000000 0.000000 1.000000
            filter:
 EDID:
  00ffffffffffff004c2ddc084e51345a
  0f160103803c22782af831a4564f9d27
  0f5054bfef80714f81c0810081809500
  a9c0b3000101023a801871382d40582c
  450056502100001e011d007251d01e20
  6e28550056502100001e000000fd0032
  4b1e5111000a202020202020000000fc
  00533237423335300a2020202020012e
  020311b14690041f13031265030c0010
  00011d00bc52d01e20b8285540565021
  00001e8c0ad090204031200c40550056
  50210000188c0ad08a20e02d10103e96
  00565021000018000000000000000000
  00000000000000000000000000000000
  00000000000000000000000000000000
  000000000000000000000000000000e9
 BorderDimensions: 4
  supported: 4
 Border: 0 0 0 0
  range: (0, 65535)
 SignalFormat: TMDS
  supported: TMDS
 ConnectorType: HDMI
 ConnectorNumber: 0
 _ConnectorLocation: 0
  1920x1080 (0x2c1) 148.500MHz +HSync +VSync *current +preferred
        h: width 1920 start 2008 end 2052 total 2200 skew 0 clock 67.50KHz
        v: height 1080 start 1084 end 1089 total 1125 clock 60.00Hz
  1920x1080 (0x2c2) 148.350MHz +HSync +VSync
        h: width 1920 start 2008 end 2052 total 2200 skew 0 clock 67.43KHz
        v: height 1080 start 1084 end 1089 total 1125 clock 59.94Hz
  1920x1080 (0x2c3) 148.500MHz +HSync +VSync
        h: width 1920 start 2448 end 2492 total 2640 skew 0 clock 56.25KHz
        v: height 1080 start 1084 end 1089 total 1125 clock 50.00Hz
  1680x1050 (0x2c4) 146.250MHz -HSync +VSync
        h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.29KHz
        v: height 1050 start 1053 end 1059 total 1089 clock 59.95Hz
  1600x900 (0x2c5) 108.000MHz +HSync +VSync
        h: width 1600 start 1624 end 1704 total 1800 skew 0 clock 60.00KHz
        v: height 900 start 901 end 904 total 1000 clock 60.00Hz
  1440x900 (0x47) 106.500MHz -HSync +VSync
        h: width 1440 start 1520 end 1672 total 1904 skew 0 clock 55.93KHz
        v: height 900 start 903 end 909 total 934 clock 59.89Hz
  1280x1024 (0x2c6) 135.000MHz +HSync +VSync
        h: width 1280 start 1296 end 1440 total 1688 skew 0 clock 79.98KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 75.02Hz
  1280x1024 (0x2c7) 108.000MHz +HSync +VSync
        h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 63.98KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 60.02Hz
  1280x800 (0x2c8) 83.500MHz -HSync +VSync
        h: width 1280 start 1352 end 1480 total 1680 skew 0 clock 49.70KHz
        v: height 800 start 803 en...

Andrea Azzarone (azzar1) wrote :

Ok I'm targeting xorg and gtk/gdk too. I'm not at home right now and I cannot test it on a double monitor setup. I'll work on it next week. Thank you.

Sebastien Bacher (seb128) wrote :

seems like it's handled as a big screen rather than 2, do you get the issue if you configure the screen using the desktop settings?

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Changed in xorg (Ubuntu):
importance: Undecided → Low

Yes.

Additional info:
-The "Detect Displays" button in the "Displays" window shows "Built-in Display" and "Samsung Electric Company 27" both in the top-left corner of the left monitor, overlapping each other.
-I, if I remember correctly, if I do not use xrandr to nullify the panning, that is if I use the Display window for setting the displays, the left most monitor incorrectly pans to the right when the mouse reaches the right monitor space. So the left most monitor acts like it has both monitors' display space.

Andrea Azzarone (azzar1) on 2017-10-13
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.