GtkPlug scaled to half the expected size on HiDPI screens + zesty debdiff

Bug #1572331 reported by marmuta on 2016-04-19
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

Hi,

Marmuta wrote a patch for this issue, that I applied to the gtk+3.0 package shipping currently in the development version of Ubuntu zesty. You will find the corresponding debdiff attached to this bug thread.

Marmuta performed tests with org.gnome.desktop.interface scaling-factor = 2 , where few issues are left for Onboard on hidpi screens, that are not related to gtk, but rather to unity-greeter or gnome-screensaver. He did not notice any issue with scaling-factor = 1.

Can a sponsor please review the debdiff?

Thanks in advance.

Francesco

=============================================================================
Original description:

See attached screen shot. Blue is a GtkPlug, black is a GtkSocket. Source code below.

What I expect to happen is that the GtkPlug has the same size as the GtkSocket.
What actually happens is that GtkPlug only covers a quarter of the area of the GtkSocket.

Impact: Onboard on HiDPI displays is near unusable at login and lock screen, aka unity-greeter and gnome-screensaver. Original bug report here: https://bugs.launchpad.net/bugs/1562734.

Steps to reproduce:
- build plug and socket samples from below
- set display scaling factor to 2
  System Settings -> Display -> Scale for menu and title bars = 2
- run ./socket $(head -1 <(./plug))
-> blue GtkPlug is too small, it should cover all the black

- resize the window
-> at smaller sizes the scaling suddenly corrects itself, at larger ones it's wrong again

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libgtk-3-0 3.18.9-1ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 20 01:48:50 2016
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)

marmuta (marmuta) wrote :
marmuta (marmuta) wrote :
marmuta (marmuta) wrote :
marmuta (marmuta) wrote :

build with:
gcc -o plug plug.c `pkg-config --cflags --libs gtk+-3.0`
gcc -o socket socket.c `pkg-config --cflags --libs gtk+-3.0`

run e.g. as:
./socket $(head -1 <(./plug))

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Low
affects: ubuntu → gtk+3.0 (Ubuntu)
marmuta (marmuta) wrote :
Sebastien Bacher (seb128) wrote :

thanks

Changed in gtk+3.0 (Ubuntu):
status: New → Triaged
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Francesco Fumanti (frafu) wrote :
description: updated
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
description: updated
summary: - GtkPlug scaled to half the expected size on HiDPI screens
+ GtkPlug scaled to half the expected size on HiDPI screens + zesty
+ debdiff
Michael Terry (mterry) wrote :

Thanks Francesco and marmuta! I've uploaded your debdiff to zesty, Francesco, with only one real change: added some DEP3 tags to the patch to point at this bug and upstream.

Jeremy Bicha (jbicha) wrote :

Since this has been uploaded, I'm unsubscribing ubuntu-sponsors. Please resubscribe if you have anything else that needs sponsoring.

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.5-1ubuntu2

---------------
gtk+3.0 (3.22.5-1ubuntu2) zesty; urgency=medium

  * debian/patches:
    - Add gtksocket-unscale-before-sending-configurenotify.patch
      by marmuta (LP: #1572331)

 -- Francesco Fumanti <email address hidden> Tue, 13 Dec 2016 22:41:20 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
marmuta (marmuta) wrote :

The bug has reappeared, I see it on each login again.
The patch was added in 3.22.5-1ubuntu2, but then apparently removed again in 3.22.6-1ubuntu1. No mention in the changelog. Have there been regressions?

Changed in gtk+3.0 (Ubuntu):
status: Fix Released → Confirmed
Jeremy Bicha (jbicha) wrote :

marmuta, thanks for checking on this and letting us know.

The problem here was that the change was accidentally not pushed to the bzr branch we use to maintain Ubuntu's GTK+ package. Because of that, I didn't see the patch when I did the 3.22.6 update.

Re-uploaded to zesty and pushed to bzr this time:
https://code.launchpad.net/~ubuntu-desktop/gtk/ubuntugtk3/

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
marmuta (marmuta) wrote :

Great, thanks Jeremy.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.7-1ubuntu2

---------------
gtk+3.0 (3.22.7-1ubuntu2) zesty; urgency=medium

  * Restore gtksocket-unscale-before-sending-configurenotify.patch:
    - Accidentally dropped in 3.22.6-1ubuntu1 (LP: #1572331)

 -- Jeremy Bicha <email address hidden> Mon, 23 Jan 2017 09:44:28 -0500

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gtk:
status: Confirmed → Incomplete
Changed in gtk:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.