Nautilus: lag after choosing action in top right menu

Bug #1562002 reported by Biji on 2016-03-25
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned
Xenial
Undecided
Dmitry Shachnev

Bug Description

# Impact
This is known to affect Nautilus, but can potentially affect other applications too (the upstream bug has an example test app attached).

See also the duplicate bug 1644393, which is another appearance of the same bug but with other symptoms.

# Proposed Fix
The proposed fix is an upstream commit taken from gtk-3-20 branch:
https://git.gnome.org/browse/gtk+/commit/?id=10c3a2483635d1c1

# Test Case
https://bugzilla.gnome.org/show_bug.cgi?id=769287#c0 has a test case.

# Regression Potential
The bug is fixed in GTK+ 3.20.9, so the fix was already present in the version that shipped with Yakkety. I am not aware of any regressions.

-----------------------------------------------------------------------------
choosing action like New Tab, New Folder, Select Items Matching, will make nautilus lag (unresponsive)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nautilus 1:3.18.4.is.3.14.3-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Mar 25 20:52:21 2016
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'890x550+685+36'"
InstallationDate: Installed on 2016-03-24 (1 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323.1)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Biji (biji) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1562002

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I think that was reported before and specific to GNOME sessions ... do you get the issue under Unity?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Jon (doogie544) wrote :

Unity status is unknown, I only have Ubuntu Gnome installed.

This applies to any action in the menu, "Invert selection" "New Tab" and any other I tested.

This is causing the whole desktop to hang. I opened the system monitor to see if it was causing the processor to hang, upon using an item from the menu, the system monitor's "resources" screen froze for the entire time of the lag-nearly a minute as I recall). When the desktop was working again, you could see where the CPU's had been spiking one at a time to 100% then dropping as the next one spiked for entire history shown (mine is set at 60 seconds)

Sebastien Bacher (seb128) wrote :

That seems to be GNOME specific, maybe something for the Ubuntu GNOME team to work on then...

Jon (doogie544) wrote :

Opened a bug against Ubuntu Gnome for this issue.

https://bugs.launchpad.net/ubuntu-gnome/+bug/1584280

seb128, it is reproducible in unity too, but that button is not visible there by default.

affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in gtk+3.0 (Ubuntu Xenial):
assignee: nobody → Dmitry Shachnev (mitya57)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu Xenial):
status: New → Confirmed
description: updated
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released

Hello Biji, or anyone else affected,

Accepted gtk+3.0 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.18.9-1ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Mantas Kriaučiūnas (mantas) wrote :

I'm confirming, that gtk+3.0 version 3.18.9-1ubuntu3.3 from xenial-proposed fixes nautilus (and GNOME-Desktop) freezing issue after clicking any action in the Nautilus menu button on the right (tested with "Invert selection", "New Tab", "Select All"). Tested in GNOME-flashback and GNOME Shell sessions.

adminas@K101:~$ dpkg -s libgtk-3-0 |grep Ver
Version: 3.18.9-1ubuntu3.3

tags: added: verification-done
removed: verification-needed
Unishop (unishop) wrote :

I can confirm that this bug is fixed in gtk+3.0 version 3.18.9-1ubuntu3.3 from xenial-proposed. From my testing it affected each machine differently and thus was really hard to understand why freezing happened.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.18.9-1ubuntu3.3

---------------
gtk+3.0 (3.18.9-1ubuntu3.3) xenial; urgency=medium

  * Backport upstream patch to fix lagging and visual issues in Nautilus
    (toggled-not-clicked.patch, LP: #1562002).

 -- Dmitry Shachnev <email address hidden> Thu, 23 Mar 2017 22:44:18 +0300

Changed in gtk+3.0 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.