tracker for xorg-server 1.18 migration

Bug #1547510 reported by Timo Aaltonen
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
High
Unassigned
xorg-server (Ubuntu)
High
Timo Aaltonen

Bug Description

While testing new X I noticed that display scaling didn't work, and it was due to new randr-1.5 code. The GDK backend is buggy, running

python -c 'from gi.repository import Gdk;
   print(Gdk.Screen.get_default().get_monitor_plug_name(0))'

returns "None"

this is a blocker for the xserver update.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: rls-x-incoming
Changed in gtk:
status: Confirmed → In Progress
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Awesome that this is now fixed upstream! I've pushed a fixed package to the staging ppa:

ppa:canonical-x/x-staging

and will test it before Monday. I've also added a task for xorg-server to track the migration.

Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: New → Triaged
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

display scaling is fixed but nvidia prime still fails, guessing the bug is in u-d-c

summary: - display scaling doesn't work with xserver 1.18
+ tracker for xorg-server 1.18 migration
Changed in gtk:
status: In Progress → Fix Released
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.18.7-1ubuntu3

---------------
gtk+3.0 (3.18.7-1ubuntu3) xenial; urgency=medium

  * debian/patches/git_assistant_margins.patch:
    set gtkassistants margings to prevent the buttons from touching the edge
    (lp: #1547423)
  * debian/patches/git_xrandr15_output.patch:
    - X11, GdkScreen: properly implement init_randr15 including output name
      thanks Marco Trevisan (lp: #1547510)

 -- Sebastien Bacher <email address hidden> Mon, 22 Feb 2016 09:52:32 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

So the display scaling issue is fixed by new gtk upload, and the nvidia prime issue is fixed by a patch to xserver on the ppa.

These can move now.

no longer affects: ubuntu-drivers-common (Ubuntu)
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

and these drivers can be removed from the archive then:

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1541369

tags: added: xenial
Timo Aaltonen (tjaalton)
Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.