Windows flash black briefly before being drawn

Bug #1515561 reported by Iain Lane on 2015-11-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Low
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

Since 3.18, windows flash black for a split second before they are drawn. It's visually disruptive.

Iain Lane (laney) wrote :

Someone posted a video on the linked bug https://bugzilla.gnome.org/attachment.cgi?id=302400

tags: added: gtk318
Changed in gtk:
importance: Unknown → Low
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.18.5-1ubuntu1

---------------
gtk+3.0 (3.18.5-1ubuntu1) xenial; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    + Install the settings.ini file to set our themes.
    + Enable parallel builds
    + Ubuntu specific patches:
      - 073_treeview_almost_fixed.patch
      - 074_eventbox_scroll_mask.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind
      - 0001-calendar-always-emit-day-selected-once.patch
      - git_icon_fallback.patch
    + Add Breaks on gnome-shell << 3.16 - this needs to be updated at the same
      time.
    + Add Breaks on old overlay-scrollbar versions which still provided the gtk3
      module - we don't want to use this any more with GTK 3.16.

  [ Lars Uebernickel ]
  * Add debian/patches/0001-gtkwindow-continue-calling-gtk_style_context_set_bac.patch:
    - fixes black flickering when new windows are created (LP: #1515561)

gtk+3.0 (3.18.5-1) unstable; urgency=medium

  * New upstream stable release 3.18.5
    + GtkFileChooser:
      - Make sure external drives show up either in the sidebar or the places
        view
      - Ignore double-click events
    + Avoid some crashes in CSS parsing error handling

 -- Iain Lane <email address hidden> Tue, 17 Nov 2015 14:21:50 +0000

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
tags: added: xenial
removed: gtk318
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Khurshid Alam (khurshid-alam) wrote :

This bug may be related to bug #1518661. Because after the fix in this bug, it flashes white background and rounded corners in the CSD app are white (visible with Ambiance). The white flash effect is more pronounce if we open a large text file in gedit.

Changed in gtk:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.