Clicking a date to go back or forward a month causes repeated jumps between two dates

Bug #1480387 reported by Iain Lane on 2015-07-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+3.0 (Ubuntu)
High
Lars Karlitski

Bug Description

I asked in #ubuntu-desktop and people couldn't reproduce this in vivid or trusty. It happened for me in the most recent wily iso.

Open the indicator, click one of the greyed dates at the start or end of the month (sometimes requires more than one go). The active date starts to repeatedly jump between this date and another one. I ran with G_MESSAGES_DEBUG=all and when it's happening this is spammed (I clicked a date in 2015-05).

(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-30 00:00:00..2015-06-30 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed
(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-29 00:00:00..2015-06-29 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed
(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-30 00:00:00..2015-06-30 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed
(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-29 00:00:00..2015-06-29 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed
(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-30 00:00:00..2015-06-30 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed
(process:32382): Indicator-Datetime-DEBUG: PlannerMonth 0x2727310 setting calendar month range: [2015-05-01 00:00:00..2015-05-31 23:59:59]
(process:32382): Indicator-Datetime-DEBUG: 0x2728730 setting date range to [2015-05-29 00:00:00..2015-06-29 00:00:00]
(process:32382): Indicator-Datetime-DEBUG: rebuilding because the date range changed

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: indicator-datetime 13.10.0+15.10.20150728-0ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-2.2-generic 4.1.3
Uname: Linux 4.1.0-2-generic x86_64
ApportVersion: 2.18-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jul 31 17:09:43 2015
InstallationDate: Installed on 2012-10-07 (1026 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121007)
SourcePackage: indicator-datetime
UpgradeStatus: Upgraded to wily on 2013-05-07 (815 days ago)

Related branches

Iain Lane (laney) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) on 2015-10-01
affects: indicator-datetime (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Lars Uebernickel (larsu)
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.16.7-0ubuntu2

---------------
gtk+3.0 (3.16.7-0ubuntu2) wily; urgency=medium

  * Add debian/patches/calendar-always-emit-day-selected-once.patch:
    Fixes infintite loop between indicator-datetime and the panel (LP: #1480387)

 -- Lars Uebernickel <email address hidden> Tue, 06 Oct 2015 11:00:00 +0100

Changed in gtk+3.0 (Ubuntu):
status: In Progress → Fix Released
Changed in gtk:
status: Confirmed → Incomplete
Changed in gtk:
status: Incomplete → Expired
Changed in gtk:
status: Expired → Confirmed
Changed in gtk:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.