/usr/bin/shotwell:11:gtk_application_impl_handle_window_realize:gtk_window_realize:_g_closure_invoke_va:g_signal_emit_valist:g_signal_emit

Bug #1439026 reported by errors.ubuntu.com bug bridge on 2015-04-01
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Shotwell
Fix Released
Medium
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding shotwell. This problem was most recently seen with version 0.20.2-0ubuntu3, the problem page at https://errors.ubuntu.com/problem/faf6570a403688de1785ba9583b641e052e0bbe4 contains more details.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The issue started around marth 7, shotwell didn't change since january so likely a bug in gtk or glib

Changed in shotwell (Ubuntu):
importance: Undecided → High
Changed in shotwell (Ubuntu):
status: Confirmed → Triaged
Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Confirmed
affects: shotwell (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in shotwell:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.14.12-0ubuntu1

---------------
gtk+3.0 (3.14.12-0ubuntu1) vivid; urgency=medium

  * New upstream release 3.14.12, fixing bugs:
    + nautilus bookmarks changing places randomly
    + popover: Remove signal handlers in dispose
    + Fix unwanted transparency of drag icons
    + Revert "image: Optimize non-resize changes"
    + Avoid a crash in GtkApplication (LP: #1357791)
    + Avoid a crash with tree view rubberbanding
    + Make gtk-update-icon-cache more resilient
  * debian/patches/0001-GtkApplication-Prevent-more-crashes-around-shutdown.patch:
    Cherry-pick patch from the 3.14 branch to fix more crashes when shutting
    down GtkApplications. (LP: #1439026)
 -- Iain Lane <email address hidden> Fri, 10 Apr 2015 13:20:36 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.