menu to select zoom doesn't drop down

Bug #1383486 reported by Lyn Perrine on 2014-10-20
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
High
Allison Lortie
Utopic
High
Unassigned

Bug Description

* Impact
The new gtk popover menus are not displayed in some cases

* Test case
- log into a desktop environment showing menubars locally (gnome classic, xfce, kde, ...)
- run evince
- click on the zoom entry arrow
-> the menu should display

* Regression potential
check that widgets in gtk applications are still correctly placed on screen

--------------

To reproduce open a pdf file in evince from pcmanfm or another file manager. Then move the mouse to the upper right corner of the window along the top bar. Then try to click on the arrow pointing down to drop down the menu. The mouse pointer will click but no menu will drop down. I can still edit the zoom by clickin in this bar but I cannoy select fit page or fit width like I used to be able to in 14.04. I am using lxde as my desktop environment with openbox as my window manager.

evince:
  Installed: 3.14.1-0ubuntu1
  Candidate: 3.14.1-0ubuntu1
  Version table:
 *** 3.14.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu 14.10
Release: 14.10
I expected a menu to be able to choose zoom instead I can only change zoom by typing in the box.

Work around is to manually set a zoom by typing it in. This could lead to some accessibility problems for people with low vision if they need to zoom in on a pdf and don't know the workaround.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: evince 3.14.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic x86_64
ApportVersion: 2.14.7-0ubuntu7
Architecture: amd64
CurrentDesktop: LXDE
Date: Mon Oct 20 14:08:31 2014
InstallationDate: Installed on 2014-09-30 (19 days ago)
InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140930)
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Lyn Perrine (walterorlin) wrote :

I am also able to reproduce this in xfce.

Elfy (elfy) wrote :

confirmed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

"I expected a menu to be able to choose zoom instead I can only change zoom by typing in the box."

ctrl + mouse wheel zooms in and out here

Lyn Perrine (walterorlin) wrote :

I can confirm the ctrl+ mousewheel alternate workaround works as well. Sorry didn't try that.

Brian Murray (brian-murray) wrote :

The drop down appears using an Ubuntu Desktop environment e.g. unity.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1383486

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

That seems like a gtk issue, the popover widget doesn't work when a menubar is displayed

Changed in evince (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → High
Allison Lortie (desrt) wrote :

This was fixed upstream here: https://git.gnome.org/browse/gtk+/commit/?id=a1af365566161067c4eb246a1c66e7914f119537

Unfortunately this doesn't backport cleanly. I'll try to rebase the patch.

Allison Lortie (desrt) wrote :

It will work if we also take 0dcffe3cd421555926e74002d5297d6dac0886e7, which is another bugfix that may be worth having.

Allison Lortie (desrt) wrote :

Both have been pushed upstream on gtk-3-12 branch.

affects: evince (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
assignee: Lars Uebernickel (larsu) → Ryan Lortie (desrt)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.12.2-0ubuntu16

---------------
gtk+3.0 (3.12.2-0ubuntu16) vivid; urgency=medium

  * debian/patches/git_popover_position.patch,
    debian/patches/git_popover_display.patch:
    - correctly display gtkpopover widgets, thanks Ryan Lorties for
      backporting the fixes (lp: #1383486)
 -- Sebastien Bacher <email address hidden> Tue, 28 Oct 2014 18:23:29 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Iain Lane (laney) wrote :

We should SRU this too

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu Utopic):
status: New → Confirmed
Iain Lane (laney) wrote :

The popovers work for me in vivid, seems the patches are good

Sebastien Bacher (seb128) wrote :

Thanks Iain, uploaded to trusty as well

Changed in gtk+3.0 (Ubuntu Utopic):
importance: Undecided → High
status: Confirmed → In Progress
description: updated

Hello Brendan, or anyone else affected,

Accepted gtk+3.0 into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtk+3.0/3.12.2-0ubuntu15.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Lyn Perrine (walterorlin) wrote :

I can confirm that in lubuntu with
libgtk-3-0:
  Installed: 3.12.2-0ubuntu15.1
  Candidate: 3.12.2-0ubuntu15.1
  Version table:
 *** 3.12.2-0ubuntu15.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.12.2-0ubuntu15 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
The popover widgets in evince work perfectly.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.12.2-0ubuntu15.1

---------------
gtk+3.0 (3.12.2-0ubuntu15.1) utopic; urgency=medium

  * debian/patches/git_popover_position.patch,
    debian/patches/git_popover_display.patch:
    - correctly display gtkpopover widgets, thanks Ryan Lorties for
      backporting the fixes (lp: #1383486)
 -- Sebastien Bacher <email address hidden> Tue, 28 Oct 2014 18:23:29 +0100

Changed in gtk+3.0 (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers