software-properties-gtk crashed with SIGSEGV in gtk_application_impl_active_window_changed()

Bug #1357791 reported by Anders Pamdal on 2014-08-16
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

...

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: software-properties-gtk 0.92.37.1
ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
Uname: Linux 3.16.0-9-generic x86_64
ApportVersion: 2.14.5-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Aug 16 22:47:01 2014
ExecutablePath: /usr/bin/software-properties-gtk
InstallationDate: Installed on 2014-03-04 (165 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/software-properties-gtk --open-tab 2 --toplevel 75497479
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=sv
 XDG_RUNTIME_DIR=<set>
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f52596d2f30: mov (%rdi),%rax
 PC (0x7f52596d2f30) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: software-properties
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: software-properties-gtk crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to utopic on 2014-08-16 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Anders Pamdal (anders-pamdal) wrote :
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
summary: - software-properties-gtk crashed with SIGSEGV in g_closure_invoke()
+ software-properties-gtk crashed with SIGSEGV in
+ gtk_application_impl_active_window_changed()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
information type: Private → Public
tags: added: vivid
Changed in software-properties (Ubuntu):
importance: Medium → High
Iain Lane (laney) on 2015-04-10
affects: software-properties (Ubuntu) → gtk+3.0 (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.14.12-0ubuntu1

---------------
gtk+3.0 (3.14.12-0ubuntu1) vivid; urgency=medium

  * New upstream release 3.14.12, fixing bugs:
    + nautilus bookmarks changing places randomly
    + popover: Remove signal handlers in dispose
    + Fix unwanted transparency of drag icons
    + Revert "image: Optimize non-resize changes"
    + Avoid a crash in GtkApplication (LP: #1357791)
    + Avoid a crash with tree view rubberbanding
    + Make gtk-update-icon-cache more resilient
  * debian/patches/0001-GtkApplication-Prevent-more-crashes-around-shutdown.patch:
    Cherry-pick patch from the 3.14 branch to fix more crashes when shutting
    down GtkApplications. (LP: #1439026)
 -- Iain Lane <email address hidden> Fri, 10 Apr 2015 13:20:36 +0100

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers