separator-size.ui test fails on build

Bug #1339495 reported by Robert Ancell on 2014-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
High
Lars Karlitski

Bug Description

When building from lp:~ubuntu-desktop/gtk/ubuntugtk3 the following test fails:

/home/bob/bzr/ubuntu/build-area/gtk+3.0-3.12.2/testsuite/reftests/separator-size.ui: FAIL

This appear to be due to the test case being incorrectly rendered under the Ambience theme.

Related branches

Robert Ancell (robert-ancell) wrote :

This does not occur when using Radiance

Robert Ancell (robert-ancell) wrote :

Seems to be caused by GtkWidget-wide-separators: true; in /usr/share/themes/Ambiance/gtk-3.0/gtk-widgets.css. This is not set in Radiance.

Robert Ancell (robert-ancell) wrote :

This value was set in saucy due to bug 1181661

Robert Ancell (robert-ancell) wrote :

My guess is the wide-separator code got broken at some point, perhaps on the migration to 3.12?

Changed in gtk+3.0 (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.12.2-0ubuntu6

---------------
gtk+3.0 (3.12.2-0ubuntu6) utopic; urgency=medium

  * debian/control.in, debian/libgtk-3-0.symbols, debian/rules:
    - enable the mir backends only on architectures where mir is built
 -- Sebastien Bacher <email address hidden> Wed, 30 Jul 2014 19:08:26 +0200

Changed in gtk+3.0 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers