gtkpopover widgets not rendered

Bug #1329792 reported by Pojar Gheorghe–Ioan on 2014-06-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
High
Lars Karlitski
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

After Utopic update to use gtk+ 3.12, GtkVolumeButton do not let to use volume pops up control. I can change volume only if mouse cursor is over volume icon and I use mouse scroll wheel.

You can reproduce this in totem and rhythmbox by clicking in volume icon and try to move up or down volume control slider that show's up.

Related branches

summary: - GtkVolumeButton do not let to change volume
+ GtkVolumeButton do not let me to change volume
tags: added: utopic

Thanks for the bug! It happens because Ubuntu's themes don't set background colors for popovers, which makes them transparent and causes them to get input events.

Changed in gtk+3.0 (Ubuntu):
status: New → In Progress
assignee: nobody → Lars Uebernickel (larsu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
summary: - GtkVolumeButton do not let me to change volume
+ gtkpopover widgets not rendered
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.12.2-0ubuntu4

---------------
gtk+3.0 (3.12.2-0ubuntu4) utopic; urgency=medium

  * debian/patches/git-gtkpopover-set-background-and-popover-css.patch
    - backport from master (lp: #1329792, gnome: #731834)
 -- Lars Uebernickel <email address hidden> Wed, 18 Jun 2014 17:32:26 +0200

Changed in gtk+3.0 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+14.10.20140619-0ubuntu1

---------------
ubuntu-themes (14.04+14.10.20140619-0ubuntu1) utopic; urgency=low

  [ Robert Ancell ]
  * Make ubuntu-mobile inherit from the Humanity / gnome themes. In the
    Unity 8 desktop session some applications refer to icons in these
    themes and this causes Unity 8 not to show an icon for them.

  [ Lars Uebernickel ]
  * Add preliminary support for popovers Add borders and shadow for the
    .popover class. Also set the background color for the .background
    class instead of on GtkWindow directly, because GtkPopover sets
    .background as well. (LP: #1329792)
 -- Ubuntu daily release <email address hidden> Thu, 19 Jun 2014 09:07:31 +0000

Changed in ubuntu-themes (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers