libgtk2.0-dev is not multiarch-ready

Bug #1317116 reported by Levi Bard on 2014-05-07
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Debian)
Fix Released
Unknown
gtk+2.0 (Ubuntu)
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

This means that if I want to compile a Gtk+ program for x86 on an amd64 machine, I need to install libgtk2.0-0:i386 and then manually symlink: libgtk-x11-2.0.so libgdk-x11-2.0.so libatk-1.0.so libgio-2.0.so libpangoft2-1.0.so libpangocairo-1.0.so libcairo.so libpango-1.0.so libgobject-2.0.so libglib-2.0.so in /usr/lib/i386-linux-gnu

$ sudo apt-get install libgtk2.0-dev:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev:i386 : Depends: gir1.2-gtk-2.0:i386 (= 2.24.23-0ubuntu1) but it is not going to be installed
                      Depends: libgdk-pixbuf2.0-dev:i386 (>= 2.21.0) but it is not going to be installed
                      Depends: libpango1.0-dev:i386 (>= 1.20) but it is not going to be installed
                      Depends: libatk1.0-dev:i386 (>= 1.29.2) but it is not going to be installed
                      Recommends: python:i386 (>= 2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libgtk2.0-dev 2.24.23-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Wed May 7 16:17:56 2014
InstallationDate: Installed on 2011-05-11 (1091 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: gtk+2.0
UpgradeStatus: Upgraded to trusty on 2014-04-22 (15 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+2.0 (Debian):
status: Unknown → New

I'm also seeing this problem on Ubuntu 14.04 for the Parallella, because of it I'm unable to compile Boinc Manager:

linaro-nano:~> sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've fixed my problem, i've added trusty-updates to the sources.list in /etc/apt
the image i used didn't have it as standard.

Olivier Tilloy (osomon) wrote :

Same problem with gtk3:

$ sudo apt install libgtk-3-dev:amd64 libgtk-3-dev:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgtk-3-dev is already the newest version (3.22.28-1ubuntu3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev:i386 : Depends: libgdk-pixbuf2.0-dev:i386 (>= 2.30.0) but it is not going to be installed
                     Depends: libpango1.0-dev:i386 (>= 1.40.5) but it is not going to be installed
                     Depends: libegl1-mesa-dev:i386 but it is not going to be installed
                     Depends: libxkbcommon-dev:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Changed in gtk+2.0 (Debian):
status: New → Fix Committed
Changed in gtk+2.0 (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.