ubiquity / mythbuntu assertion in gtkrecentmanager.c

Bug #1306341 reported by Dimitri John Ledkov on 2014-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned
mythbuntu-common (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
High
Dimitri John Ledkov

Bug Description

Upon loading a .ui file which uses file-chooser-button, under a weird environment:
- pkexeced, gui_allowed, with PWD not writable

The following assertion happens:

(ubiquity:4803): Pango-WARNING **: error opening config file '/root/.config/pango/pangorc': Permission denied

(ubiquity:4803): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed

(ubiquity:4803): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed

(ubiquity:4803): Gtk-CRITICAL **: Unable to create user data directory '/root/.local/share' for storing the recently used files list: Permission denied
**
Gtk:ERROR:/build/buildd/gtk+3.0-3.10.8/./gtk/gtkrecentmanager.c:617:gtk_recent_manager_set_filename: assertion failed: (priv->filename != NULL)

Which core-dumps ubiquity.

Related branches

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Changed in mythbuntu-common (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.18.2

---------------
ubiquity (2.18.2) trusty; urgency=medium

  * Set HOME, because without HOME GtkBuilder upon seeing a FileChooser
    button in the ui file and trying to initialise object for it throws a
    hizzy fit and aborts on an assert, if per-default it's meant to open
    present working directory and it happens to be inaccessible one like
    /root/. (LP: #1306341). This resolves launching Mythubuntu installer
    in a live session using pkexec, back in 12.04 gksudo/sudo was used
    instead.
 -- Dimitri John Ledkov <email address hidden> Fri, 11 Apr 2014 05:18:42 +0100

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers