Initial window size slightly too small causing scaling+smoothing on image

Bug #1247564 reported by Øyvind Stegard on 2013-11-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

When opening an image that is "medium sized", but still much smaller than screen resolution, eog sizes its window initially slightly too small, causing scaling and consequently smoothing to be applied to the image. This makes "crisp" images like figures, diagrams etc. look unnecessarily blurred (and bad) at first sight. Increasing eog window size a little fixes it so that the image is displayed 1:1 (pixel perfect). Pressing Ctrl+0 also fixes the initial sizing of the image.

I see no way to turn off "Best fit" option by default in prefs. That would probably fix it for smaller images, but is unpractical for larger ones, where scaling is desireable.

Attached source image and screenshot of initial eog window (untouched) shows the problem. My screen resolution is 1920x1200 and the source image is 640x480, so it should not have been scaled by eog on first display.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: eog 3.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Sun Nov 3 11:47:00 2013
InstallationDate: Installed on 2013-11-01 (1 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: eog
UpgradeStatus: No upgrade log present (probably fresh install)

Øyvind Stegard (oyvinst) wrote :
Øyvind Stegard (oyvinst) wrote :

Original source image that makes scaling easily visible.

summary: - Initial window height slightly too small causing scaling+smoothing on
+ Initial window size slightly too small causing scaling+smoothing on
image
Øyvind Stegard (oyvinst) wrote :

Also happens on 1920x1080 sized screen.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report and for upstreaming it

Changed in eog (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in eog:
importance: Unknown → Medium
status: Unknown → Confirmed
Brandon Snider (brandonsnider) wrote :

OK, this bug was fixed upstream, but it was determined to be a problem with gtk+, not EOG. So, I have created a debdiff for Saucy's gtk+3.0 package.

Here is the upstream location of the patch: https://bug719595.bugzilla-attachments.gnome.org/attachment.cgi?id=263201

This patch will also have to be added to Trusty.

The attachment "debdiff to fix this bug" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
affects: eog (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Triaged
Changed in eog:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.10.6-0ubuntu2

---------------
gtk+3.0 (3.10.6-0ubuntu2) trusty; urgency=low

  * debian/tests/build: update to not use gtkstock which is deprecated,
    the warning is making the autopkgtest unhappy
 -- Sebastien Bacher <email address hidden> Wed, 11 Dec 2013 10:52:41 +0100

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
Øyvind Stegard (oyvinst) wrote :

This is supposedly fixed upstream, but bug is still present for Ubuntu 14.04.

pabouk (pabouk) wrote :

Was this bug really fixed in Ubuntu? As Øyvind Stegard wrote the same bug is still present in Ubuntu 14.04.

With the default theme (Ambiance, and Radiance too) the window height is 2 pixels smaller than necessary for the correct pixel to pixel display. When the theme is changed to High Contrast or the toolbar in EOG is disabled the bug does not show.

14.04 contains GTK+ 3.10.8 and the resolution from https://bugzilla.gnome.org/show_bug.cgi?id=719595 was released with GTK+ 3.10.6. In the source I see that the change from the patch is still there.

Should this bug be re-opened? How to mark that the problem is not resolved in 14.04?

There is also a new bug report specific to 14.04:
https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1296487
Should it be marked as a duplicate of this one?

pabouk (pabouk) wrote :

There is also an old resolved bug #231385 from 2008 with a similar effect but probably a different cause.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.